Parts of the touchscreen don't work - See first post for troubleshooting

In order to access the support pages, you’ll need to register there first. It’s not the same login as for the shop or the forum.

I’ve moved your post to a topic where the same issue is being discussed, in case you want some background.
If you start a request via, it should set up an account as part of the process. If that doesn’t work, there’s the option of calling them - the details are at nearly the very bottom of the page with the support request form (above the grey banner).

Same problem here: I’ve got 3 “rows” on the touchscreen that are dead. It all suddenly started like a week or so ago with the touchscreen going wild (lots of random “touches”). That problem away after ~2days, but now those 3 rows on the screen stay dead. Already tried setting touch & hold delay to different value, but that doesn’t do anything.
I contacted support today, let’s see what will happen, but anyway I’m prepared to send in my phone. :slight_smile:

Is this a hardware problem for sure? I joined the club like 2 weeks ago: stripe on the very left does not work, I get the same type of doodle images mentioned earlier in this thread, and also the random touches etc.
However, there are times when the whole screen works again, which makes me wonder if it’s really failing hardware.

Is there someone having this exact problem using a different operating system, e.g., sailfish?
I would try that, but unfortunately I depend on two sim cards and a bunch of android apps…

AS no alternative OSes were available at that time I didn’t check with an different OS. But also in my case the issue was gone temporarily - but unfortunately returned again quite soon.
FP support exchanged the screen directly after I had sent in the phone. Since then (i.e. with the new screen) the problem is gone. So IMO this is a real strong hint that at least the defective screen area is really a hardware issue. I cannot comment on the crazy touch input topic because I wasn’t affected by that one.

I have the same issue: Part of my screen (vertical bande) stopped responding. It started on the right edge not long after that I received my FP2 but I was managing to work around it. But lately a new band of the screen stopped responding as well which makes it harder to use (see picture screen test).

This problem is not influence by the setting of “touch & hold delay” and is constant with time.

Hello, I can’t touch the left side of the screen, which is reeealy anoying. Can anyone help? Can you re-calibrate the touchscreen? Or what should I do anyway?

I had the same issue. After writing a ticket, I called FP support. They were very friendly and helpful. The dead touch areas seem to be a well known issue to them. By the time I called (little over a week ago) they were unsure whether the screen or the connector between screen an main PCB causes the issues. For that reason, they would not just send me a new screen, but that may have changed now.
After calling support, they sent me instructions to return the phone. I turned it in, and the repair center replaced the screen and sent the phone back in just one week.
I have had no further issues with the screen since then.

@Alex.b, I suggest you

  • write a ticket here:
  • call FP support some days after, if you havent heard back until then: Mon & Tues 10:30 - 18:30 and Wed-Fri 9:30 - 17:30 at +31 (0)20-788 4400.
  • follow the instruction for turning in your phone.

My FP2 is currently exhibiting the following problem with the keyboard. Persistently I cannot type an ‘8’ or an ‘i’. For instance if I try to type ‘8’ I get one of the following options: a single ‘7’, a single ‘9’ or (and this is most of the times) I get ‘7’ and ‘9’ both together for a single finger tipping on the touchscreen.

There seems to be workaround (not very enjoyable) by me going from portrait to landscape. In landscape I can easily and reproducible press an ‘8’ or an ‘i’. However, when you want to enter a password for a Wifi, this workaround does not work as the this window does not change orientation when turning the phone. So, for months I have not been able to log into any Wifi which required an ‘i’ or ‘8’ for the password.

After software update to v1.2.8 the problem got worse and I am now not able to press the blank key when the phone is in landscape or the number-selector key when I am in portrait.

So, more I less shiny, expensive, 2 months old phone is more or less useless, because I cannot input phone numbers anymore nor write emails or texts which include mundane letters like ‘i’, numbers like ‘8’ or more than one word (since I do not get blanks anymore).

Does anybody have the same problem? Does anybody know a fix or can give advice how I can make my FP2 usable again?


I have the same issue, but with letter “r”. theres a line, which goes vertically through the letter “r”. in this line, my fairphone got two touch points. at the left border, my touchscreen doesn’t work at all.
I try a factory reset - without success. I contacted support, but i didn’t get an answer yet.

I didn’t have much hope in this potential fix, so I didn’t try this till today, but I took my phone apart, at least just took the screen off and put it back again, and my problem has gone away! I will see for how long. I doubt it will work for everyone, but it’s worth a try if you haven’t tried it yet.

1 Like

Same problem here, didnt contact the support yet, but changing the delay had no effect so far…

Same problem here: unable to type r, f or c, getting double neighboring letters on the keypad instead. Amazingly still reasonably functional with auto correct and some creative avoiding of words…

Ticket submitted three weeks ago, no response yet apart from auto response that the team is very busy and it might take a while. Time to make a phone call I guess… Let’s hope this issue doesn’t affect the fairphone business too much. Still waiting for the fairpad etc…

Support ticket opened for the same problem. I hope this won’t hit all FP screens otherwise our delays to have an answer from the support team would stretch out…

My fix worked for less than 24 hours! Hopes raised -> dashed.

It is interesting to see that the screen itself could work again, which means it’s more likely the communication from screen to mainframe going wrong (e.g the pogo pins)


Cleaning the pins and the contact area with pure alcohol before reassembly may probably help.

Hi all,

I’m having some issues with my FP2 since yesterday. Since then the touch screen does not allow me to type the letter [i] when held vertically and instead types [o]+[u], similarly it does no longer allow me to type the letters [q] or [a] (I am using an English UK keyboard).

Due to the location of the unresponsive parts of the screen I am also not able to accept incoming calls.

I have tried to change the settings of “Touch and delay” but to no effect. I was also unable to enter the Factory mode to see if this was a hard– or a software issue; all the information I could find on the matter was for the FP1.

It may be relevant to note that my FP2 also does not allow me to hang up 75% of the time, unless I keep the phone on speaker. I have thus as of 5minutes ago changed the settings to be able to hang up with the power button.

Finally, as far as hardware is concerned the FP2 has not been experiencing anything out of the ordinary in the last week – i.e. it was not dropped on a hard surface or in any liquids. I am in the Colombian Amazon right now but I do not think that the generally high level of humidity is at cause as this FP2 has already been through rougher patches in that regard.

I moved your post here as you describe the same issue.

Hard Reset works the same on FP2 as on FP1 except Power is used to select instead of Volume Up.

I am having this Problem since the last update. I am very sure it wasn’t there before.

same issue here,
there is an area on the left side of screen which doesn’t react since i made the update to 1.3.6:

any advice?