Official LineageOS is here!

That’s life. So, here it comes as a warning and help for users of the feature “adoptable storage”:

My SD card and with it the adopted storage wasn’t recognized anymore after using the Lineage Updater to install this update (20171121).
Before the update I had the nightly from 20171114, which was a fresh install (wiped everything before).

Because some apps and it’s files are stored on the SD card part of the adopted storage, I got an error message from AFWall+ directly after the reboot, saying it’s not working correctly. Maybe the custom scripts weren’t available.

Seemed worst case and I thought about going back with the TWRP backup I made before updating.
But I gave it one more chance and tried solving it with a restart (exactly a shutdown and manual start). And it worked, so the SD card is recognized again and AFWall+ still has it’s custom scripts without the need of configuring something from my side.

A big THANK YOU for your effort @chrmhoffmann and all, who are involved!
You compete with multi billion dollar companies not only to give the users a working smartphone, but giving them freedom and control over their data back!

Some background information:
I switched to LineageOS a few days ago coming from FPOOS 17.10, because of the same problems as @Smojo had. As I anyway had to wipe everything to solve the problems, I wanted to give Lineage OS a try.
Time will show, if I can have Android free of Google, without spending hours or even days just to manage the updates, as I had every time with FPOOS and Xprivacy to be sure, not to make a mistake and have a backup of everything for the worst case.


Awesome, since when does LOS contain the proximity sensor tool? I just saw it.
I can’t really test it as I don’t have any issues but if this works that will make some people really happy.


I saw it appear in the last release, the past tuesday, 2017-11-21. It was a good surprise! And it worked flawlessly for me, :hugging:

Specific commit is here:


ohhhh thx :slight_smile: i also think that this is a bug :slight_smile::grinning:

Is there a way we can donate to the project (the port)? I’ve been so happy with LOS that I feel a donation is appropriate.


Donate to the red cross.




Just to confirm the good job with this port for FP2:

I found more people using the adopted storage on standard Android (not Lineage OS) and having to restart their phones every few days for the storage to be found again.
So it seems to be a general issue to be fixed upstream on Android.

As my last nightly update was only 4 days after flashing Lineage OS and using this adoptable storage feature for the first time, the issue has most likely nothing to do with Lineage OS or this port for FP2.
Maybe it also depends on the SD card model. I’m using a 64 GB SanDisk Ultra Class 10 card.

If adopted storage refers to bundling SD cards as one device transparently, try a different SD card. Generally speaking I’ve had crap like that happening more often or solely on smartphones when it was cold outside.

Hi Paula, where did you find the tool? I can’t find it?

Latest LOS Build
Thanks for helping…

In the list of installed apps. :wink:

1 Like

Ah, thanks I found it, but am I too stupid to open it to calibrate? I always get problems with the sensor using WhatsApp

OK, stupid me. I got it working.


Update installed via TWRP 3.1.1-2

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module)
  • selfie camera (new module)
  • USB connection to PC / MTP
  • alarm (incl. swiping it off)
  • MyPhoneExplorer
  • root

For things that might not work there’s a bugtracker.

So you’re not stupid. You tried and you succeeded :wink:


I am unable to install LineageOs 14.1 official on my Fairphone 2 (Model n° FP2, Build n° FP2-gms-17.11.2 release-keys) using TWRP 3.1.1-2. Wipe done, factory reset tried, always the same error: “twrp can’t install this package on top of incompatible data” Thanks everybody for your help.

Lineage 20171128, opengapps-nano 20171127
I’m having some more battery useAge while using the phone. I have the impression that cpu runs on higher frequency and more cores are active. Phone also feels warmer. Anyone else also, or did i manage some misconfiguration?

Can’t say I noticed anything in that direction, I have OpenGApps pico though.
But then again I accept certain battery usage when I actively use the phone and didn’t optimize much, and I have a flip case around the phone, so I only notice warmth when I test calling functionality after an update, because then my ear feels it :slight_smile:

Also … be aware of the different performance profiles you can set …

1 Like

I don’t know where it came from, but even before updating and without running a special app I experienced yesterday a battery drop of 30 percent within maybe 20 min…

1 Like

This topic has become a bucket for many different issues.
We encourage you to start a separate thread for each issue.