Official LineageOS 20 FP4

I hope that it can help to have this issue solved.

If someone understand how to reproduce it, please share it to add the information to the ticked

Not worked for me. Was running A13 iode with security updates of March updated to FPOS12 with March security and cannot lock. So someone at FP needs to get things straight. My only other thought is the custom key that gets added by iode at the beginning. If FPOS doesn’t delete this then I’ll delete and see what happens!!

You have to delete the Iode custom keys before manually installing FPOS again, at least it was the case in the past.

Thanks for your quick reply. My plan is to revert fully to stock and relock. Was impatient for A12 so played around with LOS 20 and then flitted between Calyx and iode. I just want to reset to stock and lock now, so hopefully the steps you’ve given me will now successfully do this :+1:

Doesn’t work and the 2nd command that disables verity needed an extra command on the end which was flash vbmeta vbmeta.img It seems that Calyx and iode know how to be able to lock the bootloader it’s just a pity that FP don’t.

Hi folks!

Has anyone successfully used the new Android 12 binaries to build LineageOS?
As far as I understand, there are some files missing that were present in Android 11.


Hi y’all,

I am running LOS and I noticed that the call volume is always very high. The volume control does not seem to have any effect and it appears to be always at maximum volume. Do more people experience this? And where would I report such an issue?

I’ve noticed the same thing with my volume. If you want to report it, you probably need to open a bug report with Lineage.

See FP4: cannot change call volume (#5763) · Issues · LineageOS / issues / android · GitLab

I noticed that the Messages app that comes with LOS 20 does not include a feature to search through messages. What other apps are people using for SMS/MMS on LOS20 that support searching? (And will handle unencrypted sms/mms – I’ve read that support for unencrypted sms/mms has at least been deprecated from Signal if it is not already removed)

You could give QKSMS a try:


Hello there,
I just bought a FP4 and I’m thinking about installing

I’ve done it a few times on FP2 without any issues, but still I like to read forums before jumping. And I see many people have bricked their FP4 at the step where they re-lock the bootloader after installing a custom ROM.

So I thought I’d ask a few questions before trying my luck as I really can’t afford bricking my phone. And if there’s not a zero risk path then I might simply not follow through.

  • How important is it to lock the bootloader?
  • At the moment, I’m on Android 11 with latest security patch from Jan. 5th 2023. Is is safe to use the image here which looks from Apr. 10th?
  • Should I use the recovery from available in that same repo or something else?

Thanks for your dear help :slight_smile:

If you plan on installing LOS and want to lock your bootloader you’ll have to build your own images, that’s not supported by default.

Large parts of the Android security model rely on a locked bootloader and there are apps that won’t run if it’s unlocked.

There are several other ROMs (/e/OS, DivestOS, CalyxOS, iodéOS) that will let you lock your bootloader, but whatever you do check that fastboot flashing get_unlock_ability returns 1 right before you lock it!

Oh and welcome to the community BTW :wave:


Did anyone experience Dual SIM issues or (dual) WLAN Call issues?
Specially Telekom.

Have problems with that and hope LOS could be a solution.

@rca Just installed the most recent Lineage for Microg. Happy to report that I seem to no longer have the issue with needing to toggle the speaker phone button after a reboot in order for people to hear me on a call.


@2allseew Thanks for the update - that is fantastic to hear! I will try to install the update this coming weekend.

Yes, you should be safe regarding the security-patch-downgrade issue if you go with e.g. lineage-20.0-20230604-microG-FP4 - but still: always check fastboot flashing get_unlock_ability as mentioned by @hirnsushi :slight_smile:
If you are interrested in some advanced features as e.g. an system-integrated adblocker then take a look at iodéOS. It’s basically LineageOS+microG+Adblocker and some other cool features, advanced privacy (german article) and so on :slight_smile:

Always go with the recovery provided by the OS devs (LOS4microG, iodéOS…)

is there any way to get aptx working again, or maybe install lhdc. tried magisk, but cant seem to get them working. seems a bit of a waste to use sbc or aac when my headphones support propper codecs. seems to be an issue in the stock rom as well.

Following up from the post by @2allseew on 6/5, I had a chance to update to the 6/4/2023 build of LOS 20 about a week ago, and I wanted to confirm that with that build I also no longer experience the audio glitch that we’ve been discussing, and this is true for both my FP4 and another belonging to a family member. To be clear, now, with the 6/4/2023 build, after the phone is powered-on/rebooted, the audio just works as expected during calls. It is no longer necessary to toggle speakerphone on/off the first time a call is made/received following a reboot to get the outgoing audio to start working. I will plan to mark this issue as resolved in the LOS bugtracker.

At this point, I feel like I can say that my FP4 with LOS 20 is doing everything I need it to do, and doing it well. I have been using my FP4 with LOS 20 (and MindTheGapps) in the USA (Boston, MA area) on the Mint mobile network (T-Mobile MVNO) for just over 5 months now, since 1/15/2023. On a day-to-day basis the phone just works. There are a few very minor annoyances, most of which are rather infrequent, and some of which may be due to the network rather than the phone, but overall I would not hesitate to recommend the phone to a user in the US provided that they install LOS 20 (or another OS that allows LTE to work on the US networks (unlike the factory OS)


opened a issue.