Official LineageOS 20 FP4

Hey! Just a few months later and now there is an official LineageOS 20 for FP4. I’m using it for a few weeks now and I just have some quality issues but no essentials for me.

-the NFC stops working after some time, you have to switch off/on again

-the camera is limited to 12MP

-USB headphones doesn’t work

My banking app works well which surprises me cause I read from other OS’ that safetyNet is not supported. On the other hand it seems my banking app lacks safety.

Does anyone using LOSofficial experience same issues or has a solution for mine? Your welcome to keep this thread alive!

Whoops, initially this was meant to get postet under the Help topic.

This is not a specific LOS issue. We have been waiting for Fairphone to provide this capability for third party apps for about a year now. In the first post of Camera & Camera2 API - missing features & bugs all problems regarding third party camera apps are mentioned. E.G.:

Maybe this is the problem and Fairphone has to solve it:

This applies to stock ROM as well as all custom ROMs. CalyxOS has developed a patch that bypasses the SYSTEM_CAMERA permission check. This has also been adopted in LOS and iodéOS. Therefore, thanks to Calyx, at least the wide-angle camera now works. But all other problems seem to persist. Fairphone has unfortunately given up working on solutions for this in the meantime. Only with a lot of luck will they find the time and energy to work on it again sometime in the future:


I’ve been using LOS for a while now, and I seem to recall the FP4 being able to switch to the wifi signal automatically.

Now on LOS, this doesn’t really seem to happen unless you completely lost the weakest wifi signal.
I have a wifi repeater in my house, since the signal gets really bad upstairs, but I always have to manually switch wifi even though the wifi indicator clearly shows its weak.

Worst, when opening the wifi settings while already connected to a router, it generally takes about 30 seconds, sometimes more to display the wifi list and allow me to switch.

Now I’m not sure how this behaved on FPOS but I don’t recall this process to be that painful. Anyone else having similar issue?

my february build can be downloaded here: Index of /stuff/fp4 , built again without RELAX_USES_LIBRARY_CHECK=true. Since LineageOS for microG now offers images as well (, this will be the last build I am offering unless someone speaks up.

Hello, I am using lineageos 20 on my fairphone 4 and I’m very happy with it.
But I bought the Fairphone 4, because of the HDMI USB C port.
Now I bought the ViewSonic TD1655 portable display with touch.
When I connect my phone with the monitor, the touch function is rotated 90°. So when I swipe left to right, it swipes top to bottom.
If I choose desktop mode in developer options it works fine. However, I think the standard environment is perfect for me. maybe that can be changed?

Thank you for your help

@rca I can report that I’m having the same issue on my brand new FP4 using lineage. My first call, yesterday, was using my BT integrated car audio system and it worked fine – so I thought I wasn’t having the issue. However, this morning I made a call with my handset and the person receiving the call couldn’t hear anything. Toggling the speaker phone setting worked, just as you reported. I’ll add a comment to your bug report. Hopefully an extra comment will generate some developer interest.

@2allseew Thanks for sharing that info here and also for commenting on the bug report. I’m sorry to hear that you’re also having the problem, but also relieved that I’m not alone and hopeful that additional reports will increase the visibility of the issue and the likelihood that it gets attention and gets fixed soon, as you said.

Hi, do you guys know how the install of Lineage for microG from works? I always did it like the normal lineage install but now I found a boot image in the folder for the fairphone and there is no description how that’s supposed to be used

1 Like

You don’t really need to use the boot image, unless you want to patch it with Magisk for rooting. In a new Lineage or (Lineage for Microg) installation, all you really need are the main zip and the recovery zip. The basic installation steps are the same for both Lineage and Lineage for Microg. Where they differ are people installing Lineage may also plan to install Gapps.

1 Like

Ah, alright, thanks :smiley:

How fresh are security updates of LOS on FP4?

I’m running Lineage OS for Microg which uses the Lineage OS code. I’m currently running a Lineage 4 Microg rom that was built on March 8th, 2023. That build has the February 5th Android security updates and the January 5th FP vendor security updates.

How do you know that? I mean, where can I find info about specific version both of Android and vendor security updates that particular LOS release has?

Settings → About phone → Android version → Android security update



I managed to install plain LineageOS (noticed the microg builds only afterwards, sigh. Already done the work to get F-Droid privileged extension working, not going to re-do it now).

I would like to re-lock the bootloader to get my phone into a secure state that I can use for the next 5 Years without having to do any hackeroonies. However the phone refuses to boot into LineageOS and I have to unlock the bootloader again to fix this. Is there any known fix? If not, do you think this will be fixed at some point in the near future?


Welcome the community :wave:

I’ve moved your post to this existing topic, relocking has been discussed before.

TL;DR: Not supported by default, you’d have to build it yourself.
You might want to consider one of the relockable options (iodéOS, CalyxOS, /e/OS, DivestOS) before you do that :slightly_smiling_face:


That’s an argument yes. I’d like to stay as vanilla as possible. Set up once and run it for the next 5 years (already missing my FP2 Open OS :cry: )

In that case /e/ OS is probably the most long term solution, right? Is the back up solution from /e/ OS compatible with LineageOS if I ever have to switch?

/e/ OS has microG pre installed (yay), but its own store (eh?) and I cannot get the privileged F-Droid extension to work.

Maybe we need a feature matrix of what is possible and what is not so easy with the different operating systems :smiley:

Well, I think you’ll need root for that (but "as vanilla as possible and root…).
If your device is rooted you might try e.g. FP3 (Magisk-rooted) F-Droid Privileged Extension Issue - #18 by DarthDavester - Fairphone - /e/OS community

With LineageOS I could use the adb Hack since I could remount the partitions with root via adb. But that does not work with /e/ OS. There are other reasons I dislike /e/ OS, so I am back at square one.
I would like to avoid rooting.

My simple goal is to get an OS that can be updated within the next few years with microG instead of google apps and working F-Droid with privileged extension. No fancy stuff. The Linux Mint equivalent as a ROM, if you know what I mean.