Camera & Camera2 API - missing features & bugs

It depends upon the third party and where you are. If you bought in the EU/UK etc. you can use support. and benefit from a five year warranty that includes OS support if it is the default OS.

See warranty conditions:

Surprisingly I was asked if my problem still exists after I got the answer I wrote here:

I explained again that they basically can read this thread about details (and that it is not really specific for Custom Roms, but also when using any other camera app, no matter which OS is in place).


I don’t know what to say. :man_facepalming: At least the person I’m communicating with understands what’s the underlying problem and actually talks to the developers. But it seems some people there are just clueless.


Sometimes they seem to under-rate the community knowledge and expertise… this problem is such a show stopper.


And on the other hand they constantly tell the people to check the forum or contact an Angel when they are out of ideas🙊

Will as well open a ticket and list this, as well as all other observations after a few more days of use.


Reply from support:

I actually have some more information to share about this. Here’s a quote from one of our developers:

There’s no standard way in Android to work with those high resolutions, wide angle camera etc. Regular Android apps (installed via Play etc) can only access standard feature sets of Android (Android SDK etc). Anything that’s not covered by the SDK is just not accessible for regular apps. Preinstalled system apps (like our own camera app) can have access to everything we give them access to, including device-specific custom camera features.

Just to clarify: wide-angle support, high-resolution and other such features are not “exotic” or unique to Fairphone. But Android just doesn’t provide a standard way to implement them. There are ways to make some such features accessible to 3rd-party apps (AndroidX, camera extensions), but that’s not done on FP3 and FP4, and is not a trivial topic at all.

The problem is well-understood, but not as easy to resolve as it seems. For now we are focusing our efforts on more impactful issues like those related to calls and data connectivity, or smaller issues which aren’t as time-consuming. In the meantime, the request to implement the Camera2 API is kept on hold but the team will come back to it when they have the resources to spare.

Well, I guess the multi-camera API, which is available since Android 9, is a unicorn then. *sigh* I’ve already replied back, but I guess we won’t see any significant progress in the foreseeable future.


Damn that’s sad to hear.

As much as I love my FP4, the software side keeps being annoying, in spite how little it even does compared to full stock.

Ah well, here’s hope it’ll get resolved in the future regardless.



I’ve been using my FP4 for ~6mo now and while the camera has most of the same functionality of my previous phone (a very old Samsung Galaxy S5) I’d like to suggest THREE missing features that a phone from 7 or 8 years ago had, which were really useful for lots of reasons. I’m using the stock ‘Camera’ app and these missing features are not covered above, I think

1 – The ability to voice control the camera to take a snap. Is this possible with the FP4? This is incredibly useful when you want to stick the phone into a space to say snap a serial number or something you can’t see easily and you can’t hold the phone in two hands. My old S5 would take a picture when prompted with the words ‘Cheese’ or similar. This was a stock Samsung camera app option (not a Google voice command), just like having the grid and I miss this feature on my FP4 a lot. Is this hidden somewhere or just not available? Please can I seriously request this feature be added to the stock photo app please?

2 – The photo previous option. Again this was a standard Samsung camera app option to keep the just taken picture on the screen for a few sections and the length of hold or to not show a preview was controlled in the Camera app. The usefulness of this feature was you could quickly see whether the recently taken picture was fit for purpose or you’d have to take another. The great thing with the preview was that you didn’t have to go into another app to see the result. With ‘1’ above, you could one-handed reach the phone into a space, say cheese then view the screen for 3 to 5 seconds then reach in again if it was blurry or not composed properly. My FP4 seems very antiquated in these respects and since a camera is such a part of a smartphone I think this is poor.

3 – A native photo viewer. Again old Samsung Galaxy phones (presumably all phones) allowed the user to go straight into a photo viewer within the camera app and zoom in, share to other apps etc. This worked even from the photo preview. The camera app on my FP4 seems to want me to use a ‘Google photo’ app, which I don’t use. I’d like to request a reasonably useful viewer available within the camera app, like other phones have without the need to use a cloud service, which I presume Google photo is. Why not use the button to the left of the shutter to allow the user to head to the file section to view the picture there, or give them the option to specify where this takes them, to the app or service of their choice, rather than Google photos when lots of people must use services from Synology, Dropbox etc etc. This seems a very limited and closed system. It also wouldn’t be so bad if the FP4’s native ‘Files’ app allowed the user to view photos taken on the FP4 with the built in camera app to be viewed in the Files app. You allow video to be viewed in VLC but the photo implementation is completely backwards and a real problem. When I try to view an image, a photo taken on my FP4 with the built in camera app and then try to view it in the built in Files app I get the message ‘Can’t open file’! I mean!

Who dreamt this up and then implemented such a frustratingly awkward camera and file view system with massive feature gaps, and force-linked to apps or services that not everyone uses when the camera is such an important feature? Especially as there are lots and lots of other linked services out there. Please tell me I’ve just not enabled some in-built option or you are actively working on all these three almost ubiquitous (except here) basic features.

Please do reply.


Hello and welcome to the forum. This thread isn’t really about this kind of app features, but rather about the underlying camera API (application programming interface) used to control the raw camera hardware using any 3rd party camera app. Also note that this is just a community forum. You probably want to #contactsupport with this request if you want these features in the stock camera app.


Hi there,
is there a way to get the fully featured camera on CalyxOS? Also wide angle etc?

1 Like

Please read the conversation above and see here


Just was reading ur tutorial for the camera hack and was wondering… U know u work for free to hack a phone to finish an badly done firmware? .

How do you install it as system app in system-priv?
I’m trying to include it in my LOS build. However, I do not know how to move OC’s gradle setup to Android.{mk,bp}.

When I last tried it I added Open Camera as a Prebuild APK. See Prebuilt apk in Build | AOSP Rom Development | Aditya Telange
Don’t think gradle can be included easily.

You can add it directly in the device tree git repo, i.e. create a folder device/fairphone/FP4/Opencamera with the APK and Also add a privapp-permissions file etc.

If you want to include the stock FP4 camera, you can just include the prebuilt APK via proprietary-files.txt

1 Like

Thx. That did the trick.

wide angel is working now in iodèOS
at least in their opencamera fork. not sure if it is also working in gcam versions. have no FP4 to test ist


I bet the OpenCamera is installed as a system app, that would explain it. I doubt there’s been any change made to the API recently.


I’d love to see this in CalyxOS… seems like a non-/low-priority issue currently :-/.

1 Like

yes, fixed with SYSTEM_CAMERA permissions
tried it some time ago but didn’t work. weird only now…


they are using AOSP based default camera, also as system app
you just have to ask them if the want to implement it in their camera, should be possible, too, i think

1 Like