Official LineageOS 20 FP4

Thanks :slight_smile:

I’m using the build as daily driver and no issues so far.

I’m building on my laptop which is an AMD Ryzen 7 4800H with 16GB RAM + 16GB swapfile, concurrency is set to 12.

I leave the build running overnight without any other SW running. Having cache enabled I’m not sure about build time, last took only 40minutes.

One thing I overlooked a couple of times and led to failures was that I wasn’t using lineage-20 image tag.

Hope it helps

1 Like

Thanks again for your hard work on getting it too Official. I am running on my FP4 and runs beautifully. I want to relock the bootloader now and done the get_unlock_ability and it shows 1. Security updates are the same as Fairphone updates. Is a key automatically installed or not to enable me to critical lock and then lock bootloader. Or if not Magisk way to allow Wallet and Banking?

1 Like

Can I install the official build over an unofficial (mustermann) one directly the same way as I would an update or will that break things?

In the past that worked flawlessly. And I am not aware of any change in Lineage 19 or 20 that would prevent that.

Handy, I vaguely remembered there being something needed to update keys? Or does that only apply for building images or am I totally off base?

Has anyone already tried if LOS20 also has the call quality issues as reported here for FPOS?




I’ve updated my FP4 to the latest official build now and while it works there’s one strange issue. I’ve thought about going back to stock briefly in order to make sure that the firmware is fully up to date but couldn’t.

In the developer options the OEM unlocking toggle is stuck in the “locked” position and greyed out, but the UI says that it is already unlocked.


In Fastboot it seems like the non-critical partitions are unlocked but the critical ones aren’t:

$  fastboot flashing get_unlock_ability
(bootloader) get_unlock_ability: 0

$ fastboot flashing unlock
FAILED (remote: '	Device already : unlocked!')

$ fastboot flashing unlock_critical
FAILED (remote: 'Flashing Unlock is not allowed

$ fastboot flashing lock_critical
FAILED (remote: '	Device already : locked!')

Any ideas how to get around this? I was able to upgrade the ROM via sideloading just fine and could also flash the recovery partition so I think the information from fastboot is correct.

EDIT: Attempting to fix this with Trapped in fastboot mode with locked bootloader and corrupted custom ROM - #117 by hirnsushi

EDIT2: Worked (root device, run resetprop ro.boot.flash.locked 1 in shell as root, toggle the toggle)

FYI official LineageOS builds will always include latest available firmware, just like CalyxOS. Be careful with bootloader relocking on LineageOS though as that has not been tested.


I am currently running an old Lineage OS 19 version and would like to upgrade to the latest 20,
preferably without loosing my data, thus following Upgrade LineageOS on FP4 | LineageOS Wiki

I used the pico gapps on my last install, so apparently, I should stay with that, to not need a factory reset. However, since I can’t find it, I downloaded the MindTheGapps-13 linked on the upgrade website, but can’t find out to which pico/nano/… level that corresponds. Google apps | LineageOS Wiki
Which would be the right google package to install instead, or better from where would I get it? OpenGapps itself seems outdated, does it mean I can’t get pico gapps for LoS 20 yet? In this case I would have to factory reset and switch to mindTheGapps?, I guess

I can’t tell how smooth the upgrade work, as I haven’t done one on FP4. For other phones this work without losing data as long as you follow every part of the upgrade wiki for the depending phone.

It’s hard to compare OpenGapps with MindTheGapps as there is only one whole package against up to 12 without sharing exactly the same apps in any of them. Best comparision would be against a OpenGapps nano package with some extra apps, but not quite as “large” as the micro package. As I used both of the packages a long time, I would currently prefer MindTheGapps for newer phones.

A factory reset wasn’t needed at all when I switched OpenGapps to MindTheGApps on an older phone while upgrading LOS 18 to 19. All apps worked as expected after the upgrade, maybe you have to redo your app settings for some apps and wait until the apps have updated themself to their current version.


It’s great that LOS is now official for FP4! :tada:

Security Updates Fairphone 4:

The CalyxOS releases for it only contain the latest fixes to the open source components, such as the OS code and the Linux kernel. Proprietary components such as the bootloader, modem firmware, and other firmware get updates as soon as the stock OS update is available.

@mikeNG How is it with LOS for the FP4? How often are there updates for OS code and the Linux kernel? Monthly, every 2 months, …?

Looking at the change log for the next build and the Jan security update is ready to be deployed. I would say the security updates will be quicker but for updates to the phone’s hardware we will have to rely on FP.

1 Like

Hi all,

I have installed the new update of the official LineageOS through the OTA from the update menu on the smartphone.

The update was done successfully, but it take a very long time.

The first step to download the update and second step to install was done quickly, but the 3rd step to finalize the installation package take more than 3 hours.

Is it really normal that it take so long?

Thanks in advance

had the same thing, took forever to update,never seen it before, but my old phone would always boot into twrp to update, and this one is staying in the os. i was able to keep magisk going so thats a plus :slight_smile:

I upgraded to the official release at the weekend. First tried to replace the keys as stated in the wiki. But my packages,xml didn’t contain any keys, so the script did nothing. Then I just dirty flashed the official build over mine. That worked fine. No issues so far.
TLDR; Just flashing the official build should work.


It is indeed as simple as that, just tried it, everything went perfectly well.

On another topic, I’ve been rocking LOS with manual update for so long that I don’t remember how OTA updates handle root and GApps…
=> Do I need to restore image through magisk → proceed to OTA → install magisk in second slot through magisk ?
=> Are gogle apps wiped when proceeding to OTA updates ?

1 Like

Some questions regarding LineageOS 20 on the FP4:

  1. Can I use ext4 as Filesystem on the external SD?
  2. Does Android Auto work via USB?
  3. Does Volte and Vowifi work?
  4. How is your experience with the camera? LOS camera and GCam?
  5. What is the selinux status?
  6. Does it pass safety net checks?

Thanks a lot in advance

Has anyone successfully locked the bootloader after installing LineageOS?

Following happens on my phone:

  1. fastboot flashing lock_critical → works and boots fine
  2. reboot into bootloader
  3. fastboot flashing lock → always boots into bootloader.
  4. Boots fine when fastboot flashing unlock

As far as I read, LineageOS 20 still does not support relocking, correct?

I played around with this for a couple hours yesterday, but didn’t get it to work. I’ll keep trying though.