Official LineageOS 19 for Fairphone 3/3+

I can’t permanently switch of the location icon (big green icon in the upper right corner indicating location access). If i disable it in developer options, it gets re enabled after reboot

WiFi drops when downloading large files since 19.1 :frowning:
There is no difference using 2.4 or 5 GHz networks. Testet on 3 different WiFi networks. Same behavior: Connecting to WiFi, start download the recent OTA update, error downloading at 40 or 47 percent, WiFi connection disconnects and I have to reboot the phone to be able to reconnect to the WiFi network. Anyone else with the same issue? - LineageOS 19.1, mindthegapps

1 Like

I experienced this also, but very sporadic. Just did a test to download the OTA, this went flawless…

I can confirm this 100%!

I opened a bug report regarding this issue.

3 Likes

Someone having problems with LOS 19.1 sending and receiving MMS with Bouygues, even after a fresh install and resetting and checking APNs multiple times:

It does work with 17.1 and 18.1 though…
Does anyone experience the same on LOS 19.1?

Did you notice FP3 wlan drops when up-/downloading large files? This issue seems to exist at least since lineage-18.1 dated 2022-06-13 with kernel 4.9.227+, but “This didn’t used to happen until a few weeks ago.”
@TeamB58: Because of the timing, could there be some link to the FP3-stock-R-changes?

Thanks for the pointer. I have not been able to reproduce this issue since I am on same sources.

There don’t seem to be device tree specific issue as part of that topic. Could it be an issue from Kernel? We do have a backup kernel branch. We switched from old and outdated Android 10 based kernel to latest Android 12 tag based sources.

Anyone willing to try out a test build from old kernel branch? I am unfortunately a bit occupied.

There’s an update available to WiFi driver sources and I have tried to merge the latest sources here: https://review.lineageos.org/c/LineageOS/android_kernel_fairphone_sdm632/+/334755

I don’t know if this will help address the issue or not but would be worth trying.

1 Like

Thank you @TeamB58 for updating the driver sources. Will they be available in the next (OTA) build or is this just for people who build by themselves from scratch?

Same here also in LOS 18. Wifi drops, then phone reboots.

I can generate a test build but since I am unable to reproduce this issue I would require a volunteer to validate.

Also, since this is a test build it’s suggested not to be tried on top of stable release.

1 Like

FYI: First Lineage4microG build is available since yesterday: FP3

4 Likes

…and the upgrade via adb sideload worked like a charm. :smiley:

Hi. I installed LOS a few weeks ago and I wanted to update my build to the latest version via the updater app.
Installing the updates takes FOREVER (been running for one hour now) and a few apps as well as Google Play Services keep crashing every 5 minutes.
Does anyone have the same update experience?

I’ll keep you updated if it works in the end but I didn’t have this problem with the previous LOS version when I tried it a few months ago.

EDIT: it worked after 15 more minutes. When rebooting, I was stuck on the “Fairphone, powered by Android” screen. Had to power it off by holding the power button and it rebooted successfully. I’m up to date.
I’ll see if the update process is the same on the next build.

Same for me it takes ages. Can’t say about the reboot problem, though, as i reboot to bootloader and then temporarily in twrp for flashing a magisk prepared boot.img. there the reboot works flawlessly

1 Like

The install was OK without crashing apps, although i had that with previous updates. The reboot didnt work properly. I had to remove the battery in order to get the phone started again.

1 Like

Thank you very much for your work and this fantastic website, it helps a lot! And sorry for my question which is not direct linked to your work.
But has anyone managed to install the version 19.1 of MicroG for LineageOS? And has anyone managed to get a patched playstore to work with? In the past (till version 18.1) I flashed after microG the MinMicroG installer from FriendlyNeighbourhoodShane. But this seems to be no longer possible as the version 19 includes already the whole MicroG but unfortunately without the patched playstore.

I managed to install iodéOS 3.1 (based on LOS19+MicroG).

I did it by installing FakeStore 2 PlayStore (magisk-module). I had some trouble making it work, I posted my fix in the matching bugreport.

I have a question, but it might be a little stupid: I currently (still) have 18.1 installed on my FP3+. I initially flashed 18.1 together with the OpenGapps pico package, which works fine. But it seems that the OpenGapps project has some challenges getting a version for Android 12 out. It seems that MindTheGapps is available for Android 12, though.

My question is: Considering that I want to dirty flash from 18.1 to 19, is it possible to flash MindTheGapps instead of OpenGapps? So far, I’ve found various advice, from people saying it would work, to people reporting breakages, e.g., #32 in this thread. It seems to me that it ought to work, considering that both are “just” repackaging existing Gapps for easy installation, but I would like to be sure.