Official LineageOS 19 for Fairphone 3/3+

I had the same setup and used mindthegapp without any issues.

3 Likes

I also had the same setup, and finally took the plunge and did a dirty upgrade incl mindthegapps without wiping any data. Everything seems to work just fine!

1 Like

So, I dirty flashed LOS 19 with MindTheGapps, and everything works fine. Thank you @Grimmwolf and @BroX for confirming that this works, and thank you @TeamB58 @dk1978 and all the other contributors for your work in supporting LOS on the FP3.

One tiny note: Reading german ID cards via NFC still doesn’t work, with the same symptoms I reported for LOS 18.1. Interestingly, GPay complained about the phone being “rooted or otherwise modified” when I tried setting it up, which may or may not be related. This is not a major issue for me though.

1 Like

For me, the German id card works must fine…
But I’m not using gpay

Thank you for you effort @TeamB58 . Is it possible to update my current build with your test build via adb or do I have to make a complete clean installation? Asking because it is my work phone and I don’t want to start everything from scratch …

hi! i flashed LOS 19 with MindTheGapps; everything works, great job!
but i use google wallet and a signatue app. both tell me that my phone is rooted. i don’t need root, but i need the apps. so how can i remove root?
i tried magisk to “mask” root, but it didn’t work.
please help! or i have to change back to fairphoneOS :frowning:
Franz

If you have magisk installed but don’t need it, you can uninstall it.
Otherwise, you might want to try universal safety net fix and magiskhide props config as magisk modules. People also report good results with some unmounter module. Also, hiding the app my help.

But be aware that this is a never ending cat and mouse game with/by Google. Though, at the moment, i got most of my banking apps running.
Also, this might also be triggered by the userdebug build property and/or an unlocked boot loader…

Edit: denylist unmount and hide userdebug as magisk modules might be handy, also. Did not try

at first i had NO magisk, but he wrote that i am rooted. then i installed magisk - it helped a little bit. then i installed a module called shamiko - a little bit better but some apps still wrote that it is rooted. i also hided the app. well, i tried really much.
at the moment i completely resettet the phone, no magisk, bootloader is closed, but google wallet still means the phone is rooted :frowning:

In Google play store, settings, what does it say re certification of the device?
If i remember correctly, there was the possibility to whitelist a device for certification. Don’t know whether this possibility still exists or is helpful for wallet. I once tried Google pay for fun, which worked, and then removed everything again, because Google already knows enough, it doesn’t need to have access to my paying habits also

play-protect certificate: device is not certificated
tried to certificate … still not certificates. perhaps it takes a while

yes, google knows al lot… but i have an app for digital signature which also doen’t work

Yes, that might take a bit.
The Google thing is a personal decision. It’s ones own decision, and that’s fine for me. There are zealots, but in the end, there are also personal needs and decisions…

i deleted cache and memory from playstore, now it’s certified.
reboot…
still the same :-/

edit: CTS profile match - FAIL
??

I did a dirty update from LOS 18 to LOS 19. Everything is running wonderfully so far! Thanks for the work :slight_smile:

Only one thing is not running clean yet (except the design of Android 12): When I make a call, I don’t hear a dial tone. There is only a short tone, then nothing and the next thing I hear is either the call recipient or the voice mailbox.
Does anyone have an idea what this could be?

1 Like

Just to confirm. The build is 32 not 64, right?

No, the fp3 is arm64

Thanks, i couldn’t find a working GAPPS with minimal install. In the end I used NikGApps Core.

I was tempted by these, also, but stayed with mindthegapps. So, maybe my installation is too fat, but then, except for search (except music and reverse image)i use many tools. Unfortunately

Good that you mention it. It happens with my phone as well and is pretty confusing. Don’t know when this started, though.

Same for me. Calling “normally”, without any Bluetooth or other headset, holding it to my ear, there is no dial tone at all. I haven’t tested calling via headset or with the phone on loudspeaker yet.

As far AS I can tell, it started after upgrading to LOS 19, I never noticed it before.

Same thing with a Bluetooth headset: There’s no audible dial tone when making a call.