Official LineageOS 19 for Fairphone 3/3+

Hi everyone. My phone has been stuck in bootloader since last update. Trying to adb sideload the update would not work, and the fastboot set active partition isn’t working either. I am getting a bit desperate here, I am afraid my phone is bricked. Can somebody please help me?

Where exactly do you get stuck? Can you describe it a little bit more?

Can you reboot to the recovery to sideload the image, so you can follow my workaround?

I get stuck at each and every phase. If i try to reboot, I get stuck at logo image. If I go to fastboot mode, I cannot change partition from a to b (command would not work). I also tried flashing the image through fastboot but got stuck to bootloop again.
In recovery mode I tried both to reinstall update and image using adb sideload. In the first case, stuck again to bootloop. When trying to flash image, here’s whay I get:

adb sideload lineage-19.1-20221114-recovery-FP3.img
serving: ‘lineage-19.1-20221114-recovery-FP3.img’ (~0%) * failed to read command:

Then nothing happens. P.s. I use NikGapps, not MindGapps.

When in fastboot mode, what does fastboot devices show? Does it list your device?

Seems like adb get a timeout, this is normally a sign that adb is not active. After selecting recovery mode and after it’s loaded, did you select the “Apply update” option. Only after that the adb sideload command can upload an image.

If it worked, don’t forget to also sideload the “old” NikGapps package, otherwise you will get stuck into bootloader animation again.

When typing fastboot devices, it lists the serial number corresponding to my device.

Pertaining to adb, yes I selected apply update before trying to upload both image and update. I tried again and got the same error message. I am really lost here, nothing seems to work.

What do we mean by ‘old’ NikGapps package btw?

Does adb devices list anything? Otherwise adb seems to be disabled.

You will have to flash the NikGapps package over the old one to reset the Google Apps to standard settings and get around this boot loop.

As I explained, when typing adb devices I get the serial number of my device. Does this mean the device is or is not recognized? And what package would I be supposed to flash? More recent or old one?

The command I was asking previously was the fastboot which is different to adb. Do both list your device? If it list your device, your fastboot and adb connection should be ok. If adb doesn’t list your device, adb is disabled.

It shouldn’t matter as long as it resets the permissions of the Google Apps. The package I used through my first flash worked for me to fix the problem, but I’m using MindTheGapps.

You try to load the recovery image (over recovery). You should sideload the full image

Hi HardCoreTec,

Are the “security fixes” special to the FP3-Build of LineageOS 19? - or are they global for all LineageOS 19 ports to other devices?

Would it be possible to provide a test build without these security fixes in the former case? - then it would be possible to see if the problems with denied accesses are gone.
I already tried to grant to System-UI the missing access rights (according to the logs) - but it was not possible to set the needed access rights with the normal Setup-App - thus this has to be done by adb or whatever developer tool.

At FAQs - NikGapps | NikGapps Website there is an interesting guideline to do a “clean flash” without loosing data. I’d try this, if there is a real chance to fix the access right problems. The strange thing is, that I find no other bug reports regarding “systemui” and “requires android.permission.ACCESS_FINE_LOCATION”. So I suspect that this problem is very specific to this FP3 build of LineageOS 19. Am I wrong?

Thanks for your support,

Hi Achim, no they are not specific for FP3, these fixes are global and provided by Google or volunteers.

It’s not that easy as there are OTA-Updates provided in this release which restrict flashing old versions to the device without cleaning all data. Don’t know if this time is spent wisely with this approach as it also seems that the official non LOS FP3 build has this boot loop.

Did you reflash the latest NikGApps over the old one and done all the steps I suggested here? This procedure should also work for users using NikGApps.

As the unofficial LOS FP4 release also ends up in a boot loop when GApps are installed with this update, you can see that there is a relationship to this fixes provided by the last update. And it seems that this is a bigger problem with Google Play Store, not (only) a LineageOS one.

Yes, that was it.
Didn’t find the setting at first, thought it was a global setting and not somewhere in the PlayStore app.

@TeamB58: I checked the build instructions and found that the FairphoneCamera is not available open source but only as binary blobs via the script :disappointed_relieved:. So would just the right combination of forwarded proprietary blobs make up and running? Does show what is missing to get there? Your help would be much appreciated …

Hi All,
Do we still have issue with the latest build related to Lineage or as per the ongoing discussions, it’s related to the GApps package it self?

Please help confirm this by today.


1 Like

hey Margherita_Gr!
I had similiar issues like you at first.
for me worked the the lastest package ( together with an older version of gapps (
The system is working again apart from gapps. I don’t mind the non functional gapps as long as everything else is fine. I just wait for upcoming updates.

The problem is a correlation between the last update and using any Gapps packages (at least MindTheGapps, NikGApps, microG), It can be fixed by reflashing the Gapps package again and correct the messed up permission on these packages. Otherwise the phone is stuck in an endless boot loop, as it can’t start the Gapps services.

I doubt that the disfunction of the Gapps will be fixed in any LOS release in the future as it’s not the fault of LOS and provide no Gapp package by theirself. After you successfully reinstalled the Gapps package, just complete my workaround and fix your Gapp-Settings to have a fully functional phone again. It’s not that complicated and is fix in a minute! :wink:

Did you remove the build because of the issue?
Does this mean you were able to fix it? If so, very cool! If not, still good to remove it.

Yes, fixed with


after reflashing MindGapps to its base version the boot is successful

Can you explicit what you mean here ? I am locked at this preliminary step.

Thank you for the whole explanation though.

Just wanted to say that you need to select the right package for your phone in relationship to the LOS version the user is running, as at least also FP4 is affected by the bug.

For that phone, you currently need the right “base” package which is in relationship to the LOS19 or LOS20 build people are using on their phone.