Official LineageOS 19 for Fairphone 3/3+

which GAPPS package variant is used by the most maintainers / developers of LOS 19 for Fairphone 3/3+?

I’m currently using MindTheGapps, but am willing to switch to another variant to avoid having problems, that are specific to my GAPPS variant, so that the maintainers can’t reproduce the problem.

I have the impression, that the combination of MindTheGapps-12.1.0-arm64-20220605_112439 version which I initially installed with LOS19.1 causes some permission problems for classes/packages like System UI and TelephoneRegistry, which are finally leading to problems like freeze - often logcat contains several lines reporting very long draw-times, which indicate severe system stability problems. Especially MagicEarth is freezing very often - this was not the case as long as I used the stock ROM.

Is the MindTheGapps package containing some parts that are not regularly updated? - like some setting-files, scripts
→ should I perform a sideload update of LOS in combination with a new MindTheGapps release?
Which MindTheGapps version should I use in combination with the next update of LOS?


1 Like

But what does that mean getting “the right package” ?

Of course I use the package that is built for my phone with the GG package. (I have used those for two years and upgraded them at least three times without troubles)

I just tried setting the last build (as I saw it available this morning) and I am still blocked in the boot loop.

Same here with microg.
When the phone sleeps it’s loosing the Wifi. When waking up it reconnects to Wifi again.
No great problem to me as long as I have mobile data too.

some time ago I reported the following problems from some of my logcat logs:

Today I found
There is documented the way to set permissions for system apps.

Which part is responsible to set those permissions for system apps like “SystemUI”?
Is it the task of the LOS19.1 package for FP3/3+? - or is this the task of MindTheGapps?
Is it possible to add a settings file to /etc/permissions without rooting the device? - by adb session with console text editor like “vi”? - or is this partition mounted read-only?
My Fp3 freezes very often and several activities are lasting longer the used from Stock-ROM.
For example MagicEarth freezes on LOS19.1 at FP3 very often.
Also on start of “Open Camera” the access to the camera device is often provided with a very long delay.

So I’d like to fix all my detected permission problems to see whether this changes anything of the other problems.


I’m seeing the message
LocSvc_ApiV02: reportSv:3443] At least one RF_LOSS is 0 in gps.conf, please configure it

Seems I get a gps fix, but using a navigation app fills the log with these messages

Hi all

I installed the official version, but lost nearly all data on the device, because the system can’t access the filesystem or parts of it anymore. So I reinstalled LOS again (after factory reset), but now I have the same issue again. Does anyone experience something similar? Could it be even hardware?

Thanks for any ideas how to get to the root of this problem.

Which rom did you use before?

LOS 18 (official), but I did a clean install of LOS 19

I’'m not sure that a migration at such a late stage is still supposed to work (I did it early, and kept all my data), but in case you have a backup and data is lost anyway I’d try a factory reset

But this is a drastic measure… Maybe somebody else has way better hints than I do

Yeah I didn’t even bother trying to migrate and did a factroy reset before each install, just to be sure. So that should be fine.

Is there any tutorial / way to use this ROM with a persistent installation of UnifiedNLP and f-droid privileged extension?
I know of the prebuilt roms from the MicroG people, but they always lack on updates and do not include firmware updates…

I tried different ways to install UnifiedNLP and f-droid privileged extension including these tutorials:

My understanding was, that the shell scripts should reenable UNLP and f-droid PE but both did not survive a OTA update of LOS.

Has anyone managed to do this or are you guys either using MicroG’s LOS or GAPPS with this ROM?

I installed these things through Magisk-Modules in the past, maybe that’s an option for you? Now I am using iodéOS, if you install the Beta-Updater you will get more frequent OS updates, might also be an option for ya?

I hope it’s okay to ask this here. I wanna switch back to the fairphone stock OS. How easily is this achieveable? Can I just flash the stock ROM? Is it possible to backup my apk files (apps + data) and reinstall them on the other OS?

I think that’s quite easy. Just follow the official documentation:

If you’re planning to re-lock the bootloader after the installation then search for hints on the forum before doing that.

Afaik you’ll have to (temporarily) root your system to do that (by using a backup system like titanium).

1 Like

Hi All,

It has been a long time since the last update here. I have been working on lineage-20. One big issue here was the NFC topic. LineageOS has removed support for NXP stack in favor of AOSP. But because of some issues, it does not work properly on FP3. So, I spent quite some time converting the stack to prebuilts. It’s now done and things are working fine.

Another topic is regarding the screen density. I personally feel the density is a bit high especially after Android 12. I was checking stock and they seem to have lesser density. So, I thought of checking here if we can reduce to 420 as done in stock.

Let me know your thoughts. I am fine to provide an unofficial build as well if required.



I’m not quite sure how this looks, but i have the impression it’s all quite small now (maybe I’m just too old… :-))

On another topic, I’d maybe be interested in being able to have a setting to stop charging at maybe 80% or some such… And probably being able to set zram
Both actions now require root…

Any ideas about that?

I second that. Right now I have to hack the device, but if that can be done natively, that’s a darn good idea.

1 Like

I understand and I am sorry but feature requests would directly have to be made to Lineage(via ticket?). Since this is a request in platform, it will be handled by the appropriate developers. I will have a look at this as well and see if I can get something.

1 Like

Thanks both for a first feedback. I just wanted to first check an echo to my proposals. If that’s positive enough i will create two tickets for this.

Without knowing anything about the how to, I just wanted to mention, that Iode OS has Smartcharging integrated.