Official LineageOS 19 for Fairphone 3/3+

Again, thanks for your answers,
maybe someone can replay these steps:

-Turn off mobile data
-Connect to Wifi
-Put phone in standy by, and don’t wake it!
-Leave Wifi range for some minutes
-Get back into wifi range, but don’t wake the phone
-Write your self an email from somewhere else, eg an PC
-Wait for the to be received on the phone, but don’t wake the phone
-My result: the email is not received, no vibration, no sound, no LED notification
-Wake up the phone, Wifi is not connected, after some seconds the Wifi is reconnected, and the email is received

Since my phone has already broken several times during the update, I am currently hesitant with updates

I’m also experiencing this. When going shopping or otherwise leaving home and losing wifi, after coming back wifi only reconnects after unlocking the phone


I’m still having an issue with the NFC card reader, reported already for 18.1 here. It’s not super important to me personally, but it has persisted so far from 18.1, through an in-place upgrade to 19.1, to the clean flash of 19.1 I just did (because I b0rked Google Play when I tried to recover from the failed OTA upgrade this monday).

But I have to say: It’s awesome having someone actively work on LOS on this device. Thank you, and @dk1978 both, for your work on this. Looking forward to LOS 20 as well.


I had a wakeup problem with a weak WIFI signal, which ended in killing of webview_service. I use the tool “SysLog” (with the documented adb calls to allow logging of global logcat data).

A complete log of this fault can be accessed at

Some interesting problems:

  • Some errors “calling a method in the system process without a qualified user:” for and

  • Some problems “Permission Denial: receiving Intent” for regarding requires android.permission.ACCESS_FINE_LOCATION and for android.permission.READ_PHONE_STATE

  • E/i2c-msm-v2 7af5000.i2c( 0): OVER_UNDER_RUN_ERROR: msgs(n:1 cur:0 tx) bc(rx:0 tx:66) mode:DMA slv_addr:0x28 MSTR_STS:0x0c000000 OPER:0x000080c0

  • HIMAX-Problem

E/i2c-msm-v2 7af5000.i2c(    0): error i2c_msm_dma_xfer_process(n_bufs:1):-6
E/nq-nci 5-0028(    0): nfc_write: failed to write -110
I/[HXTP] himax_common_resume(    0): enter
I/[HXTP] himax_chip_common_resume(    0): enter
I/[HXTP] himax_release_all_finger(    0): enter
I/[HXTP] himax_release_all_finger(    0): exit
I/        (    0): [HXTP] irq_enable_count = 1
I/[HXTP] himax_chip_common_resume(    0): END
  • WLAN-Problem with Killing of something afterwards
I/binder  (    0): 10640:10640 ioctl 40046210 7fd3d1f884 returned -22
E/        (   19): [19:59:23.695865] [000000DB754CCF45] [VosRX]  wlan: [E :WDI] WDTS_RxPacketDump RX Data frame is UC
E/        (   19): [19:59:23.695881] [000000DB754CD06F] [VosRX]  wlan: [E :WDI] WDTS_RxPacketDump: Management subtype:5 SA:08:96:ad:d0:a7:10 DA:4a:64:13:29:f4:6a
I/ActivityManager( 1321): Killing 6888:android.process.acore/u0a31 (adj 975): empty #17
W/wificond(  936): Scan is not started. Ignore abort request
  • Some more WLAN-Problems
E/        (   19): [19:59:27.231228] [000000DB79588F77] [wpa_s]  wlan: [E :HDD] wlan_hdd_cfg80211_set_ie Set UNKNOWN IE 3B
E/        (   19): [19:59:27.238733] [000000DB795AC24B] [wpa_s]  wlan: [E :HDD] wlan_hdd_get_classAstats: Unable to retrieve Class A statistics
E/        (   19): [19:59:27.240234] [000000DB795B32DB] [VosMC]  wlan: [E :PE ] __limProcessSmeJoinReq: 1905: DUT is trying to connect to Cisco AP
E/        (   19): [19:59:27.269635] [000000DB7963CFFD] [VosMC]  wlan: [E :PE ] limProcessSwitchChannelRsp: 4162: channelChangeReasonCode 1 status 0
E/        (   19): [19:59:27.274928] [000000DB79655CF2] [VosMC]  wlan: [E :SME] sme_QoSUpdateUapsdBTEvent: 8039 Invalid sessionId
E/        (   19): [19:59:27.527842] [000000DB79AF7575] [VosMC]  wlan: [E :HDD] 84:cf:bf:8e:e2:89 connected to 08:96:ad:d0:a7:12
E/        (   19): [19:59:27.529349] [000000DB79AFE67B] [VosMC]  wlan: [E :HDD] wlan(6) 08:96:ad:d0:a7:12 Standalone

Afterwards, the system is getting slow (“slow dispatch” warnings), and finally lowmemorykiller is killing webview_service.

I hope, that the logfile 20222-11-09_20-03-logcat.txt provides some useful information.


during usage of MagicEarth, I get lots of logcat-messages like:
11-09 12:31:07.006 I/OpenGLRenderer(25436): Davey! duration=9223358993555ms; Flags=2, FrameTimelineVsyncId=368907, IntendedVsync=13043298953221, Vsync=13043298953221, InputEventId=0, HandleInputStart=13043298953221, AnimationStart=13043298953221, PerformTraversalsStart=13043298953221, DrawStart=13043298953221, FrameDeadline=13043332286553, FrameInterval=0, FrameStartTime=16666666, SyncQueued=13043303168876, SyncStart=13043303169918, IssueDrawCommandsStart=13043303267574, SwapBuffers=13043304058199, FrameCompleted=9223372036854775807, DequeueBufferDuration=18333, QueueBufferDuration=682188, GpuCompleted=9223372036854775807, SwapBuffersCompleted=13043305239866, DisplayPresentTime=0,

From time to time, this leads to an “unresponsive” warning regarding MagicEarth.

Could this be a problem with OpenGLRenderer, or a specific problem of MagicEarth?
I didn’t have screen freeze problems with MagicEarth with stock Android.

I don’t know, whether this GPS-Warning is relevant, and whether this is caused by system, or by the app:
11-09 12:31:07.025 W/LocSvc_ApiV02( 696): reportSv:3443] At least one RF_LOSS is 0 in gps.conf, please configure it

I would be happy, if those problems could get handled, before the next Android version in ported.

Thanks for the good work,

Reporting failure to boot after today’s update.

The update went smoothly, but upon restart I only get the Lineage OS animation. It won’t complete and after a few minutes the fairphone reboots, gets to the animation and so on.

Same here ! ! !
Is there a solution already?
Could it be possible to re-apply the update via adb sideload??

It does boot after sideload. I do have problems with MindetheGapps, though…

Edit: solved also: Google Play had no permission for network

Not reproducible on pure LineageOS build. Update was successful. So, it could be something related to GMS.

Exactly the problem I had after last weeks’ update, including Google Play always being offline. I never checked its permissions, though.

Ran into same problem with todays update, but could fix it (see below).

Even after sideloading it stucks in an endless boot animation with reboot loop.

It seems to be a problem when using Google apps. After sideload the image again, boot problems exists but after reflashing MindGapps to its base version the boot is successful. But some errors occur during login (e.g. Google Play, Youtube) because of the old Gapp versions.

The problem seems to be located within the Google Play Store network permissions which are all reset to zero. After allowing the network you have to clear the cache and local data for the app because of the downgrade. After that a reboot is required and you have to wait until the Google Play Store do it’s background update. Do another reboot next and update the Google apps via the Play Store. I didn’t saw any error messages after that, but haven’t time to test all apps.

EDIT: One more problem which have to be solved for people using the fingerprint sensor: Under Security->Trust agents->Reenable Smart Lock (Google)


Thank you for the detailed description on how to fix this. I had the same issues as the others and fixed it by following you descriptions.

Glad it worked. I found another issue on a testphone after the Gapps “downgrade” and updated the procedure for users which are using the fingerprint sensor.

Thank you so much! Your solution fixed my problem too!
You made my day!

Thanks, that worked so far.
The only issue I have is that PlayStore thinks I’m not connected to the internet and hence I can’t update anything.
I’ve looked up that problem, but the suggested solutions didn’t work for me (remove account and add new, clear cache and local data, restart the phone, don’t be in a VPN, check connection).

Check whether play store may use the network. That’s in the properties for the app (where permissions and all that is listed). For me, it’s long press the icon, type on the i, and check network settings. Most probably network usage will be “off”

Please check the permissions for the network access as suggested by @ lklaus. Also after this it’s crucial to reboot and wait until the Google Play Store did it’s background update from V28 to V33. You can check this in the app settings at the bottom of details. Only after this update is done, you can use the app like before and the “not connected” error inside should be gone.

which part of the system is responsible for setting those access rights? Is this the task of MindTheGapps? I wonder, why I see so many access rights problems regarding system apps like Play-Store, SystemUI and TelephonyRegistry. I have the impression, that some important events/informations are not getting to the relevant apps, so that the system gets unstable.

So it would be interesting, whether these problems are caused by the interaction between MindTheGapps and LineageOS for Fp3+. In this case, it would be interesting to know, which alternative GAPPS-Package is compatible with Android 12 and causes no/fewer problems.

I used Open-Gapps for other devices with former Android versions. But as Open-Gapps is still not officially supported for Android 12, this seem no suitable choice to me.

Any recommendations? - and howto for switching of gapps version without losing my data?


1 Like

Not quite sure about the real cause, but could be related to the security fixes inside this build which cause problems at least for the MindTheGapps package.

I heard about NikGApps, but I don’t know if this package didn’t also have this problem,

Personally i wouldn’t advise to switch to a new Gapps supplier if you don’t want to do a full wipe and a clean install. Otherwise you have old configs and scripts which can cause problems in the future. As far as I know, removing the left data by hand isn’t an option without a TWRP recovery, where you got full access to the root filesystem.

1 Like