Official LineageOS 19 for Fairphone 3/3+

Hey @TeamB58. Thanks for asking. Current issues for me:

  • Dial-tone usually missing
  • Alarm clock: Snoozing via shaking or turing down the device does not work. Very annoying for all night owls out there. :slight_smile: It was at least present since LOS 18.1:

Thanks for the hard and good work! :heart:

Thanks.

For the alarm, please file a bug so that relevant team can look into it. Do mention that it was there since 18.1.

For the dial tone issue, I thought it was fixed. Let me check this again.

High power consumption, can you see what’s consuming more?

WiFi drop, strange again as it was fixed a few weeks ago. I’ll continue to observe this one.

Thanks. Here (global) or here (device specific)?

I did not mention power consumption, but I notice this too. I thought it’s because of (in my case) missing Google Play Services resulting in a constant connection to Signal and Threema servers.

Fix found for the ringback issue. Submitted here: https://review.lineageos.org/c/LineageOS/android_device_fairphone_FP3/+/343468/1

Should get fixed in next update.

2 Likes

Thanks for fixing the ring tone.

Mobile network consumed 25% alone in 32h. The rest was small percentages only. Not enough to add up to 100%, but that is all i could get from the battery settings.

Here’s the issue: Alarm clock settings to snooze by shake or turning down do not work on Fairphone 3 (LOS 19.1) (#5255) · Issues · LineageOS / issues / android · GitLab

So, I just tried to install the 20221107 update via the updater and am now stuck in a boot loop.

FP3+ with the official LOS19 ROM and MindTheGapps. I also got the “usual” crashed apps during the update installation, but it normally works despite them, so I didn’t think anything of it.

Eventually the updater app finished installing the update, I started the reboot, and now it’s boot looping. Each try takes two or three minutes before the phone shutting off and trying again.

Fixed it by rebooting into recovery via volume up + power, and manually sideloading the update (plus MindTheGapps, to be safe…). Everything seems to work again now.

Not sure what, or why, this happened. If there is any diagnostic data (logs, or similar) that I can provide, I’d be happy to do so.

Yes please.

Enable USB debugging and authorize it. Start capturing logs as soon as the device reboots using adb logcat -c && adb logcat -b all > crash.log.

Edit: Just now tried the update and it went smoothly.

Thanks.

For me, it went smoothly, also, but with the intermediate step of flashing a magisk-patched boot image
Otherwise, the known effects of force closed apps. And it definitely finishes faster if the screen stays on (caffeine for help :slight_smile: )

Will this still give you relevant data even if I’m not stuck in a bootloop any more? If so, I’ll get you those logs later today.

I don’t think so. Bootloop → Restart happens normally when there’s something crashes continuously. Would have been good to get this detail and address. Try to capture them when it happens next time.

Hi All,
Thank you for your continuous support for LineageOS on FP3.

Now that we have addressed the last bit of blocking issues, do we still have any more issues to be addressed that is critical/blocking?

Or, are we good to move to Android 13 via LineageOS 20? I’m super excited about it actually.

Looking forward to your feedback and suggestion.

Thanks.

3 Likes

Hi!

Thanks again for your work, having an up-to-date minimal Android install available just because I have the luck to have the same phone as some motivated person is so great.

I am wondering if the DRM issue is fixed? I am using the lineage+microg distributions which is almost 3 weeks old, so maybe I am in an outdated situation:

  • “adb logcat” still shows a lot of ‘library “android.hardware.drm@1.0.so” not found’ as described by @Kariburger
  • some video apps like Twitch or Disney+ consistently freeze (Disney+ at first launch and Twitch when trying to open a stream), which seems to increase the frequency of the warning above, so I guess it’s related?

I think the DRM related fix was merged on Oct 21 - one day after the last LOS4MG build made. So you will have to wait for the next one …

1 Like

@TeamB58 before moving on: Do you see any chance to make the FP3 stock camera com.android.fp3camera available via the proprietary blobs?

Hi, thanks for your work!
What is the Status of the
“Wifi doesn’t reconnect in Standby” Problem?

I will. Apologies for not getting the logs, but my focus was on getting the phone working again. I’ll keep it in mind in case it should happen again.

It should be very easy since we have full support for the proprietary setup. We just need to add the camera app from Build Instructions — FAIRPHONE open source documentation and build.

However, it looks like the A11 version of app seems to have some issues in A12/A13. It isn’t working the way it should unfortunately.

@dk1978 and I discussed this topic some time ago but we could not conclude on it. We’ll check this again soon.

Hi, thanks again for pointing out. I am not sure if we should consider this as a blocker. I have started using LOS as my daily driver from a few weeks now and I can confirm WiFi works without any issues. Note that I fresh installed 19.1 the first time after introducing the new kernel a few weeks ago.

Since I am unable to reproduce, I am finding it very difficult to analyze and debug this. Please let me know if you have any thoughts on what we could do for this.

Sure, thanks.

1 Like

I just want to confirm that the issue seems to be fixed. It is ringing as expected. Thanks again as it was really confusing not to have the tone…

1 Like