Official LineageOS 19 for Fairphone 3/3+

Reporting failure to boot after today’s update.

The update went smoothly, but upon restart I only get the Lineage OS animation. It won’t complete and after a few minutes the fairphone reboots, gets to the animation and so on.

Same here ! ! !
Is there a solution already?
Could it be possible to re-apply the update via adb sideload??

It does boot after sideload. I do have problems with MindetheGapps, though…

Edit: solved also: Google Play had no permission for network

Not reproducible on pure LineageOS build. Update was successful. So, it could be something related to GMS.

Exactly the problem I had after last weeks’ update, including Google Play always being offline. I never checked its permissions, though.

Ran into same problem with todays update, but could fix it (see below).

Even after sideloading it stucks in an endless boot animation with reboot loop.

It seems to be a problem when using Google apps. After sideload the image again, boot problems exists but after reflashing MindGapps to its base version the boot is successful. But some errors occur during login (e.g. Google Play, Youtube) because of the old Gapp versions.

The problem seems to be located within the Google Play Store network permissions which are all reset to zero. After allowing the network you have to clear the cache and local data for the app because of the downgrade. After that a reboot is required and you have to wait until the Google Play Store do it’s background update. Do another reboot next and update the Google apps via the Play Store. I didn’t saw any error messages after that, but haven’t time to test all apps.

EDIT: One more problem which have to be solved for people using the fingerprint sensor: Under Security->Trust agents->Reenable Smart Lock (Google)


Thank you for the detailed description on how to fix this. I had the same issues as the others and fixed it by following you descriptions.

Glad it worked. I found another issue on a testphone after the Gapps “downgrade” and updated the procedure for users which are using the fingerprint sensor.

Thank you so much! Your solution fixed my problem too!
You made my day!

Thanks, that worked so far.
The only issue I have is that PlayStore thinks I’m not connected to the internet and hence I can’t update anything.
I’ve looked up that problem, but the suggested solutions didn’t work for me (remove account and add new, clear cache and local data, restart the phone, don’t be in a VPN, check connection).

Check whether play store may use the network. That’s in the properties for the app (where permissions and all that is listed). For me, it’s long press the icon, type on the i, and check network settings. Most probably network usage will be “off”

Please check the permissions for the network access as suggested by @ lklaus. Also after this it’s crucial to reboot and wait until the Google Play Store did it’s background update from V28 to V33. You can check this in the app settings at the bottom of details. Only after this update is done, you can use the app like before and the “not connected” error inside should be gone.

which part of the system is responsible for setting those access rights? Is this the task of MindTheGapps? I wonder, why I see so many access rights problems regarding system apps like Play-Store, SystemUI and TelephonyRegistry. I have the impression, that some important events/informations are not getting to the relevant apps, so that the system gets unstable.

So it would be interesting, whether these problems are caused by the interaction between MindTheGapps and LineageOS for Fp3+. In this case, it would be interesting to know, which alternative GAPPS-Package is compatible with Android 12 and causes no/fewer problems.

I used Open-Gapps for other devices with former Android versions. But as Open-Gapps is still not officially supported for Android 12, this seem no suitable choice to me.

Any recommendations? - and howto for switching of gapps version without losing my data?


1 Like

Not quite sure about the real cause, but could be related to the security fixes inside this build which cause problems at least for the MindTheGapps package.

I heard about NikGApps, but I don’t know if this package didn’t also have this problem,

Personally i wouldn’t advise to switch to a new Gapps supplier if you don’t want to do a full wipe and a clean install. Otherwise you have old configs and scripts which can cause problems in the future. As far as I know, removing the left data by hand isn’t an option without a TWRP recovery, where you got full access to the root filesystem.

1 Like

Hi everyone. My phone has been stuck in bootloader since last update. Trying to adb sideload the update would not work, and the fastboot set active partition isn’t working either. I am getting a bit desperate here, I am afraid my phone is bricked. Can somebody please help me?

Where exactly do you get stuck? Can you describe it a little bit more?

Can you reboot to the recovery to sideload the image, so you can follow my workaround?

I get stuck at each and every phase. If i try to reboot, I get stuck at logo image. If I go to fastboot mode, I cannot change partition from a to b (command would not work). I also tried flashing the image through fastboot but got stuck to bootloop again.
In recovery mode I tried both to reinstall update and image using adb sideload. In the first case, stuck again to bootloop. When trying to flash image, here’s whay I get:

adb sideload lineage-19.1-20221114-recovery-FP3.img
serving: ‘lineage-19.1-20221114-recovery-FP3.img’ (~0%) * failed to read command:

Then nothing happens. P.s. I use NikGapps, not MindGapps.

When in fastboot mode, what does fastboot devices show? Does it list your device?

Seems like adb get a timeout, this is normally a sign that adb is not active. After selecting recovery mode and after it’s loaded, did you select the “Apply update” option. Only after that the adb sideload command can upload an image.

If it worked, don’t forget to also sideload the “old” NikGapps package, otherwise you will get stuck into bootloader animation again.

When typing fastboot devices, it lists the serial number corresponding to my device.

Pertaining to adb, yes I selected apply update before trying to upload both image and update. I tried again and got the same error message. I am really lost here, nothing seems to work.

What do we mean by ‘old’ NikGapps package btw?

Does adb devices list anything? Otherwise adb seems to be disabled.

You will have to flash the NikGapps package over the old one to reset the Google Apps to standard settings and get around this boot loop.