English

Official LineageOS 18.1 for Fairphone 3/Fairphone 3+

Didn’t you download the install file to somewhere? The package would be in the filename.

Else … Here’s a comparison of the packages … Package Comparison · opengapps/opengapps Wiki · GitHub … perhaps something from the chart is obvious on your phone.

Else … Select the desired package on opengapps.org and then download “VERSION INFORMATION” (comes as a text file for the selected package).
This will give you a list of package names which get installed with the package, you can compare the ones which are different from package to package with what you have on the phone.

1 Like

Thanks for fixing the BT issue.

Can you please add a “known issues” section to the first post? I read through a lot of messages here complaining about brightness issues and boot loops. I’m not sure, if I should upgrade already. Thank you. :heart:

3 Likes

Hi, maybe somebody else also has this problem. I experienced massive performance hits when using data from an sd card. Especially navigating apps, and my newspaper, which stores its daily doese in many little files were a pita using.
I stumbled about https://www.reddit.com/r/LineageOS/comments/p7inuy/awful_storage_performance_on_181/ where a few people complained. Just now I did the recommended change: adb shell setprop persist.sys.fflag.override.settings_fuse false
and it really feels usable again.

2 Likes

Interestingly, my issue with the camera app is back after the last update of LOS4microG (September 3rd).
It seems, that in one of the slots it is working and in the other one not.
Whenever I open OpenCamera, I get the following screen:

In the settings, Camera is present but can’t be started:

Today I have tried to migrate the apps data to the SD card but the procedure doesn’t and pressing on the “start migration” (or however is it called in English) doesn’t do anything. Is this a known issue?

Hi All,

For the auto bringhtness issue. I think I have found out a solution for this. Have a look at this. Solution is to set minimum to 10(so that array starts from 10 as the first value) and dropping config_screenBrightnessSettingMinimum.

I have been using it from past 2-3 days and seems to work.

Let me know your feedback. If fine I shall submit the change.

Thanks,
TeamB58.

7 Likes

Hi!
I’ve just built my own 18.1 image. I’m able to flash the image itself. After rebooting to 18.1 recovery mode, I’m neither able to flash opengapps nor magisk. Sideload always reports an error, and the device isn’t visible anymore via adb devices.

Regards,
Alex

Hello, I have flashed LOS4uG and successfully rooted it with Magisk.

I have created a work profile with Insular. I have the Rooted debugging option active.

After I run adb root from my terminal I expect to be able to run adb commands as root, but I get permission denied when I try to push/pull files from /storage/emulated. In particular I would like to push my backup (/storage/emulated/0 and /storage/emulated/10 folders, but there is no way to do that up to now.

I haven’t found anything on the internet, does anyone know any workaround? Also I am xperiencing some LED flickering on the flashlight (was experiencing it even on LOS 17.1), is it only me? I can confirm the LED flickering is due to LOS, since when I flashed stock OS there was not any flickering.

Hi, I just realized that the same issue exists for me. My navi app is just incredibly slow. Is there a way towards fixing this in the official builds?

Cheers

Anyone else experiences strange issues with file system permissions? Some apps behave as always, some apps have certain restrictions (which seems to be the "new normal "with 11), some just can’t access anything on storage, even though they got permissions granted (notably FolderPlayerPro).
Also, settings declaring to not enforce access rules for external storage seem to have no effect. At least, i can see no difference…

Just realized this seems to have a big impact on media scanner services… Looks like they simply don’t scan any longer.
Music players, such as simple player, or FolderPlayer, can’t detect (new) tracks, or music at all. VLC still works as expected.

@TeamB58, @dk1978 : do you know something about this effects?

Yesterday I upgraded from 17.1 to 18.1 without any problems or data loss. Thanks for your work, @dk1978 and @TeamB58!

Unfortunately I just discovered another issue regarding brightness. I have been using the function that allows you to adjust brightness swiping over the status bar since 17.1. As soon as I reach the top left corner now (which equals minimum brightness) the brightness jumps up to maximum right away. Anybody else with that problem?

After todays update magisk is gone. I have the app and zip-file from magisk.me. The app showed me that it is not installed, Had to flash the zip-file again. Magisk is working again. But I don’t know why it didn’t survive this update.

My tablet has also LOS18.1 with magisk and there it survived the update.

Magisk isn’t supposed to survive OTA-updates without doing just a few extra-steps, according to the documentation you have to:

  1. Restore your system-image
  2. install OTA-update (DON’T RESTART)
  3. Install Magisk to the updated slot
  4. Restart

It is just that it survived every update. But not the one from today.

Currently on the 03/09/21 microg build.

  1. My phone likes to not respond when it gets to low battery, around <10%. The other day I had to force restart by holding the power button as charging didn’t wake it.
  2. Not sure how best to describe it but I think I sometimes get “soft reboots” where the OS refreshes.
  3. The camera viewfinder is oversharpened and shows moire-like effects. This may be because of the FP3+ camera module downsampling?
  4. Citymapper refuses to move past the splash screen for me
  5. Is there any way of having the screen turn on for a second when a notification comes in?

On the whole I’m very happy with this though, so thanks!

#5. would be interesting for me, too. I’ve got this issue since LOS17µG.

Additionally, the battery discharges twice as fast as before this update. It’s like it was with LOS16µG. Maybe this fits with your #2. But I didn’t notice anything similar.

My battery wasn’t <10% but I’ll observe this.

Can’t conform #3. (no FP3+) and #4.

Strange: On one of the two slots, the install to inactive slot option disappears as soon as the first two steps are performed. I have to then sideload and install the magisk zip from recovery.

This happens only on one slot. So, i have to do this every second week.
Anybody experiencing the same?
More importantly, any idea why and how do I fix it?

#1. confirmed! Same issue.
Is a downgrade to the LOS17µG version before possible without any issue like upgrades are?

Excellent list, experiencing issues 1, 2 and 5 too.

If I may add a number 6: in LOS16.0 (not sure about 17.1) if my phone battery died it would still try to boot if you had set an alarm. E.g. if my phone would run flat during the night, it would still wake me up in time for work :slight_smile: