Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

+1 from me on the nightlight. I’m also with gapps and the greyscale option in the digital wellbeing app isn’t working which is probably linked to the same issue since it sounds like all the display and colour adjustments are broken. Look forward to a fix sometime :wink:

I switched from /e/ to LOS-microG17.1. Unfortunately I read too late, that TWRP should not be installed. Now I get at every startup the message “Your device software cannot be checked for corruption. Please lock the bootloader”, and after 5s it boots.
Is there a way to undo this step of installing TWRP? How can I get rid of this message?

Thank you very much!

Hi Klaus,

actually - I don’t have a backup. I just thought, it’s an upgrade and a standard procedure.
Switching the slot with fastboot doesn’t get me any further. It’ll get me back to recovery on Slot B (LineageOS 16.0-20201210-microG-FP3).

Slot B brings me to recovery of LOS 16
Slot A to recovery of LOS 17.

Did I accidentally upload the recovery zip? Just checking…
No. Checked name and size of the zip.

Is there any chance to get back to LOS16 at least :frowning:

Was re-locking my bootloader a bad idea with stock LOS17.1, will this interfere with OTA updates or risk bricking?

After some searching I think this is the case, but if anyone can confirm this it would be nice, as unlocking and restoring user data after the factory reset will take me some time.

Do i understand you correctly that a normal boot brings only the recovery? Even in the slot for los16?
I’d try installing 16 anew, probably after making a data-backup with twrp

Exactly.
I just decided to do a “facotry data reset”. This might be the fastet way to get it running again.
My contacts and calender are on my home server, so there is no big loss.

Thank you anyway!

This has nothing directly to do with TWRP.
If you do an OS-update, your recovery partition with TWRP will be replaced by LOS-recovery.
(You can also do this by manually installing the recent microG-LOS version either through Settings -> System -> Advanced -> Updater or even with TWRP (adb sideload))

I assume you had to unlock the bootloader with the command fastboot oem unlock?
You can try to relock the bootloader again with the command fastboot oem lock
To do so, you have to boot into the bootloader.
That worked for some useres here. But be aware that this won’t work if you have rooted your phone. And it will wipe your data partiton (you’ll loose all your data). So make a backup first :wink:
I have a rooted phone and prefer to do backups with TWRP so I can’t lock my bootloader.
(You can boot directly into TWRP without installing it with the command fastboot boot twrp-3.5.0_9-0-FP3.img

1 Like

Thank you for your answer.

Yes, after the LOS installation TWRP was replaced by the LOS recovery.

I thought that by installing TWRP the file format of the recovery partition changed which would not happen if you just sideload but not install TWRP.
Is this correct?

Does it mean the message “Your device software cannot be checked for corruption. Please lock the bootloader” pops up for everybody who uses LOS?

I thought locking the bootloader is not recommended for LOS?

I did not root my phone.

Yes, with the installing of TWRP, the recovery partition was changed. I don’t know what you mean with format, though.

Just to be sure: Are you talking about this warning?


Yes, this is warning pops up for all who have unlocked the bootloader.

Take a look here:

It works at least for some users here…

2 Likes

I get a slightly different warning:Image 1-18-21 at 12.38

Should I still proceed with locking of the bootloader as you suggested? The warning seems to be very similar to yours. Do you know why I get a different warning? Could it be relating to rooting the device?

Sorry to ask again, I didn’t understand it fully:
It is not possible to install LOS without getting this message, right?

Thank you!

I don’t know why you get this slightly different warning.
The worst that could happen, is a non working LineageOS, forcing you to reinstall it.
But since relocking the bootloader will wipe your data partition anyway, this wouldn’t be that tragic.

If your error message is definitely the same like mine: It should be possible to get rid of this warning with relocking the bootloader. I think that’s what @Micka (I’ve quoted his post above) was able to do.
But first, you must get rid of TWRP on both slots (slot A and slot B), otherwise neither the OS nor the recovery will boot and you get this warning:


Be aware that after locking the bootloader you won’t be able to even boot into TWRP with fastboot boot TWRP.img command.

2 Likes

Thanks!

How I can get rid of TWRP on both slots? Is there somewhere an explanation on how to do that?

Hello everyone, I just switched from lineageos 16.0 microg to lineageos 17.1 microg but the calling doesn’t works, so I flashed the last modem from here and now the calling works but not the 4G. Can you give me a modem which work for both please ? Or any workaround ?

I already make many hard reset with and without microg but still the same.

Edit : I fixed the issue by flashing the modem of FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage-repack3.zip.

There are a few different ways

To check both slots:

  • Boot from bootloader into TWRP (fastboot boot TWRP.img), go to Reboot -> Switch slot and then Reboot -> Recovery
  • Boot into bootloader and type fastboot getvar current-slot
    This will report you the currently active slot.
    With fastboot --set-active=<slot> (replace <slot> with the currently not active slot) you can change the active slot.
    Then, boot into recovery.

To change the recovery:

  • Boot into TWRP -> adb sideload lineageOS-17.1.zip, then Reboot -> Switch slot, adb sideload lineageOS-17.1.zip again.
    You might also flash the LineageOS recovery image seperately.
  • As mentioned above, this should also work if you manually initiate an update Settings -> System -> Advanced -> Updater (to reflash both slots, you might have to do that two times…)

Also thanks for the info @HolosericaCaligo! I just asked the same about relocking above, didn’t see the post from @Micka from november where he locked LOS16 and was able to update.

@os01: I relocked my bootloader and can confirm that after this my LOS17.1 booted without the “The boot loader is unlocked” warning, but now I’m curious whether updating LOS will work OK.

Some questions, maybe someone can clarify it for me :slight_smile:
I’ve read relocking the bootloader has some security advantages, I guess this helps against rootkits or someone being able to TWRP backup your personal data if your device gets stolen?

So the downside is that TWRP backup also doesn’t work for the owner, and a rooted OS won’t work either. I didn’t root but sideloaded some system apps (F-droid PE and UnifiedNLP), my LOS boots fine relocked. And if I understand @HolosericaCaligo correctly, for me worst case a LOS update could break the OS, after which I can still use the recovery to reinstall stock, losing my data if I haven’t backed up first.

Oh, does that “Your device is corrupt. It can’t be trusted” error when locking with different slots mean a brick or can that also be fixed, does fastboot still work then?

You could try it yourself.
Either boot into recovery and try adb sideload LineageOS-17.1.zip
Or manually trigger an update at Settings -> System -> Advanced -> Updater
It doesn’t matter if there’s a new version available or not. You can also “update” the already installed version.

Yes, I think those are some of the advantages.

Yes. Or at least fastboot should still work :slight_smile:

That was my FP3. And yes, fastboot/bootloader was still working. I just had to unlock my bootloader again. But that was somehow to be expected since I’d rooted my FP3 :see_no_evil: :grin:

2 Likes

Thanks for the info! I will try an OTA, after a backup just to be sure :slight_smile:

I already wondered if the photo was your device, quite a scare I guess :see_no_evil:
Nice tot know fastboot still works in that case!

1 Like

Has anyone managed to upgrade from LOS 16.0 to 17.1, both official or microG, without loosing /data?

I get push notifications about upgrading official Android for FP3. How come? I’m on LOS 16.1.

Some of us saw that, too… Would not work, though, and disappears after an update, if i remember correctly (you’re on los 16 official? )