Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

Just a quick FYI for those interested:
LOS4microG 17.1 has officially landed over here: https://download.lineage.microg.org/FP3/


I’ve been through the instructions and install, but after install and reboot my phone seems to stop at the Fairphone logo on the boot screen and doesn’t actually boot into lineageos. Any thoughts?

[Edit: Think I fixed it, used a different build]

I’m using my FP3 with LOS and MircoG since it was available at lineage.microg.org.
I had almost no problems with installing LOS 16 and it runs very smoothly since.
(Except Fennec. It keeps crashing without any pattern - but that’s for another time.)

Today I’m trying to update to LOS 17.1 with this manual:

And I fail with ADB. When I try to sideload the ZIP-package, I get an error:

C:\Program Files (x86)\ClockworkMod\Universal Adb Driver>adb sideload lineage.zip
error: protocol fault (no status)

After a few minutes, the blank screen of the FP disappears and I’m in LOS recovery. Tried to activate sideload again via “apply update” but didn’t get any further.
I also copied the ZIP onto the microsd - maybe the recovery mode accepts the file via “apply update” somehow, but “Apply from ADB” is the only option…

So I cancelled the upgrad for today, restarted into LOS 16 and deactivated debugging mode.

Version of ADB: platform-tools_r30.0.5-windows.zip

The directory you executed adb in is the ClockworkMod\Universal Adb Driver directory, though. Did you extract the current platform tools to there or did you add the path to the platform tools to the PATH variable and there’s no (perhaps old) adb command in ClockworkMod\Universal Adb Driver?


Yes yes and yes.
That was a bit stupid.
I’ve flashed Cyanogen for a friend 5 years ago.
So I was in the wrong program folder.,

Anyway, got it sideloaded. Pressed “reboot” in the menu, cause…

"Once you have installed everything successfully, click the back arrow in the top left of the screen, then “Reboot system now”.

…wasn’t visible.

The FP tried to boot, but got stuck with

Can’t load Android system. Your data may be corrupt. If you continue to get this message, you may need to perform a factory data reset and erase all user data stored on this device.


Edit: But the recovery mode tells me I’m in slot a now with version 17.1…

8 posts were split to a new topic: Issues with push notifications on the LineageOS MicroG version

I had to wipe data going from 16 to 17. This might be the case here, too. I hope you have a backup? Else you might try switching slots and boot the old system

+1 from me on the nightlight. I’m also with gapps and the greyscale option in the digital wellbeing app isn’t working which is probably linked to the same issue since it sounds like all the display and colour adjustments are broken. Look forward to a fix sometime :wink:

I switched from /e/ to LOS-microG17.1. Unfortunately I read too late, that TWRP should not be installed. Now I get at every startup the message “Your device software cannot be checked for corruption. Please lock the bootloader”, and after 5s it boots.
Is there a way to undo this step of installing TWRP? How can I get rid of this message?

Thank you very much!

Hi Klaus,

actually - I don’t have a backup. I just thought, it’s an upgrade and a standard procedure.
Switching the slot with fastboot doesn’t get me any further. It’ll get me back to recovery on Slot B (LineageOS 16.0-20201210-microG-FP3).

Slot B brings me to recovery of LOS 16
Slot A to recovery of LOS 17.

Did I accidentally upload the recovery zip? Just checking…
No. Checked name and size of the zip.

Is there any chance to get back to LOS16 at least :frowning:

Was re-locking my bootloader a bad idea with stock LOS17.1, will this interfere with OTA updates or risk bricking?

After some searching I think this is the case, but if anyone can confirm this it would be nice, as unlocking and restoring user data after the factory reset will take me some time.

Do i understand you correctly that a normal boot brings only the recovery? Even in the slot for los16?
I’d try installing 16 anew, probably after making a data-backup with twrp

I just decided to do a “facotry data reset”. This might be the fastet way to get it running again.
My contacts and calender are on my home server, so there is no big loss.

Thank you anyway!

This has nothing directly to do with TWRP.
If you do an OS-update, your recovery partition with TWRP will be replaced by LOS-recovery.
(You can also do this by manually installing the recent microG-LOS version either through Settings -> System -> Advanced -> Updater or even with TWRP (adb sideload))

I assume you had to unlock the bootloader with the command fastboot oem unlock?
You can try to relock the bootloader again with the command fastboot oem lock
To do so, you have to boot into the bootloader.
That worked for some useres here. But be aware that this won’t work if you have rooted your phone. And it will wipe your data partiton (you’ll loose all your data). So make a backup first :wink:
I have a rooted phone and prefer to do backups with TWRP so I can’t lock my bootloader.
(You can boot directly into TWRP without installing it with the command fastboot boot twrp-3.5.0_9-0-FP3.img

1 Like

Thank you for your answer.

Yes, after the LOS installation TWRP was replaced by the LOS recovery.

I thought that by installing TWRP the file format of the recovery partition changed which would not happen if you just sideload but not install TWRP.
Is this correct?

Does it mean the message “Your device software cannot be checked for corruption. Please lock the bootloader” pops up for everybody who uses LOS?

I thought locking the bootloader is not recommended for LOS?

I did not root my phone.

Yes, with the installing of TWRP, the recovery partition was changed. I don’t know what you mean with format, though.

Just to be sure: Are you talking about this warning?

Yes, this is warning pops up for all who have unlocked the bootloader.

Take a look here:

It works at least for some users here…


I get a slightly different warning:Image 1-18-21 at 12.38

Should I still proceed with locking of the bootloader as you suggested? The warning seems to be very similar to yours. Do you know why I get a different warning? Could it be relating to rooting the device?

Sorry to ask again, I didn’t understand it fully:
It is not possible to install LOS without getting this message, right?

Thank you!

I don’t know why you get this slightly different warning.
The worst that could happen, is a non working LineageOS, forcing you to reinstall it.
But since relocking the bootloader will wipe your data partition anyway, this wouldn’t be that tragic.

If your error message is definitely the same like mine: It should be possible to get rid of this warning with relocking the bootloader. I think that’s what @Micka (I’ve quoted his post above) was able to do.
But first, you must get rid of TWRP on both slots (slot A and slot B), otherwise neither the OS nor the recovery will boot and you get this warning:

Be aware that after locking the bootloader you won’t be able to even boot into TWRP with fastboot boot TWRP.img command.



How I can get rid of TWRP on both slots? Is there somewhere an explanation on how to do that?

Hello everyone, I just switched from lineageos 16.0 microg to lineageos 17.1 microg but the calling doesn’t works, so I flashed the last modem from here and now the calling works but not the 4G. Can you give me a modem which work for both please ? Or any workaround ?

I already make many hard reset with and without microg but still the same.

Edit : I fixed the issue by flashing the modem of FP3-REL-Q-3.A.0033-20200815.010936-user-fastbootimage-repack3.zip.