English

Issues with push notifications on the LineageOS MicroG version

I switched from 17.1 GSI with microG to Off17.1 with microG.
Finally A2DP is working again.
But I’ve got trouble with microG Cloud Messaging. No App connects to it.
The push notification tester app leads to a red cross at “Register for Push Notifications”.
Even the checkin dial (* # * #2432546#* # *) doesn’t help.
Does anyone have similar issues?

I have the same issue as ‘in-go’ with GCM. I just did a fresh install of the latest Lineage with MicroG (17.1) ROM, and I also can’t make GCM work anymore. However, this seems to be a microG 0.2.16+ issue rather than Lineage. From what I read in these two GitHub issues, it seems it does work but is extremely slow (1+ day):

Downgrading to 0.2.15 should help apparently, but I don’t think we can easily do that since it came with 0.2.17. I tried adb install -r -d com.google.android.gms-204713030.apk but after reboot the version still says 0.2.17.

1 Like

Just for Information: Before installing I did all the wipe/factory reset/format, too.
I’m just using Titanium Backup to get back data off some apps.
Trying to downgrade to 0.2.15 with f-droid lead to an error.
I’m installing everything in the hope, there will be an update soon which fixes this topic.

I also had issues (none of my apps could register to GCM) with microg GCM and could solve it by doing this:

  1. Delete cache and data of microG Services Core and reboot.

  2. Activate Device Registration in microG and reboot.

  3. Activate Cloud Messaging and reboot.

  4. Delete data and cache (or reinstall) of apps that should use GCM and start them.

  5. It worked.

3 Likes

That’s what I did a few times… without success.
But now it works without doing anything. Maybe the 1+ day is reached…

Hi !
Is anyone else having issues with push notifications on the MicroG version ? None of my apps can register in GCM, not event after dialing the *#*#CHECKIN#*#* code, rebooting and reinstalling apps. The app “Push notification tester” shows a red cross on “Register for Push Notifications”, and none of my apps can use them.
Even weirder : in the microg settings, the switches to register my device with google and to enable GCM reset to false everytime I reboot.
Everything works OK on /e/OS, but I would like to stay away from it, for personal reasons and because they disabled the gesture navigation controls, which is a feature I also love :wink:

Hi dotsumae.
Some of us had same issues.
Look about january 17th of this thread.
Maybe the five steps manual from E7buX8d works for you.

5 Likes

Yes they did work :o
Thanks a lot ! I hope you found a way to make GCM to work.

1 Like

I’ve moved all your topics concerning GCM on LineageOS from the long LineageOS 17.1 for FP3 here.
I hope this way the topic is not lost in the long development topic and it can be found easier by others facing the same problem.
Hope that’s ok for you . Please send me a note in case I missed a post when moving…

3 Likes

I faced the same issue. I tried several things and also checked the mentioned issues on github. Suddenly it started working.
I had the feeling that it was as soon as I enabled developer mode (repeatedly pressing build number), but this could be just by random.

Hi,
I have installed the latest LineageOS for MicroG (20210414) on my FP 3 and managed to register some apps to GCM (thanks to E7buX8d!). I’ve tested it by using “Push Notification Tester” app, which said that everything is working fine and sent me notifications to confirm this - one immediately and one with a scheduled delay of 5 minutes. But nevertheless, I don’t see any notifications from other apps, although some of them usually send a lot.
And - curious enough - when I opened MicroG settings again this morning to check the respective settings, it showed that actually these apps did send notifications, but they didn’t show up. (see screenshot).


So what’s wrong?

Did you try the suggested solution?

Yepp, that’s why I wrote “thanks to E7buX8d!” (the user who posted the solution).

But meanwhile it seems to me that one more reboot may have fixed this issue as well. At least, I can see some more notifications from different apps now. I’ll keep an eye on it to see if they are complete now.

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.