Notification for incoming call delayed

Hi,
since a few weeks, I have a problem with notifications for incoming calls. The phone starts ringing but it takes a few seconds until the notification is shown telling me who is calling and allowing me to answer the call.
I’m using the conventional Google phone app and it has all authorisations. I have uninstalled all updates but that didn’t help. I also have tried another phone app, that didn’t help either the problem was the same. The problem does not exist for incoming calls in Threema, the notifications for these calls are shown immediately.

I have no idea how to tackle the problem and only found one message in the forum with a similar problem (🇩🇪 Verzögerte Anzeige von Anrufen) but it received no answers. Has anyone an idea how to fix this?

Thank you in advance!
Stefanie

Is it always or only when connected to a Bluetooth Device?

1 Like

Thank you for replying.

No, it’s unfortunately always the case.

You might have a look at adb logcat. But this imho needs a little bit of technical deep dive…

1 Like

I have the delay of the call notification bar too, but only when bluetooth is enabled and a device reacting on phone calls ist connected (Smart Watch, Car). With BT disabled, I have no delay.

1 Like

Thank you, I had a look but didn’t really understand what to do… Do I understand correctly that this isn’t an app to be installed but something in the phone’s software?

I just noticed that I don’t have the problem anymore when I switch off Bluetooth. Some other entries in the forum mentioned that they have the same problem when connected to a Bluetooth device. As I was never connected to a Bluetooth device when the notification was delayed I thought that my problem is different until now. However, it indeed seems to be related to Bluetooth, independent from whether a device is connected or not.

Thank you. I also just noticed that I don’t have the problem anymore when I switch off Bluetooth. As I was never connected to a Bluetooth device when the notification was delayed I thought that my problem is different. However, it indeed seems to be related to Bluetooth, independent from whether a device is connected or not.

I would prefer to keep Bluetooth enabled all the time to connect quickly to my headphones. But if there’s no other workaround, I guess I’ll deactivate Bluetooth for the time being.

Well, it’s not really in the phone’s SW and no app (although an appropriate app like “MatLog libe” might also be used) but rather a possibility to get logs from the phone using e.g. a PC.
You find more details e.g. here:

1 Like

I just noticed that I don’t have the problem anymore when I switch off Bluetooth. The thread you mentioned was about people having the same problem when connected to a Bluetooth device. As I was never connected to a Bluetooth device when the notification was delayed I thought that my problem is different until now. However, it indeed seems to be related to Bluetooth, independent from whether a device is connected.
I hope the problem will be solved some day. Thank you for your help!

Thank you, I’ll have a look!

1 Like

You have to tell support, so that they are aware