English

Noisy coloured pixels on my Fairphone 2

touchscreen
Tags: #<Tag:0x00007f9ffcbe7320>

#42

As mentioned by others above: the problem is a lack of connection between mainboard and the display.
I fixed it be opening and reclosing the blue gates, once you open it and take out the battery.


#43

Hi! Sorry for the lack of answer, i had absolutely no time to come here in the last few weeks.

My problem got solved. Not by myself, though. I tried (almost?) everything on this thread, up to the hard reset, but nothing worked. I contacted one of the team members who is on the forum, and after his intervention, i got an answer from the support. From there it went pretty fast, they changed my phone, and i have a new one, which is fully functionnal, and has been for the past few weeks.

The only comment i’d have is that they changed everything, up to the outer case, which was probably not in question here… but that’s the subject of another thread, i guess ^^
I don’t know exactly where the problem was, in the end…


:fr: Fairphoneurs sur PARIS
#44

Thanks for answering, don´t worry about the time it took.

Yes, my first little problem was the seal around the camera modul.

When I asked for it to be replaced, they sent the whole back cover again… Not much about “only replacing what is really necessary…”.

My phone is worse and worse, I am tired of having a not working phone, when I try to use it. I hope to get it exchanged, too. Do you think I can just send it in like that?

Where did you send it to? Maybe I can just send it there, too.

Thank you so much already!!! Hope you are still satisfied with the new phone?


#45

No, you have to get in contact with support first. If you have already opened a ticket and are waiting for a reply, a phone call or a post in this topic Support request not answered yet might speed things up.


#46

Hello all,

Just for the sake of heightening the visibility of this problem, I’m gonna add to this post that I’m experiencing a similar problem. I don’t always have the full-screen noise, but something much more fancy: the items on the screen move and tremble and part of the screen is full of noise pixels. I want to add that I paid attention not to drop my phone and that I don’t keep it in a leg pocket. The problem occurred for the first time after a transatlantic flight 2 weeks ago and has not disappeared since. I was smart enough to take my old phone with me as a back-up and I haven’t used my FP2 since.

I’ll submit a support ticket after this post as I don’t feel like wasting hours on cleaning and resetting the phone only in order for it to not work. So thank you all for trying so hard and taking this hope from me. :>

Picture towards the end of FP2’s booting:


#47

Picture a few seconds later:


#48

I’m also experiencing this. Asked the support about it, didn’t got a reply… Has anyone already been able to fix the issue?


#49

In the hope that this will raise the profile of this issue, I am also having this problem as of today! I will send a support ticket now and post again if a response comes through. As suggested in this Fairphone 1 post:

I pinched around the side of the phone which has temporarily corrected the problem. Not sure how long this will last for.


#50

The fact that pinching the edges helped you indicates that there is no “real” hardware issue but rather a bad connection. If the problem comes back please try disassembling the screen and carefully cleaning the connectors.
Also if you haven’t sent your support request yet may I kindly ask you not to do so? Support is suffering from an enormous backlog and - if at all possible - should not be bothered with issues that have been sorted out already.
Also, don’t worry: this issue is on the #commonissues list and therefore Fairphone is aware of it.


#51

Hi,
I have the exact same problem with the screen. It started a few days ago (sometimes the colors were suddenly reversed; it showed grey ‘noise’ like a television without signal; the screen was overly - more than normal - sensitive; it showed only half of the screen or it was flickering/moving like crazy). In between, the phone worked fine.
Since yesterday, the only thing it is showing is nothing, and once in a while the grey noise. The system seems to work properly, though.
Since a lot of people have the same problem here, it seems to be a malfunction - does anyone already have an official reply of the Fairphone organization, or a longterm solution?


#52

A lot is a relative term. Compared to the number of FP2s sold very few people have this issue and usually it’s solved by taking off the screen and cleaning the connectors. If that doesn’t help then the screen could be defect, in which case you’ll need to contact support. But first please try to clean the connectors.


#53

Judging by the significant number of people whose posts indicate that it did NOT work, I’m not sure if this is the best idea. I read through the entire thread and the success rate of disassembling and reassembling seemed pretty meager. In addition, one forum user indicated that the FP2 team gave them a hard time for trying to fix it themselves.

It’s been three weeks now that my request has been open and I have not heard back from anyone.


#54

I would say, disassembling is always worth a try as it helped some, doesn’t make anything worse, and just takes a few minutes. Remember, the phone was build to be easily taken apart, and for removing the screen you don’t even need tools.
But of course, it’s your decision to try it, but it takes a moment compared to 1 or 2 weeks for repair when you send it in.


#55

I have the same problem. My roommate does too. Our phones a completely useless as it is now. Have anyone here got a response from the support team about what to do? I do not get the impression that disassembling helps from what you all write!?


#56

When you say “sorted out already”, what do you mean? What is the solution?


#57

I was replying to someone who didn’t have the issue anymore after pinching the screen.

If taking off the screen and carefully cleaning the connectors doesn’t help then it’s probably a hardware isse, but please try cleaning first.


#58

Thank you for your answer :slight_smile:


#59

I have a Fairphone2.
Very irregularly, but also quite often, when I want to use it, the screen is grey with millions of dots.
To gave evidence, I made some picture but this list does not allow attachment.

The phone is NOT usable then. This is extremly disappointing for me, because i thought I get a reliable phone when investing 500+Euros!

Also, I do not find any address to send it back for repair
I am still within a warranty period, and if this problem does not get fixed I want my money back.
Where can I turn to??


#60

I have the same issue as everyone else here along with a few others. I’ve submitted tickets twice for various issues 2 months ago and I’ve had no reply. Disappointment with the product and service doesn’t even begin to describe what I’m feeling at the moment. I spent a considerable amount of money on a Fairphone and now I’m going to have to buy another phone while I wait to see if I get any response from the manufacturer…


#61

You’ll want to contact official support. You can file a ticket here (huge backlog, so takes ages), or call them (scroll all the way down for number/times, juts above the grey bar at the bottom of the page). Sending the phone to a random address will just delay matters as it won’t be processed correctly. If you received the phone less than two weeks ago, you can arrange to return it for a full refund if you prefer that to a repair (no reason needs be given, but the phone should be good-as-new). If you’ve had it longer, you can arrange for a repair under warranty.

As mentioned in some of the posts above, in some cases it’s a case of problems with the connector that can be solved by taking the screen off and putting it back on again. Worth trying especially if you’re in a rush.


Fairphone really has to sort out its warranty support