Noisy coloured pixels on my Fairphone 2

I think it can be done, but the thing is probably pretty technical.

You can flash TWRP, boot it, and dd if=/dev/random of=<path to mapped userdata partition> through adb shell. Don’t forget to mkfs.ext4 <path to mapped userdata partition> after that, so the new owner could use it fine.

Alternatively, you can do that on a file instead of TWRP (if you have ~60 GB sparse on you computer), and later convert it to a sparse image with Android SDK’s img2simg and flash it with fastboot. Something like (pseudo-code):

$ PARTITION_SIZE=`fastboot get-size userdata` # I don't really recall this subcommand
$ dd if=/dev/random of=random.img count=$PARTITION_SIZE
$ img2simg random.img random.sparse.img
$ fastboot flash userdata random.sparse.img

(Then you should create another img file, empty this time, mount it in the loop device, mkfs.ext4, img2simg and flash it with fastboot.)

The TWRP/on-device option is more straightforward, though.

Disclaimer: this is all experimental and I can’t really offer any guarantee. But I really think it is doable. I did some dding on-device to wipe the encryption headers (as explained on another post here in the forum) and flashed some custom sparse images when I tinkered with self-built FP Open and porting CyanogenMod.

Hey axcro,

Here is how I’m managing the pressure of the connector. Simply some paper taped between the protection and the core module.

Untitled

Thanks a lot for keeping us up to date with your other experiments. My solution works like 70% of the time. When it’s not working I’m simply pressing hard with my hand trying to keep calm and then it works for a while… I think all in all it improves my patience skills a bit.

4 Likes

Hi @Roboe,
I didn’t get it done with fastboot but with adb. (Actually I didn’t take the time to figure out the missing parts of your pseudo code :wink: )
Here is what I did:

  1. fastboot erase - some people say this is enough to securly wipe your data, but I have my doubt about this.
    fastboot erase modemst1
    fastboot erase modemst2
    fastboot erase cache
    fastboot erase userdata

    Link: https://android.stackexchange.com/questions/161103/what-fastboot-erase-actually-does

  2. flash Fairphone Sibon (actually this seems to perform a fastboot erase as well)

  3. I had luck that the screen was working for a few minutes so I could grant access for adb. The OS was asking me directly at the first bootup assistant, no need to go to settings.
    In adb shell I then performed the following command until no space was left:
    dd if=/dev/urandom of=/sdcard/junkfile
    This took several hours.
    Link: https://zackeryfretty.com/secure-erasing-android-devices-guide-for-the-super-paranoid-seller/
    (adb shell with TWRP didn’t work at first but since the authorisation from the OS it does, don’t know if it was my error or if I didn’t accept something due to the not working screen.)

  4. Removed the dummy/junk file(s)

I would say this is secure enough for me :smile:
The phone parts are already for sale…

@letrollpoilu: Thank you, but unfortunately this doesn’t work for me :frowning:

For my “other experiments”: I decided not to throw the PCB into the oven at all. I tried to heat up every individual pin for ~4 sec with the soldering iron (not sure which temperature my iron gets), but without any change to the phone’s behavior.

Overall I would say this problem only gets worse once it started to occur. I would advice everybody who starts to have these or similar issues to quickly backup all data and prepare an other phone for rescue.

Taking preparations for data backup and for wiping the phone is anyway a good idea for everyone :wink:

For me the Fairphone Journey has ended here. To bad it was no happy end …

1 Like

Hello everybody,

I have had the same issue here, for the last 2 months. First few glitches that were solved by restarting the phone (did not feel so different from the classic random reboot issue…)
It got worse quickly, and for me it has become obvious it was linked to heat. As the phone is prone to overheating, I am now convinced one chip got damaged with false contacts somewhere. Twisting the phone sometimes makes the screen working, but nothing permanent.
I feel that only replacing the core module would (maybe) work, but I don’t think it is worth it anymore on this phone : I would have loved to keep using it for several years, as everybody here, but a brand new recent phone is much cheaper, and my FP2 lost a bit of my trust after 3 years sometimes painfully owning it…

Just giving my feedback on the glitch, no real solution to share, sorry to say…

Cheers!

EDIT : applied the workaround from letrollpoilu, placing a filler between the case and the phone to put pressure on the pogo pins connecting the screen. Worked for some days, but now it is back to before, or even worse (I guess it forced on the pins that got broken further…).
In contact with the helpdesk, the solution is to change the full core module, so to expensive for me.
So I am out, buying another phone, see you for FP3 maybe!

Hi there.
Same here. Tried a lot. Guarantee expired. Fairphone only offers replacement of the core module for about 380€. Frustrating.
It now seems obvious that the connector pins of the core module and the contact area of the display cannot …well, connect properly (Pressing the index finger pretty hard next to the battery helps).
So either the pins should stand out more (springs inside worn out?) or the plastic parts, keeping up the pressure inside the phone, are worn out. Either way this seems to be something so simple and mechanical that there must be another solution except swapping the whole core module?
Well. I hope somebody has an idea and I will continue following this thread. With some other second-hand-non-fair-phone…

3 Likes

Hey everyone,

I have the same problems after a few weeks. Sometimes I can’t turn my mobile on, sometimes the screen stays black, sometimmes it works well, sometimes the screen starts to shake… I live in Bochum, Germany. Is here anyone near Bochum or Wuppertal, who has an FP2, so I could check if it’s a problem with the screen. If not I will send it to Fairphone I think. I tried to change the shell and do clean the contacts but nothing works. Do you have any idea? It’s nearly impossible to “work” with this phone, because you can’t be sure, if it works and for how much time.
Thanks in advance!

I moved your post here as you are talking about the FP2 and the other topic was about the FP1.

1 Like

I have the same issue. I have cleaned all contacts, the issue remains. I have tested with an old screen (broken cover glass but otherwise working), same issue. So this indeed seems to be an issue with the connection between the display and the core (or an issue of the core module). For now, whenever the screen is showing up weird / pixelized, it is enough to slighly “twist” the phone as described above; this typically leads to the screen staying properly connected. Pressing where the connectors are helps too, but I have to press constantly and VERY hard. I’ll stick with the twisting trick for now, let’s see how long that works…
This started all of a sudden, without me disassembling the phone or dropping it - on the second day of vacation, very inconvenient ;).

:warning: Disclaimer added by moderator:
This post contains instructions that will void your warranty and might be futile as the same issue can have it’s cause in a defective screen instead of the core module. :warning:


edit: so just after a couple of weeks it began again with the coloured pixels all over the screen, so the paper-trick is just to retards the problem… until now i have no idea. I’ll maybe check the oven, like ElKrasso proposed.

Hey guys!

I hope I found a solution for this problem! A couple of days before I had the same problems with the Display, like the fully coloured screen, but touchscreen and phone itself still working.

What I have done to fix it on my phone is as follows:

I disassembled the phone until the last screw to have the Core Module completely free of other modules. see picture. Then I disassembled the Core Module itself, to lift up the core and circuit board. Removing it from the Case is kind of tricky, but carefully you can manage that.

Now I placed a small piece of cardboard, like from a postcard, where the connector pins of the display (pogo pins) are fixed by 2 screws. see picture again, where it’s marked coloured. This get’s the connector pins closer to the display and gives a proper contact. To fix the cardboard in place I just taped it with a very small piece of glue strip.

That’s it. I reassemblied everything and since then I have never hat problems again.

I hope this will help you and I would like to hear about your experience with this method!

Good luck!!

7 Likes

I opened up my phone too, and dismounted all modules, but then didn’t see a way of how to remove the mainboard from the plastic bottom - how did you manage that? There are four silver screws that I saw, and one black (directly above the screen connector), but even after unscrewing all of those, the mainboard seemed connected very firmly!
There is a small slit though in the plastic, a bit above your blue rectangle, where I could squeeze in a bit of folded paper below the mainboard; and for now, this also seems to do the trick! For this, you theoretically don’t have to disassemble the modules; though it helped I would say, as I had to slightly twist the phone to be able to slip the paper in.

The black one frees the brown rubber around the screen connector. It you take it apart, the last two screws show up, :slight_smile:. This is not well explained in the iFixit disassembly guide. I (or someone else) should add that info there since iFixit is a collaborative effort.

1 Like

My screen issues seemed to be fixed for a while, but have started re-occuring; so I decided to go in and try the full disassemble to get in some more material in at the proper location.

And thanks to those details with the rubber fixation, I could this time get under there more easily! I had prodded the rubber a bit before, but it didn’t really seem loose. Now I managed to disassemble that part as well and get the mainboard loose on this side. And even though it was stuck somewhere on the other side still (approximately at the battery contacts), I managed to get in a thicker slab of paper.

However, in my case, it hasn’t improved things, it rather seems to have made them slightly worse - even setting down the phone softly on a table can trigger the screen to fail again. Additionally, sliding the display back in (when assembling the phone) seemed to be slightly harder than it previously was.

I’m not sure about the conclusion here - maybe in my case it isn’t really the display contacts at all where the problem lies, but some loose connection in the motherboard itself…?

I dried it. Doesnt work. Doesnt change anything. I share the assumption that it is not just a problem of THAT contacts. Because it helped the last weeks just when I bent the phone, nt when I give pressure on the places of that display contacts.

With the continued necessary occasional twisting, my phone now has on two occasions of twisting also decided to reboot. So I assume some battery contact is also affected now by this.

This more and more looks like a loose connection somewhere on the motherboard to me…

#contactsupport

And if you still have warranty …

Unfortunately, warranty expired beginning of last year (bought it in the initial crowdfunding). I guess I should still contact support to see what they recommend (e.g. a replacement core module?)

Yes I think the same. I dissambled everything, after the phone were not useable at all anymore. But it seems like I would need someone who explains me how the connection from the pins of the displaycontact to the motherboard works :wink:

Because its very sad, that its obviously just a contact problem and still the only conclusion is to change the whole core modul. ?

:smiley: I tried the oven!

Seems like the display works again :smiley: great! Thank you ElKrasso!

Now the phone stays at the Fairphone symbol. But I am able te reach Team Win. Seems like the 200 degree burned the OS.
I dont realy know what to do further, but I will continue reading how to reinstall the OS in TW.
Crazy journey with this phone!

3 Likes

How long did you let it stay in the oven?
You can enter the recovery?

I’m a little cautious regarding the baking:

  • First, all the places I checked on the web recommended not to use the oven for food afterwards anymore (and I don’t have a non-food oven at the moment)
  • Second, quite a few people also said that just baking like that might make your device work for a little while but the solder contacts will not be redone very well…
  • Also, I’m not sure about what was meant by “Dissemble anything you could from your core module.” - which parts from the core module can I actually still disassemble?

I’m far from a soldering expert (though I have a soldering iron), so maybe it might also work (and is safer) to just re-heat the individual pogo pins with a soldering iron? That’s what I’m probably going to try next…

But I’m very curious to hear more about whether you got your software set up again and whether it works for a longer time! Have you tried booting into fastboot (Power+Vol down)? If that’s working (you’ll see static text - Fairphone, and the phone will be reachable via USB), you should be able to flash everything else again!

2 Likes