No FP2/Android phone recognized in Win 10

Hi folks,

I’m pretty desperate because I have no clue how to solve this problem.
I updated my laptop recently to win 10 and discovered that my FP2 is not recognized anymore (worked fine with Win7). I just got the opportunity to connect to a Galaxy S7 - same behavior. I changed the cables - that’s not it. I tried different USB ports, nothing changes, same with USB debugging on/off. The device is recognized (USB connecting sound), but then it says “missing driver”. I know that there are issues with some update and MTP driver, but everything I find with google for that problem lists the phone in the device manager under “Mobile Devices” but when I look it up it is listed unter “other devices” and I don’t even have an entry for Mobile Devices. That also means that the solutions for the mentioned MTP driver problem don’t work.

All I wanna do is access the files on my phone and I would prefer to do it without additional programs/apps. It should be possible, shouldn’t it?

Has anyone an idea what I am missing here?

If it doesn’t connect to other devices, too, then perhaps it is Windows 10 N:


Yes, that is it, thank you so much!

I thought I already installed the feature pack, but I just discovered that there are different versions out there and I installed an older one which didn’t work anymore.

Installed the right one and worked like a charm!

Problem solved!