New update July 2020 - phone now won't boot

Hi. I had an update notification on my phone this morning. I agreed to the update and pressed restart when prompted. It hasn’t worked since and boots into “Team Win Recovery Project”. We’ve tried to reboot it and it either boots back into team win recovery project or just gets stuck on the start up screen. We think that there might not have been enough space on the phone for the update, and have cleared some space but that’s not fixed it. Any ideas on what else to try? Thanks very much

Hi there,
Are you under LineageOS? Normally a update of the regular OS won’t boot you on TWRP (TeamWin Recovery Project - see #twrp) AFAIK.

Hi Alex,
thanks for your reply. It was running on the OS it came with (after several of the updates that the phone prompted/recommended). LineageOS doesn’t sound familiar to me.

Ok, mistake on my side to think it couldn’t happen on the regular OS.
Please check this thread, seems to be the same problem, I don’t know if there is a solution though, but it may be interesting:

great, thank you. I’ll give it a go.

For whatever reason, it seems that Fairphone OS 19.11.2 is recently pushed (again) to people still on 19.08.1 – 8 months after it was originally released. If this is the update you were trying to install, you will most likely need to install it in a different way now. This involves a computer that your FP2 needs to be connected to in a way explained here:


But then you’ll have to do a #dic:backup, and if your phone doesn’t boot, you’ll have to do it through #twrp.

Yes and no. It’s a recommended safety measure, but in this case data will only be lost in case of an accident as this is an upgrade, not a downgrade (in which case data would inevitably be erased).



Note to others reading here: I’m starting to think Fairphone is currently pushing the most recent update (19.11.2) to latecomers again. There have been reports of this here and there in recent days. My guess: Fairphone needs all FP2 users to be on 19.11.2 to be able to (at a date not known yet) upgrade to Android 9 – more specifically: Upgrading to Android 9 will require the AOSP recovery (and 19.11.2 replaced TWRP by the AOSP recovery).


I have de same problem, how did you solve it??

With an earlier update, manual installation of the OS, as suggested above, worked for me (see here , & other messages in the topic “FP2 does not start after update”).
You may first want to try clearing the cache, though, as suggested by s99h in a later thread:

1 Like

Thanks so much both of you. My phone is much better now.



I have a Fairphone 2 and tried to install an update last week, after which the phone will only load TWRP. I have tried a manual installation, but my PC can’t find any devices in fastboot mode. I have also tried a factory reset, again to no avail. When I try to install from the phone’s cache, there don’t seem to be any available files. My computer recognises that a USB device is plugged in but I can’t access any of the files. Please help!!

Thank you,


Hi Sarah and welcome to the community forum!

I’ve moved your post here as it looks like the exact same problem. It also seems like you found advice to do the manual installation that has been marked as solution in post #6

If that fails for you, 2 questions first

  • when you tried the manual installation method, what did the phone show? Just some “powered by android” boot screen (plus maybe a blinking blue LED)?
  • what operating system do you have on your PC

Hi Ingo,

Thanks for your kind help! My PC is running Windows 7. My FP2 has successfully connected to it in the past. When I try the manual install, the phone shows the logo and ‘powered by Android’, with a blinking blue light.



1 Like

Ok, that’s correct. And on windows it should work to execute flash-for-windows.bat

When that script doesn’t detect the Fairphone in fastboot mode it often is the cable and/or USB port on the computer. You might already have tried that but I’d better mention it regardless.


Did you get a warning “No Fairphone 2 found in fastboot mode”? In case you haven’t tried that already, you could download & extract the ZIP archive again - that worked for me.

Dear all,
after the first shock, because the update from OS 19.02.x to OS 19.11.2 crashed my FP2, I could find the solution here: the manual update fixed it.
Many thanks for this advice.

The previosly mentioned method to clean the cache changed nothing.

I have two other FP2 to be updated from OS 19.02.x to OS 19.11.2.
Now my question:

Is it possible to do this update in the normal way?
Without such manual update?

Many thanks and best wishes


It should. If you open the app called “Updater”, you should see that there is an update, and be able to dosnload it.
In @LisaNewton’s case, it led to an issue, that doesn’t mean it’ll be the case for you.
Edit: It already happened with your first FP2 did it? Then I’m afraid that if the two others gurn the same (which won’t necessarily be the case), you will have to do the manual update.

Tell me if I misunderstood your message. I’m not sure this answers your question.

Thank you for your answers.

Yes, that is exactly what I have done to run in this problems.
Well I fixed it with the manually update process afterwards.

So I asked, if there is an other way to do this update right, without running in a total system crash and fix it manually again. :laughing: