New software update Kola Nut 1.8.5 is ready

Try thinking about your Smartphone as being a computer. You can have a big variety of different possible installations. Can Windows guarantee you not losing data while updating? No they can’t. They can just assure you they have done their best for you not losing your data.

Fairphone has done their best for you being able to make a backup. There is, amongst others, e.g. Titanium backup. But neither is this an easy tool, but I find all backup solutions have pitfalls. In my opinion there is not the “easy one fits all”. Some restores may fail because of different memory layout and maybe other reasons.

When updating OS while not changing storage layout I have not experienced loss of data. But I was also always successful connecting the phone to my computer when I had turned on “USB debug”. It may depend on your computer OS and its settings, too.

I have not experienced yet the Fairphone Updater App telling nothing but “Fairphone” as version number and giving details about release notes. Mine tells in the headline “Fairphone Updater” with blue thin characters on white ground, below I find (translated) “Your current operating system Fairphone Kola Nut 1.8.5 Your operating system is current”, and on the bottom it says “Are you an experienced user? Enter the advanced mode”.

Since the phone is usually charging when attached to the computer via USB, and yours didn’t do (before), I assume it was not firmly connected to the cable. Or can you try a different cable?

From my understanding the Android USB settings are irrelevant when you want to use the SP Flash Tool, the phone should still be operating in its ‘factory settings’ mode.

My point was that my ‘factory settings’ looked different than described in other place: it didn’t start into recovery mode right away but into a different menu first.

However the ADB mode was my saviour :smile: and thanks for your help!

  1. The charging problem happened independently of charger. I tried three kinds. I read that many people had this and similar problem with the charger. I tried the connection to the computer with two cables with the same result. It does not appear.
  1. read a bit about this backup on other threads just now and it seems to be a very difficult tool. And that you need to do some tricks to make it save all contacts, sms, apps etc etc. Hard to follow those tips since I am new to smartphones and would need a manual with stepwise instructions of each step on the fairphone. Does this manual exist anywhere? Is there no stepwise instruction of backup before updating on Fairphone homepage? I cant find it.
  1. to me it looks like the updater has got stuck during the udating process and is not continuing. I did give it superuser acces and it seems to remeber this but then it is stuck on that “moving ring” and please wait…

  2. I wonder if the problem could be a loss of Wifi connection at any point during the update? I have Wifi now but sometimes it does disappear and possibly it happened at some point during the update. BUT, I did get as far as re-installing google apps so I thought the update was done. Then I got a new notification of update, and then again, and now it is stuck on that moving ring.

  3. When entering system settings/Apps/ALL, I found an app called Fairphone OS 1,47 MB. When I enter this it says version 1.1. Could this be my OS? I cant see it in the updater for the reasons I said before. It is stuck. (NO IT WAS NOT SEE BELOW: )

  4. I entered the system settings/Apps/ALL/Fairphone Updater and selected “Clear data”? It stopped the “stuck” updater and now I can see that the OS is Cherry 1.6 (but still needs to know how to update step by step).


1 Like

Hi all,

We are happy to announce a fix is available for users who are unable to reinstall Google Apps after installation of the faulty Storage Upgrader 1.8.5 on the software update release day (19 May).

The fix is easy to install, just visit this link: through the standard browser on you device and you should be able to install the APK file from there. If the short url link above doesn’t work for whatever reason, here’s the full link:

After that you will see this screen:

Just press “FIX”, allow Superuser access when asked and restart your device after this.

After the restart you should be able to install Google Apps through the Fairphone Updater app as normal.

Good luck with the process, and we are sorry for the inconvenience this issue has caused some of you.




Thanks for the fix, though i’ve fixed it already using the SP-Flash-method. One question: Does this also fix the somehow ‘broken’ bootloader (no sdcard found, updates via adb quit after ~25%)?

1 Like

Thanks. The fix worked for me.


Unfortunately did not work for me… Although I haven’t been able to install GAPPS through the installer since the first 1.8 betas.

Doesn’t work for me as well… the Fix runs successfully, then after reboot I am in the same situation again. (tried twice)

I am one of those that repartitioned the phone shortly after release with the XDA method though, maybe has something to do with that?

It worked for me!



From someone totally new to smartphones and hopes to get stepwise manual instructions

  1. How can you first update to 1.8 but not the unified storage. Is it a
    two step process and you chose not to follow the second step?
  2. What does flash back to 1.6 mean and how do you do that?
  3. do you keep the sd-card in the phone while udpating?
  4. What do you mean by “sync of all my accounts manually” and how do you do that?
  5. Is textSecure an downloadable app that you use for sms and contact
    list? Why is this better? And, is this related to question 5?

Thanks for you patience

Doesn’t work fo me either. Same as @michaschm writes in his post.
Are there any other fixes planned?

ad 2) On the Fairphone manual download page you find a link to older OS versions. You can download them and install them manually - either in the recovery console, then the downloaded file has to be on your phone, or from the Computer via the tool “adb” from Google Android SDK. The process of writing the OS to your device is called flashing. You could name is “updating” as well, but this usually means flashing with a newer version. Since kbe has installed an older version, he said flashed the phone back to 1.6.

ad 3) For my flashings, I have left the sd-card in the phone.

ad 4) See your System settings -> Accounts. If you have Google Play Store installed, you’ll probably find “Google” there. If you touch this setting, you’ll see if and when it was synchronised last time. kbe said he had to turn on all his synchronisations manually.

ad 5) TextSecure can be used for sending and receiving SMS text messages as well. I don’t know if it integrates into your contact list. It is an App for instant messages, but not has otherwise nothing to do for managing your contact list in your phone. Read more details about Text Secure on Wikipedia.


Thank you for very clear explanations Amber!

Does someone have an answer to this? Thank you!

An update to Fairphone OS 1.8 is not possible. The official version is 1.8.5. The Storage Upgrader for 1.8.5 is optional, and can thus be installed separately from Fairphone OS 1.8.5.

Just to avoid any misunderstandings: The storage ugrader requires FP OS 1.8.5. ‘Separately’ does not mean that you can install the upgrader without first upgrading to 1.8.5. At least that is how I understand it - please correct me if I’m wrong.
But it is optional - if you have the original FP1 partition and are happy with it, you don’t need to do the storage upgrade.

1 Like

@kgha: I would say this is not correct. I have Cherry 1.6 installed and have the opportunity in the FP Updater to install “FP KolaNut 1.8.5” as well as the “FP StorageUpdgrade KolaNut 1.8.5” (The PreUpdate1.8.5 I have already installed and see the new UpdaterApp)

I think after the Storage Upgrade you will end up automatically with 1.8.5 (independend if you upgrade from 1.6./1.8/1.85), but you can also just install KolaNut 1.8.5 without storage upgrade. I think this is meant with “can be installed separately” from @Stefan

Actually I am not sure. I installed the Storage Upgrader for 1.6, back when that version had just been released. I vaguely remember that people who tried to do the Storage Upgrader for 1.8.5 manually before installing Fairphone OS 1.8.5 experienced troubles. Does anybody have references for that theorie?

But that was of course after installing the previous, dodgy version of the Storage Upgrader, so maybe the new version works. However, I vaguely remember having read somewhere that the 1.8.5 Storage Upgrader is different from that used for repartitioning 1.6 (which I used myself) and this of course might cause trouble.

So that the Storage Upgrader also installs the new OS version? Maybe, but if so it ought to be stated much more clearly in the support section. On this page it says that “These instructions are only applicable on a Fairphone with software version 1.8.5”.

Hey guys,

did any of you solve this in any way? Because I’m having the same problems with my phone.

Hey Anika,
what problems are you talking about exactly?
Do you get the “File not found: /cache/”. message?