New software update Kola Nut 1.8.5 is ready

I tried the SP Flash Tool solution but I can’t get it to work with my FP1.

I could install the drivers, but only when I activated the ‘apply update from ADB’ option. Before that, no USB device was visible. Is it possible that there are different FW verisions around?

When I started the download with the connected phone, then inserted the battery while holding the volume-down button pressed (I also tried the volume-up button in any combination with the power-button), a ‘Android Preloader’ briefly appeared and then disappeared again,after a second.

Any ideas why I might be doing wrong?

Ok, since, I don’t find any other topic on this update I just as well may ask here …

since the recent Software Update Kola Nut … I get constantly notifications to update Android Jelly Bean 4.2.2. the update itself doesn’t work, now reading that it is an alternative update blablabla I don’t get all the other stuff Im not a geek sorry… why the hell am I being bothered with these notifications to install it?

thanks for any help.

I am sorry but this comment is not at all helpful. Do you know language for non geek users? I hoped the Fairphone can cater these too. I have no Idea what you are talking about.

since that is happening all the time, I just tried out and installed “the old launcher” without knowing what that is because your leet speak does not explain it properly. It is all as it should be again … but I am bothered now by a “update to android Jelly Bean 4.2.2.” notification and have to constantly reinstall google app store.

IF you want to go back from stock Android to Fairphone OS use this Guide to do so:

To know which file to download check settings > storage: If you have an “internal storage” and a “phone storage” you need to install FP1_KolaNut_v1_8_5_OTA and then you can update the storage with Storage_Upgrader_1_8_5. If you allready have one big storage install FP1U_KolaNut_v1_8_5_OTA.

If you’re stuck anywhere else let us know. :smile:

Please help: have update done 4 times via Fairphone launcher, rebooting done, everything as described, however phone stucks to version 1.8 but lost GoogleApps. Googel Apps not re-installale, even not via Fairphone Updater --> goto --> Apps. Please help: How can I get the update? How can I get Google back?
Thanks a lot, Sonja

Go to settings > developer options > tick “keep screen on”, plug-in your phone and try the update again. Once the update is installed try reinstalling Google apps again.
If it still doesn’t work post back.


I installed the (broken) update version 1.8.5 via ZIP file from the recovery menu.
Since then I’m stuck in the gapps Installation loop. I’ve read this thread but I can’t figure out if there will be an update for those who are in my situation (e.g. 1.8.6)? Or am I missing a solution except flashing my phone with the right ZIP file, which is now online?

I am using OSX, so do you have recommendations which tool to take for flashing?

I’m not in a hurry. I’m using fairphone without gapps ever since. But now, I’d like to install some good open source apps, that can only be found in the stores.

Thanks in advance

These two posts offer unofficial solutions, use at your own risk:

If you’re a fan of free and open source apps I guess you heard of F-Droid, but you want to install some apps that are not on F-Droid (because they are not free enough for F-Droid). Usually these apps are at least gratis (free as in free beer) and therefore can be downloaded via evozi. So if you want to free yourself from google now is your chance! :wink:


Thanks for your reply, @paulakreuzer !

Guess I’m waiting for something official then :). I wanted to install TextSecure, for I am the only one among my friends who is using the fork thats available in F-Droid: SMSSecure. I think, why not taking advantage of the big market PlayStore to push security. Perhaps, should go with threema. Sorry, off-topic :slight_smile:

Thanks a lot, worked now!!!

Well you can at least with free apps, please have a look at BlankStore from NOGapps project, I use it frequently and it works very well :smile:

1 Like

Does this mean that we should wait with trying to update again until you have found a solution? I tried three times in the same way which was described on top.

Please provide more information:

  • What exactly is your current setup (which OS version, unified partition or not)?
  • Describe the troubles, you are experiencing.
  • What have you done to solve it? (What is “the same way which was described on top”? You can do quotes by marking a sentence and clicking “quote reply” in the label, which will appear.)

Thank you! :blush:


First of all: Thanks to the moderators for the great support. You are doing a great job. :smile:

For me the update worked fine, no problems when upgrading from 1.8 to 1.8.5 on my FP1U. The home screen arrangement was deleted as announced. So everything worked as designed.

I want to give some feedback to the new layout. Should I post it here, or should I open a new topic for that?



Well the layout is not really new. The launcher from 1.6 is back because people were not digging the 1.8 launcher (or version 2 launcher).

There is a topic on how to get the 1.8 launcher back and a wiki post about launchers, but no topic about the original fairphone launcher yet. So if you want to discuss it a new topic is probably best.

1 Like

Hi Karsten,

your described behaviour with phone visibility is normal. For mounting your phone in a way your computer sees it you can either mount it in another mode, or simply turn on “USB Debugging” in System settings -> Developer options on your phone.

thanks for your reply. But the Kola Nut Updates seems to be fine now. instead I am asked to install Android Jelly Bean 4.2.2. … which I don’t need? how can I stop these notifications?

Hi Stefan!
Thank you for answering so quickly!

Unfortunately I do not know where to find information about OS version or unified partition?

This is what I find under “about phone”

android verison 4.2.2
baseband version MOLY:WR8.W1248.MD.WG.MP.V14.F1.P1, 2014/07/14 13:31
Kernel version 3.4.5
Buld number

This is what happens.

I try to start the update. It take a lot of time. Then it asks me to pull the google apps to the screen. Since it is already there I just press it to install. Then I get a new message about an update and I see that the “Install” on google apps is still there. I try again, and again… same result. I now have a new notification about the update.

Do I have to do a backup for photos, videos, messages, bank id, apps etc? And how do I do that? When I connect to the computer I am able to save the photos to dropbox because a window opens offering this option. But otherwise I cannot find the Fairphone anywhere. It is not in finder only in iphoto but I cant make a back-up from there. Where do I find it and then how do I back up all the apps and messages? I have tried pressing USB tethering, no result. I entered Storage but the option "eternal usb storage / mount usb storage/insert usb storage for mounting " is not selectable.when i connect through bluetoth i cant find the hone in finder either. i can download things from the computer to the phone but nit the other way around.

There is also a problem with the connection by cable. It seems to continously disconnect. I had this problem with the charger as well for a few days. Then it was ok again. At that time I could only charge it if the phone was off. Is this connected to my problems of connecting it to the computer? And what to do about it? but i still get a notice when it connects and disconnects and when it is connected i still cant find it on the computer. The weird thing is that it seems to continue charging although it says its disconnected. or rather i keep gettin questons about connecting to mac and it disappears from iphoto so i assume it disconnects but keeps on charging? On the other hand it looks like its charging but it stays on 53%… Something is definitly not ok.

Thank you!

If you open the updater app what does it say is your current operating system? I don’t think anybody on Fairphone OS gets notified about updating to Jelly Bean.
Or is the notification maybe coming from another app? Open your Notifications, long-tap the notification and click “App-Info”.

To find out which OS you have installed open the updater app and you’ll see your current operating system. To find out if you have successfully unified your partition go to settings > storage and see if you still have a “phone storage” and an “internal storage” or just the internal storage.

When I open the updater app there is no information on OS. Then only thing it says is:

Release Notes:
Relsease notes: for the full list of changes, please… etc
Then I have the options cancel or install.

And it says superuser granted to fairphone and a please wait… with a circle showing it is working on somehting.

It says only Internal storage only and not phone storage

I do not want to update anything until you can guarantee that I will not loose apps (eg. my bank id) and messages. And if there is a risk I can loose them I would like to get help with how to back it up. I have described the situation in the previous email.

I have tried different modes (USB, MEDIA DEVICE, CAMERA) and developer options USB debug and I can still not find the phone on the computer. And it is still connected and it seems to be charging now. It jumped to 61%.