Google Apps can't be reinstalled

Thanks @Amber… Actually I work with mac os… Would it work similarly?

Hi KatieN,

I could find Google Android SDK also for Apple. This means, that my solution suppose to work on Apple, too. You probably have to install them in order to use adb. But I don’t know how to invoke command line on Apple.

good news: Fairphone is currently testing a solution which just involves the phone itself, and for me at any rate it worked fine (luckily I was one of the testers). So for anyone not happy to do any manual stuff, I’d suggest waiting until the fix has been tested and will be made available by the FP peeps.

In the meantime, I’m now gonna reinstall my apps on my one partition phone - hopefully no more hassle with storage space problems and a good time to re-evaluate whether I need all the apps I used to have (tip: in the Play store, they are listed under My apps > All apps so you don’t have to look them up one by one)


@megalies that is great news. Will the new update come to my phone directly through the update app or will i need to keep coming back to the forum to check?


I suspect you may need to come back here, but I’m not entirely sure what it will look like when it’s made available.
At any rate it’s useful to read the steps before you do the update: they are quite simple but it would be a shame if the fix went wrong because you accidently did things in the wrong order or something like that… right :wink:

1 Like

Doesn’t work for me.
Fix is installed and applied.
After reboot I tried installing the Google app store via the Fairphone Updater.
After installation and reboot phone went into error mode (picture: android lying on back).
After another reboot I am back to the situation without Google services.
A second try did not change the situation.

@MariaMaria did you “keep screen on” (setting > developer options) and keep your phone plugged in during the fix?

"keep screen on" was on
phone was not plugged in

I tried it again with phone plugged in --> same result.

Thanks for any new ideas.

@paulakreuzer I have the same result a @MariaMaria

Just to confirm. I am currently on 1.8. I did the fix (successful) and then did the fairphone update. this stayed on 1.8 so i did the gapps update. didn’t work.

Any tips?

I don’t think the fix works on 1.8.
Did you ever even successfully install 1.8.5?
The fix is for those who installed 1.8.5 and the 1.8.5 storage upgrader before May 20th.

Doesn’t work for me as well… the Fix runs successfully, then after reboot I am in the same situation again. (tried twice)

I am one of those that repartitioned the phone shortly after release with the XDA method though, maybe has something to do with that?

@MariaMaria, sorry to hear you’re still unable to install the app store.

I don’t know if it’s significant, but for me, when (after the fix and reboot) I did the apps install from the Fairphone Installer app and the phone rebooted, I saw the standing Android robot with the open belly, and for me now the blue line indicating installation progress went all the way to the right, rather than breaking off at about 20% like it did when I was in the loop. Did you see that at all, or did you see the lying robot straightaway?

Not sure what either means, but perhaps it might help the developers…

@MariaMaria & @megalies the Android lying on his back with his belly open indicate you are in Recovery Mode.

I don’t know if its the same with this fix, but if you end up in recovery mode during an update it usually means something went wrong with superuser access.

Here is a guide that fixes that:


@michaschm You would need to reflash your phone using the with Fairphone’s Factory image (1.8.5) with unified partition to get the original Fairphone partition layout.

Some users have done this, if i remember correctly @Kephson is one of them. The procedure would be roughly the same as described here on xDA:

Since you partinioned your device yourself, i assume you are familiar with the MTK android tools?

I have zero experience in doing this myself, maybe it would be good is someone successfully recovered from custom partitioning could write a little tutorial for other users. Would you be able to do this @Kephson?

1 Like

Thank you.
Tried to reinstall Fairphone Update in Recovery Mode --> OK
Tried to reinstall Goople Apps in Recovery Mode --> abort after a very short time.
After Reboot: No change to Fairphone condition.

I think the android was off his feet straight away.
It even had a message “error” - so not just recovery mode.

People who have problems with self partitioned phone should first install the unifying upgrade to have one unified storage.
At the moment I can’t follow the problems here, because I don’t know how your phones were partitioned before upgrade… :pensive:
I will try to help everybody to get a working phone back, but please send me via private message detailed descriptions how your phone was partitioned before and what you exactly did when you upgraded your phone. So I can try to help you and I can try to write a manual how to fix it.


Dear @Kephson , unfortunately I am not allowed to send you a private message, sorry. So I try here:

I have a first edition fairphone.

Some weeks ago (I guess about 8 or something) I bought a SD card and repartition my fairphone. I think I did it this way (it’s a German site, sorry).

When the update came last week I tried to install it, but it did not work. So I installed it manually via the recovery mode. (

Since then the updater showed me that the installation was successful and told me to install google apps. But this did not work. It always looked as if it worked and then it came up again.

Then I tried this fix Hotfix available for Storage Upgrader 1.8.5
It again looked as if it worked. But now I’m back in the look again.

Do you need any other details?


Hi there. I am facing the same problems and did exactly the same as KatieN did. I guess the root cause is connected to repartitioning the Fairphone prior to the latest update.
Any help easier than the solutions mentioned before will be much appreciated.
Best, Alex