Google Apps can't be reinstalled

Hi Paul,

what I always wanted to know: Do they work with GApps installed? I mean, you suppose to have other µg Nlp services installed, but I dont use Google location services anyway. Can I just override these µg with the one from F-Droid?

1 Like

I found a good solution for me which I want to share with you. Of course, I cannot take any responsibility if you follow my instructions. Use at your own risk, you are yourself fully responsible for your phone.

I came from 1.6 with old partition layout and have installed 1.8.5 Storage Updater without first installing 1.8.5. Here I stuck with old Recovery console which then could not find any content for /sdcard and with non-working GApps (first to mention Google Play, but all other Google services are practically affected due to this).

I usually work on Linux, so I wanted to find something without requiring Windows. All I needed was USB cable which connected my Fairphone to my Computer, and ADB, which you can find as part of the Android SDK available from Google working on any both Windows and Linux. On Linux, there are preconfigured Packages available for e.g. Debian from its repository.

Fairphone has integrated the 1.8.5 Recovery console in the new Storage_Upgrader_1.8.5 in the main directory as image file recovery.img. This makes it very simple to install:

  1. Download & Unzip to your harddrive
  2. Copy the recovery to the device: adb push recovery.img /sdcard/
  3. Run Shell into device: adb shell (if it doesn’t find your device you turn on “USB-Debugging” in Settings->Developer options)
  4. Become root inside adb: su
  5. Go to location of your image file: cd /storage/sdcard0/
  6. Flash recovery image: dd if=recovery.img of=/dev/recovery
  7. Exit adb shell: exit

Now you have a working recovery console which detects your sdcard and can install contents from it. I continued via adb, which is also working nicely. Since GApps need to work out I have now continued installing 1.8.5 for unified storage. This file contains patches for making GApps work again (same as the new Storage Upgrader, but I cannot run the whole Upgrader package any more, and I was unsure how to run the patch):

  1. Download for FP1U - Mid-2014 (2nd batch) & FP1 with unified storage
  2. Reboot into Recovery (Power button + Volume up), press power button to enter menu, select “apply update from adb”
  3. Flash new Fairphone OS via adb: adb sideload
  4. After copying the OS to the device the recovery console will automagically start installing it. The progress bar will take a while to proceed from around 30% till 70%.
  5. I have unzipped the USB cable when flashing was finished. The recovery showed its main menu and I chose: “reboot system now”

My Apps which I have installed from F-Droid in the meanwhile remained existing and working, now I could proceed with installing GApps with the installer provided by Fairphone.


Great, this worked for me!


Good question. There is actually a version of µg Nlp for GAPPS devices on F-Droid but nobody could confirm that they work yet. (How would one know if Google provides the location anyway.)
But I suppose it’s also somehow possible to uninstall Google’s NLP and then install the GAPPS-free legacy version.

1 Like

I just tried µg Nlp for GAPPS devices on F-Droid and it works without the GAPPS installed. My backend is from mozilla.


@Amber: Awesome, it worked for me too. Thank you for posting this solution.


@paulakreuzer : any news from the official front? how long do you think will it take them to come up with a solution?

@Amber 's solutions seems quite complicated for not so techie users…



hi Katie, I’m also still waiting (for over a week now) for a solution that doesn’t involve anything that comes with warnings like ‘at your own risk’, as much as I admire all the tech people here who can do this stuff.

Perhaps @anon12454812 or @Marco have some idea of the status of this problem? Hope you all had a nice day off at Fairphone HQ (Monday was a holiday in the Netherlands) and have fresh ideas about how to get us out of the loop, or at least can let us know if you don’t yet and that we’re not forgotten…


Hi KatieN,

if you use Linux and don’t worry about command line then I believe my solution is more like a every day workflow. The command line makes it a bit technical and not so easy to execute under Windows. On the other side I have tried to mention every single step which makes my description a bit lengthy and it works on every machine that can run Google’s Android SDK.

1 Like

I must write “at your own risk”, even when I believe that there is no risk. It’s always possible to do something undesired and may lead to unexpected results. I was also worried if I should do, because when something would have gone wrong, then I could not expect Fairphone to support this.

1 Like

Thanks @Amber… Actually I work with mac os… Would it work similarly?

Hi KatieN,

I could find Google Android SDK also for Apple. This means, that my solution suppose to work on Apple, too. You probably have to install them in order to use adb. But I don’t know how to invoke command line on Apple.

good news: Fairphone is currently testing a solution which just involves the phone itself, and for me at any rate it worked fine (luckily I was one of the testers). So for anyone not happy to do any manual stuff, I’d suggest waiting until the fix has been tested and will be made available by the FP peeps.

In the meantime, I’m now gonna reinstall my apps on my one partition phone - hopefully no more hassle with storage space problems and a good time to re-evaluate whether I need all the apps I used to have (tip: in the Play store, they are listed under My apps > All apps so you don’t have to look them up one by one)


@megalies that is great news. Will the new update come to my phone directly through the update app or will i need to keep coming back to the forum to check?


I suspect you may need to come back here, but I’m not entirely sure what it will look like when it’s made available.
At any rate it’s useful to read the steps before you do the update: they are quite simple but it would be a shame if the fix went wrong because you accidently did things in the wrong order or something like that… right :wink:

1 Like

Doesn’t work for me.
Fix is installed and applied.
After reboot I tried installing the Google app store via the Fairphone Updater.
After installation and reboot phone went into error mode (picture: android lying on back).
After another reboot I am back to the situation without Google services.
A second try did not change the situation.

@MariaMaria did you “keep screen on” (setting > developer options) and keep your phone plugged in during the fix?

"keep screen on" was on
phone was not plugged in

I tried it again with phone plugged in --> same result.

Thanks for any new ideas.

@paulakreuzer I have the same result a @MariaMaria

Just to confirm. I am currently on 1.8. I did the fix (successful) and then did the fairphone update. this stayed on 1.8 so i did the gapps update. didn’t work.

Any tips?