Google Apps can't be reinstalled

okay. thanks. i followed all the instructions but when i go into “apply update from sdcard” the directory is empty though i have deposited the zip file accordingly onto the sd card. how do i proceed? my phone tells me it can’t find any sd card at all.

So any estimation on when we finally get a fix…

…I am sitting here for days now and can’t do anything with my phone, while I am already seeing advertisements for the next phone all over the place and getting mails about it, yet not even the old FP1 is working as it should.

@michaschm I can understand that you’re disappointed by the update, but if you don’t explain which problems do you have, nobody can help you to fix your problems :wink:

Hi all,

after reading every topic on this problem for the past 3 days and trying everything, I hope that you can help me. Let me describe my problem, although I think I am only repeating what others have said before.

I downloaded the KolaNut 1.8.5 update (no pre-update was available), which didn’t seem to work, because my phone kept telling me that there is a new version and everytime I tried to do the update, it said that no file was found. I then did the storage upgrade (2 days ago) manually and then it seemed to work. However, I still couldn’t install Google Apps. I then tried to go back to Jelly Bean or 1.6, neither worked. Then I tried to put 1.6 back on manually, but no files were discovered on my sd card or phone when in recovery mode. I now downloaded the version of the upgrader that Rick postet about and tried to put it on my phone, no success with this file either, it doesn’t show in recovery mode. I also tried connecting my SD card to my computer and put the file on, no success. I also tried the ADB stuff, but it wouldn’t connect to my phone, so nothing happened and I had to take the battery out to get it back running again.

Any suggestions?


Hi @Lisa_Quadt, I do think you have the same problem as the rest of us. Something was wrong with the manual storage upgrade, and while they have found what was wrong with the file and fixed it, they are still working on a fix for those of us who are stuck in this Google Apps loop without access to our sd-card in recovery mode…
I take it it will be posted in this topic when there is a solution, but this wiki post seems handy as well, @paulakreuzer is doing a good job getting all the info together. The wiki post also contains a solution if you’re not afraid of going tech.

1 Like

If you’re very technical-affin there is a risky ways with special tools, but it is not recommendable for everybody. Practically there is something wrong in the recovery console. Fairphone is currently working on a general solution.

Can you tell me in which thread can i find this answer?

@albertako the fix has already been released:

In the top right corner of each grey quote-box there is an arrow. If you click it it takes you to the quoted post.


Well, Paul, your comment this is the answer for everybody who is not yet affected, who want but have not run Storage Upgrader so far. It is good to say this again, to promote that now there are working upgrades.

The second sentence (“we are still working on solution”) is for those who have already upgraded and stuck in some or another loop. And I have answered this part to Lisa, because she has done the storage upgrade and cannot put any other OS and GApps, like me. Better to wait for us, until Fairphone releases a fix, unless someone is techical-affin and wants to try out somewhat risky way.

1 Like

This Solution worked for me, there where just these differences: after installing the 1.6 image I had to reboot before the fairphone updater recognized that there is an update. And after the following online update there was another after one more reboot (both to 1.8.5…). After this I installed the Google Apps and it was successful.

I still hope there will be a more simple solution for other users who aren´t able to do all these steps. And I hope we all can have more trust in official updates nevertheless these are online or manually. Because I onliy did what fairphone officially wrote before and this is what caused this problem… :wink:

But for me it is solved - thanks a lot.


I have a problem reinstalling Google Apps after update to Kola Nut 1.8.5. Here’s what I’ve done:

  1. Successfully updated from Kola Nut 1.8 to Kola Nut 1.8.5
  2. Ran Kola Nut 1.8.5 Storage Upgrader (hadn’t previously done so under Chery (1.6.)
  3. Successfully rebooted phone
  4. Followed instructions to re-install Google Apps (tried both through widget as well as Fairphone Updater)
  5. Restarted my phone (saw system updating screen etc)
  6. After restarting my phone, no Google Apps are installed. Instead I am reminded again to install them.

I’ve tried installing the Google Apps for at least 10 times now. Nothing seems to work. Can anyone help me? Many thanks in advance.


When did you do step 2?
Before or after Rick posted this (May 22, around 13:00):

It was last weekend, so before Rick’s post you are referring to.

Ok then you have options:

  • wait for the solution the fairphone team is still working on
  • contact support, maybe they can work out an individual solution for you
  • try this solution at your own risk. :warning: But be aware: 2 people already screwed up their phones trying this solution.

So, the problem I described is something that’s known and on the radar? I have no problem waiting for an ‘official’ solution by the FP team.

1 Like

Yes it is. And I think waiting for the official solution is a wise decision.
Let’s all hope it comes soon. :smile:

OK cool. Great news. Luckily I have a phone I can fall back on, so not exactly in a rush. Even thought, using my FP is of course the preferred option :slight_smile:
Thanks for the super fast reply, by the way, on a SUNDAY!

1 Like

Any news on this? Google services are quite important for catching your location (scary anyhow)…

I was just asking the same question in the staff category of the forum but I guess at 22:00 on a holiday they won’t answer.

But if you are uncomfortable using Google services for location it might be a good idea to look into µg Unified Nlp and Free Location Databases.

1 Like

Thank you, will look in this later on

1 Like