Can I install new recovery partition from Factory Mode?

It seems I blew a step in the upgrade process from 1.6 to 1.8.5 to the unified partition.

I now find my phone get’s stuck in a boot loop - it gets as far as blue background and white loading (at best) and then reboots.

I pulled the battery, then powered on using Volume Up and Power to get to recovery mode, but same problem (boot loop).

The only option that doesn’t result in reboot loop is holding Volume Down and Power which takes me to factory mode.

If I plug in the usb, then:

fastboot can’t find the device.

adb can find the device
adb shell works, but su fails (permission denied).
adb sideload waits indefinitely since there’s no corresponding menu option (as you might expect)

I’ve tried running adb reboot bootloader, but that just takes the phone back into the boot loop.

I was thinking to follow Amber’s steps here to try to install a valid recovery image.

a) The dd command to copy the image to /dev/recovery will certainly fail as I can’t gain root.
b) Even if I could get it to succeed, is running such a command going to affect the correct partition or is the configuration inside of this factory mode somehow different?

So, what can I do with factory mode to get my device working again?

I’m on a Mac, so really hoping theres an option that doesn’t involve me tracking down a Windows machine so as to use SP Flash.

I believe you are talking about the Testing Mode, where your hardware can be tested?

If Volume Up + Power button (Recovery Mode) doesn’t take you to the resting robot, I fear you have screwed up your recovery. You need to flash the binaries.

Maybe there is a tool like SP Flash for Macs too?

1 Like

What happens if you type “adb reboot recovery”? It should reboot your phone straight into recovery.

If upper command doesn’t reboot your phone into recovery console: Does “adb logcat” or “adb shell” and inside the shell “logcat” give any hint about why your phone stuck in a boot loop? What happens if you run “adb root”? I find so strange, that by updating you have lost root. Sure you tried to update to Fairphone OS Kola Nut? I have never tried the optional offered stock Android OS, so I don’t know how it looks like and which facilities you have got there.

If you run stock Android OS then maybe Chainfire’s adbd insecure app helps you to run further commands (to be installed by adb install …).

What do you see in system settings -> System -> # Superuser? Does the menu option exists at all? (Oh no, you cannot complete boot actually…)

A practical guide to root your phone manually via adb is the guide on

The F-Droid page offers a more complete guide, I find.

Yes, it’s test mode.

Any reboot takes it into a bootloop, booting into recovery either by the power and volume up or by the adb reboot command also gets me to a boot loop.

Factory mode/Test Mode looks like this:

So there is definitely no System settings menu to go play with superuser settings.

In terms of the cause, I was having trouble with the update, so I went to do a sideload (had successfully taken that route previously), but I think I passed the wrong zip file to adb sideload :open_mouth:

I suspect the reason I don’t have root is that test mode is booting into a different image with a different configuration (maybe even lives on a different part ROM/part of the ROM?) and so su is finding that the adbd process user doesn’t have the privilege to elevate to root.
This also makes me suspect that even if I were able to dump new files in via adb install, that it wouldn’t be modifying the actual image that it boots into and so wouldn’t solve the problem.

I’ll ask for help on xda, see if there’s any insights they can offer on testing mode.


As far as I understand it if you can’t boot up and neither access the recovery mode than you hard bricked your phone. The only way out I know of is XDA’s Guide but that one needs a windows pc with sp flash. If there are no similiar tools for mac you’ll probably need to find a pc…

I moved a post to a new topic: What is the MTK driver installation during the use of SP Flash tool good for?