Google Apps can't be reinstalled

I don’t think the fix works on 1.8.
Did you ever even successfully install 1.8.5?
The fix is for those who installed 1.8.5 and the 1.8.5 storage upgrader before May 20th.

Doesn’t work for me as well… the Fix runs successfully, then after reboot I am in the same situation again. (tried twice)

I am one of those that repartitioned the phone shortly after release with the XDA method though, maybe has something to do with that?

@MariaMaria, sorry to hear you’re still unable to install the app store.

I don’t know if it’s significant, but for me, when (after the fix and reboot) I did the apps install from the Fairphone Installer app and the phone rebooted, I saw the standing Android robot with the open belly, and for me now the blue line indicating installation progress went all the way to the right, rather than breaking off at about 20% like it did when I was in the loop. Did you see that at all, or did you see the lying robot straightaway?

Not sure what either means, but perhaps it might help the developers…

@MariaMaria & @megalies the Android lying on his back with his belly open indicate you are in Recovery Mode.

I don’t know if its the same with this fix, but if you end up in recovery mode during an update it usually means something went wrong with superuser access.

Here is a guide that fixes that:


@michaschm You would need to reflash your phone using the with Fairphone’s Factory image (1.8.5) with unified partition to get the original Fairphone partition layout.

Some users have done this, if i remember correctly @Kephson is one of them. The procedure would be roughly the same as described here on xDA:

Since you partinioned your device yourself, i assume you are familiar with the MTK android tools?

I have zero experience in doing this myself, maybe it would be good is someone successfully recovered from custom partitioning could write a little tutorial for other users. Would you be able to do this @Kephson?

1 Like

Thank you.
Tried to reinstall Fairphone Update in Recovery Mode --> OK
Tried to reinstall Goople Apps in Recovery Mode --> abort after a very short time.
After Reboot: No change to Fairphone condition.

I think the android was off his feet straight away.
It even had a message “error” - so not just recovery mode.

People who have problems with self partitioned phone should first install the unifying upgrade to have one unified storage.
At the moment I can’t follow the problems here, because I don’t know how your phones were partitioned before upgrade… :pensive:
I will try to help everybody to get a working phone back, but please send me via private message detailed descriptions how your phone was partitioned before and what you exactly did when you upgraded your phone. So I can try to help you and I can try to write a manual how to fix it.


Dear @Kephson , unfortunately I am not allowed to send you a private message, sorry. So I try here:

I have a first edition fairphone.

Some weeks ago (I guess about 8 or something) I bought a SD card and repartition my fairphone. I think I did it this way (it’s a German site, sorry).

When the update came last week I tried to install it, but it did not work. So I installed it manually via the recovery mode. (

Since then the updater showed me that the installation was successful and told me to install google apps. But this did not work. It always looked as if it worked and then it came up again.

Then I tried this fix Hotfix available for Storage Upgrader 1.8.5
It again looked as if it worked. But now I’m back in the look again.

Do you need any other details?


Hi there. I am facing the same problems and did exactly the same as KatieN did. I guess the root cause is connected to repartitioning the Fairphone prior to the latest update.
Any help easier than the solutions mentioned before will be much appreciated.
Best, Alex

Hi, I have waited a couple of days for a less scary approach than using the Flash tool, and just wanted to share what just worked for me after testing most approaches above.

Problem: Stuck in Google Apps not installing loop
Device: FP1 (first batch)
Complication: Had re-partitioned the phone myself before updating (not the official unified storage)
Solution that worked: Manually installing the Storage_Upgradet_1_8_5 (unified storage) by the guide found here:

After doing this I had Kola Nut 1.8.5 installed and could follow the normal flow to install Google Apps, and all is working well so far.

This will clear all content on your phone, so make sure you have a backup before going ahead, but this at least worked for me and I am very happy to have my email, calendar and contacts back in the phone.

1 Like

Hi everybody,
I have almost the same issues as everybody else around with no end in sight…
First I couldn’t install the udate 1.8.5. After the fixes it worked. I now have a running 1.8.5 system.
Anyhow - I can still not install Google Apps. I downloaded the Storage Upgrade Fixer and installed it. Google Apps still don’t work.
I have never manually partioned anything. I really don’t know much about the technical background - I just want a working phone. I relied on the Google calendar which isn’t working now. That really upsets me. I’ve been without a calendar now for over a week!
Is there any solution?
Thank you so much for your help!

I had a similar problem during the beta. First: You are on 1.8.5 now and have one unified partitition? Just to be sure, please verify by opening the Fairphone Updater and checking the Version, then go to Settings -> Storage and check the “Internal Storage” which should be around 13GB.

If both is well reinstall the update 1.8.5 to remove possible remains of the Google Apps:, open the Fairphone Updater again, enter Advanced Mode, then tap Android For Fairphone, then Fairphone Kola Nut (it should read “Installed” below) and tap Install.
This will reinstall the upgrade, after the reboot (note the number of “optimized apps” during the process), please make sure there are no Google Apps left by checking your installed apps for GMail etc.

Then use the Updater to install the Google Apps. After the reboot, the apps will hopefully get installed and you should see a progress bar (note that the number of “otimized apps” should be higher now). After the reboot, you should see the Google Wizard and be able to configure your Google Account.

Let me know it that works! Good Luck!

1 Like

Thanks for this solution. This worked for me nearly straightforward and is, as far as i can see, the most robust solution of the problem.
A friend had a problem with installing the drivers needed on a Win8.1-Computer. How to resolve this problem is very well described on , including a download-Link for the “Mediatek VCOM Port”-Drivers. We used the 'DA USB VCOM Port" and the “Preloader USB VCOM Port”, which was sufficient.
There is another minor error in your description: It is not the ‘Volume up’-Button but the ‘Volume down’-Button you have to press to enter the factory mode.
Anyway: Thanks for your description, it helped a lot!

1 Like

“Volume up” leads to recovery mode, “Volume down” to that particular factory mode, indeed - but all its menu is written in chinese characters, so finding the right option is quite a challenge.

When using SP Flash for flashing the fairphone you won’t see this menu anyway. The flashing process is controlled by SP Flash and the menue is not shown.

SP Flash tool requires Windows, so it is actually already unusable for me, but also it uses adb in its work. Therefore I don’t see the need to use SP Flash tool. All what it does must actually also work straight from adb, but adb is compatible with all systems.

I did try to update my Fairphone (first batch) 7 days ago. It updated first to 1.6. Then it refuse to update to 1.8.5 because the \cache was ‘full’. So I did try to install Google Apps on 1.6 but without success. Using this forum and other information from I could update manually to 1.8.5 but still without Google Apps. No errors, just no Google Apps after installing it.

I did send a support request to fairphone but only got a ticked number. No support at all
Trying to use my backup for Google Apps ended up with an error when I try to access Settings so for the FOURTH time I did a ‘factory reset’. I ended up with 1.8.5 again, working but still no Google Apps!
I did get it working finally by installing 1.8.5 again with the storage fix (it did removed everything saved on my phone)
The 1.8.5 update did cost my over 8 hours work with still several settings lost!

first factory reset: short after getting my fairphone it did crash to the resting Android robot
second factory reset: a update did cause loosing everything (the backup did not work)
third factory reset: enlarging the storage to 7GB so I could start using the fairphone for the purpose I did buy it
FOURTH factory reset: update to 1.8.5

I thing that fairphone did prove one thing: It is not possible to bring a (partly) fair phone on the marked by a small company.
If fairphone does create the second fairphone as it did make the software for the first one…

The next the fairphone does need a (security) update I will buy a new phone from a company that is knowing what it bring to the marked.

BTW The 1.8.5 update did not solve existing issues.

Hi Jan,

“cache full” usually sounds either like a repartitioning before, or, between the updates, you haven’t wiped the cache from within the recovery menu. I didn’t have a problem to install Google Apps on 1.6, so maybe you can describe your experience like what you see on the screen more detailed.

For your support request you unluckily didn’t say when you have filed your request. Of course you will get your ticket number automatically immediately, so when did you send and how long did you wait till you said “No support”? It was saturday afternoon when you wrote your article. I believe Fairphone offers support on usual business hours monday till friday.

How did you enlarge your storage to 7GB?
Now you are on 1.8.5, right? And your “existing issue” is installing Google Apps? How do you install Google Apps and what does appear on your screen?

Dear @Jan4,

i am sorry for the trouble you went through. But the issues you have are probably related to you repartitioning your Fairphone yourself:

I can understand the motiviation, the Storage Updater could have come earlier, but you must have known that you are moving to unsupported territory by repartioning the phone using the guides from xda/forums. And if remember the authors of such guides mentioned that.

The best way forward is to fix your partition layout to just one unified partition as the “Storage Updater” does. You will find some guides how to do this in this thread. You will need MediaTek tools (which you used for repartitioning your phone earlier) and the the Fairphone System image.

Yes, the Software of the FP1 has some issues, but the Team improved the software a lot. I am sorry you are still affected by bugs and other issues in this version. But modifying the system on such a low level as you did can have implications and i am pretty sure it could cause problems with any other phone too.

1 Like