New software update Kola Nut 1.8.5 is ready

Just as an observation: I am just downloading the Update KolaNut 1.8.5 and the zip file is saved during download to /storage/sdcard0/updater/ And has total file size of 200.8MB. I will report back if the update succeeded.

My Configuration before Download:

  • I am running Cherry 1.6@FP1 without the StorageUpgrade applied
  • Telephone Storage: 3GB free space out of 13 GB (=sdcard0)
  • Internal Storage: only 200MB free space out of the 1GB partition (=system folder)

Depending what partition causes your problems I will run in the same problems or not - and will report back here.

@paulakreuzer: at which partition is \cache located or other way round: which partition does it belong to? I fear it is located at the 1GB-“internal storage” - but than I could also run in troubles - right?

At the moment I have at the folder /cache the file (117.4MB) which most likely was downloaded during installation of PreUpdate KolaNut 1.8.5 (which I did one week ago).
–> Any idea if I can delete it, just to be save to have enough space there?

@anon90052001: If some problems during updates arises from insufficient free space in the /cache folder maybe you can use a different folder (which is checked for enough free space) BEFORE any update is performed? Couldn’t be that difficult to integrate to the FP-updater-app, right?

I get the “File not found: /cache/”. message on a repartitioned with small cache.
Now I have to download and run the storage upgrade, right? On my fairphone is Cherry 1.6 installed, but I can only download the Storage Upgrader for version 1.8.5. So the upgrader isnt’t compatible with my OS? And it has a filesize about 200mb. To run the upgrade my cache ist too small, as for the normale OS update to version 1.8.5 too, isn’t it?

yes, I do get the message. I’m having a 1st batch phone. And as a few other people I’m stuck after the pre-update with no google apps.

I read here in the forum that this might have something to do with the storage and/or partitions? My internal storage says 4 GB, so guess I must have changed the partitions sometime, remember it vaguely…

Anyhow, I tried this fix to just get the google apps back. Didn’t work.

I was just trying to get an app to backup my phone data (since I don’t have the Backup & Restore App anymore and no google play thats a bit tricky…).
After that I was about to try the storage upgrader…

Do you think thats the way to do it?

If you have an idea to JUST get the google apps back that would be enough for me, I’m don’t really have to have the update…

Installed Storage Upgrader for version 1.8.5 on Fairphone 1.6. Now everything works fine. The whole topic is very confusing but thank you to the fairphone-community!

1 Like

@Horst_Schlammer: Can you please check in the FP-Updater-App which version of FP now runs on your phone? Is it really KolaNut 1.8.5 (then my intuition was correct) or still Cherry 1.6?

I don’t know, I have and always had a unified partition.

You could try updating the OS manually.

I have just fixed my partition problem and now when I try to add widgets to my homescreen “Fairphone Os wurde beendet” (was stopped) pops up.
What can I do to fix this problem.
Cheers Christina

Try clearing the cache (Settings > Apps > All > Fairphone OS > Clear cache)

Thanks. It worked. I had to clear the cache twice.

1 Like

The initial release of the storage upgrader didn’t contain two items (Recovery image and recent Google-signatures) which are included in the 1.8.5 release. This is the reason why people got stuck when upgrading directly from non-1.8.5. The current storage upgrader includes these items therefore I assume, direct upgrade would work.

1 Like

works for me (as far as I can see).

1 Like

Yes, it’s 1.8.5. The Storage Upgrader includes the update.

1 Like

Can anybody tell me, how I best update from Chestnut 1.3 to KolaNut 1.8.5?
In the old Chestnut1.3-Updater-App I only see the option to go to Cherry 1.6.
Any ideas? Or just go stepweise 1.3–>1.6–>1.8.5? No direct way through official updater?

I think there must be a reason, why it is not displayed. It might be best to go 1.3 > 1.6 > 1.8.5. :wink:

I moved a post to a new topic: Play Store (Purchases) empty after Storage Upgrade

Hi Paul,

it is the Fairphone Updater App.
If I go there manually, it tells me to install the update and when I check the app Info of the notification it is Fairphoe Updater. I just cleared all data of it … no change

Yeah but what does it say IS your current OS?

If you open the updater app (not by clicking the notification but by finding it in “all apps”) it should tell you your current OS version.

I moved a post to an existing topic: Play Store (Purchases) empty after Storage Upgrade

I will strongly advice to NOT update the Fairphone to 1.8.5 unless you want to erase everything on you phone anyway.
This was the second update from Fairphone that ended up in a factory reset. It did cost me over 8 hours to fix it (partly).
Don’t count on Fairphone support; I only did get a ticked number, no support (after 7 days waiting).

its Android Version 4.2.2 Kernel 3.4.5