Network loss after android 12 update

Hello there,

Thank you for the update, but since it was installed, I lost ALL networks (phone call, text messages, data) except wifi. (I am using a Fairphone 4). I reinstalled the proper APN, restarted the phone, also tried to reset the network parameters, still no effect. I tried removing the SIM and putting it back, same.

I am using it in Japan, on the NTT Docomo network (Sakura mobile), and all was working smoothly before the update.

Thank you for any clues on the matter,


1 Like

Welcome to the Fairphone community,

Are you using a SIM card of that provider or is it roaming?

1 Like

Hi there,
I am using a SIM card from this provider.


I also have this issue.

That’s weird. Is it a physical SIM? Can you borrow another? The provider hasn’t by chance technical problems at the moment?

1 Like

I will try for another SIM, but not as far as I know (I am in touch with the service provider for this issue too) and yes it is a physical SIM.

So, I tried to exchange SIM cards with another working phone. My SIM works on other phones, but their SIM don’t work on mine.

It clearly seems to be a Fairphone 4 issue…

Same problem here. Fairphone 4 does not reliably connect to NTT Docomo after upgrading to Android 12. Usually, after a couple of hours of leaving the phone alone, i.e. no reboot, airplane mode, de- and reactivating SIM, it manages to connect by itself.

1 Like

@sgrall @henrik88 @gerb Any news on your issues? Similar cases have appeared with the latest update FP4.SP21.B.048.20230215

Similar cases here and here.

No, there is still no solution as far as I know, and the technical service I contacted in parallel is basically recommending to send it back for inspection to some technical center in Europe. Since I am in Japan it will likely take quite a long time if they solve it.

1 Like

You should make Fairphone official support aware of the problem, if you haven’t already done this [#contactsupport ]

Did you see gerb’s comment (N° 8 above)?

If you do send the phone for maintenance, I recommend effecting a Factory reset first. This will wipe all your data and installed apps. It will be done anyway on arrival at the maintenance centre, but if you do this yourself, it may just possibly clear the problem: after the reset, do a minimal set-up to check for any improvement.

More info on factory reset here.

Yes I have seen Gerb’s case, but it seems slightly different, as I never get any signal.

I will definitely try the minimal setup after factory reset, but few hopes here. I have contacted the official Fairphone support already.

I agree the problem appears specific to FP4, but that doesn’t necessarily mean it’s a HW problem. It’s probably linked to the update, something to do with the way the phone connects to the network.

Since there’s now a new release, it might be worth doing a manual install of that before sending the phone back. I suggest you talk to support about it.

I would not advise to talk to support about manual install, as it seems they have no real clue about this. Also overall be very careful with suggesting manual installs on the FP4 as long as this bootloader bug isnt fixed, because should it brick it can only be fixed in France.

@sgrall just remind that the FP4 is not made for Japan and their network (provider), so this might be a reason why its currently not working.
And just because your SIM is working in another does not mean its not broken. Was the other SIM you tested also a Japanese one or one of any country that is officially supported by FP?

1 Like

Yes, indeed.

@sgrall You might try removing the SIM, connecting over Wi-Fi and seeing whether you can get the phone to update.

Just popping in here to mention that I have similar problems, and that this update (or the one just released) didn’t seem to fix a whole lot for me. Did just contact support so I’ll let you all know if I can work out something.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.