My phone doesn't connect to my computer and I get no help

My phone doesn’t connect to my MacBookPro (Snow Leopard) for file transfer.
USB cable is okay (works for charging).
I got android file transfer installed, but it can’t find the plugged in phone.

I asked for help several times, but unfortunately the people from the support team just never get back to me again after I answered all their questions.
(Sorry guys, I love your phone - but your service kinda sucks!)

So I hope somebody else in this forum might have an idea what to do.
Any thoughts on that?

I’m no Mac expert, but maybe any of these threads help?


Make sure you select the correct UBS-mode when connecting. (It should not be “Charging only” for example).

I also have a Macbook Pro and used to be running OS X Mavericks where the connection worked fine, now I’m running the beta version of OS X Yosemite and still, everything works fine. So it could be (but don’t take my word for it) that Snow Leopard is too ‘outdated’.

Thanks for the ideas.
But where can I change the USB mode?!

Hi
I use an app called “WiFi file transfer pro” on my phone that let’s you access it from a web browser over WiFi. Works really well on my Mac mini

When you plug in your cable slide down your notifcation panel. It there should state in which mode you are connected. When you tap this, you can change this mode.

Ah, thanks - I already did this, but unfortunately my panel is empty, so I can’t change the mode.

That means your phone isn’t connected properly. Try a different USB-cable.

When I plug in the phone, a device is recognized, but I cannot access the storage until I unlock the screen of the phone. Strangely enough, on one of the USB-Ports it didn’t work at all, so you might try another USB port, if you have several.
I don’t know how you would do this on a Mac, but there should somehow be the possibility to view if a device is connected to usb (on Linux, it’s lsusb ).

Yes, I also need to unlock the screen before being able to access the storage. Didn’t realise this first and thought it was not working (and just charging)!

Hallo Sofakatze,

did you find a solution to your problem yet? I have the same problem with the connection, but I can’t just buy cable after cable until one works!?

Greetings, lilac

Hi lilac, I’m very sorry, I totally forgot to post the solution here!
Actually, it was the cable. I ruled that out first, because it worked for charging, but obviously that doesn’t mean it’s completely ok. So the Fairphone support suggested to try that first and sent me a new cable - and now everything is fine.

1 Like

jep that’s it.

nothig worked for me: tried to connect my FP with 3 different cables, no connect option came. then tried bluetooth: even worse : devices paired but didn’t want to connect.
the wifi file transfer worked immediately great simple elegant solution.

thx !!

If you have to sync files on a regular basis, you could also look into the BitTorrent Sync app. It’s working really fine and fast for syncing multiple devices - all you need is a WiFi connection. (You could also use it via a data connection.)

I use it to backup photos from my phone to a local NAS, sync music, and even to sync an encrypted password database ((Keepass Droid, available either on the developers site, on f-droid and via Google).