Missing WiFi calling option / is gone

I have installed the latest FP3 firmware with stock OS from February 2020. My carrier supports WLAN Calling and I was able to set my preference once via the search function. Actually, it could be used to set if WLAN Calling shall be preferred or not.

Unfortunately, the option has disappeared from my settings menu. If I now want to change my preference, I cannot access it anymore. The search will still display an entry for WLAN Calling (German: WLAN-Telefonie) but it will forward me to the mobile network settings without any choice for WLAN Calling preference. So, no corresponding option is visible.

I guess it is a bug. How do I change the preference for WLAN Calling now?

Welcome to the community forum.
(I corrected the topic title, you can also open topics in German here, by the way :wink: .)

Does your mobile plan with your carrier support WiFi calling?

My carrier supports it, but my plan (prepaid) doesn’t.
I got to this setting once via a notification, but it seems to have been a glitch, since then it’s gone for me, too.

It works for users with proper support for it, apparently.

you can find it in the settings of the dialer app. “Anrufkonten”, then select the sim card

3 Likes

Thank you both very much. For me, it will work via the com.google.android.dialer app now only as described by Iklaus :smiley: But, it is confusing to have sim options twice but in two variants.

However, this does not solve the riddle why I could access the menu via preferences once. I am pretty sure that I accessed it originally via search in the mobile network settings.

Could you post a screenshot I’d like to know what I’m missing on my FP2 ;).

did you mean the settings?

2 Likes

Yeah, I’ve never seen it. Thank you Klaus.

The actual WiFi calling option screen looks as follows

.

The configuration screen was once accessible via the search function for me. The entry still shows up in the results but it leads to the wrong SIM menu in the mobile network settings.

1 Like

Thanks to both of you :slight_smile:!

Singu

So there has still noone found a solution for the missing option?
I’ve got my new FP3 today and I am verry dissapointed scince I can’t use my regular mobile phone at home and WiFi Calling is the only way to go for me.

I have the excact same issue as FonFP3 discribes. I can find the entry “WiFi calling” in my search but I can’t change the settings there. The FP support was useless, unfortionatly…
I’d be greatful if someone could find a solution to that issue.

Welcome to the community forum.

You make it sound as if you didn’t read post no. 3 in this topic.

Oh I didn’t realize that this was a solution^^

I don’t have the option discribed in that post. If I look in the phone app tho option “WiFi Calling” is not there…

It’s there for me, even though my prepaid plan doesn’t support it and I’m on /e/, so I can’t check the stock OS. Anyway, it sounds like it should be the same way there …

In the dialer App: Three-dot menu in the top right corner - Settings - Calling accounts - (select the SIM card) - WiFi Calling

Yeah, thats where I looked…

Iklaus sent the screenshot of that menu. I only have three entries there. The first, second and the next-to-last one.
WiFi, Video and IMS ist missing in my phone…

If you got your phone today, did you already update to the current OS release? It should have an “A.0120” in Settings - About phone - Build number.

Else … are you certain your provider supports this feature in general? That’s not a given. If the SIM card would say no, Android perhaps wouldn’t display the option.

Well, this menu really seems to differ a lot (and as I said, this is /e/, not the stock OS) …

Screenshot_20200528-233214_Phone_Services


Screenshot_20200528-233356_Settings

I can’t update my phone somehow. It sais I have the lates version although it’s still the A.0111 version…

Yes, my provider and plan support WiFi calling. I checked with their service hotline as well.

The sceenshot you made is the page before the menu where the wifi option is supposed to be. That’s the same as mine.

Options:

  • Wait for your turn, sometimes it takes a little while.
  • Try whether the updater gives you something without a SIM card in the phone.
  • Flash fairphone 3 Stock image. (They just recently provided this opportunity, and it’s A.0120 currently.)

My bad, selected the wrong file and then I got a call … fixed now.

Thank you really much!

My plan is to wait until tomorrow or maybe the weekend and see wheather I’ll get the update then. If I don’t ill try option nr. 3.

I’ll try and take the sim out now. Maybe that will work^^

Yeah, that option doesn’t appear in my menu…Screenshot_20200528-234740

Well, I’ve updated my phone now (via PC, because it didn’t do it automaticly).

The menu in the Phone app is still the same. No WiFi Calling option…

If anyone has an idea how to fix this, I’d be greatfull.

Followup:
After some forth and back with the support-hotline from Vodafone and FP, I finally found my own way arround the problem. I bought a prepaid SIM from another operator and put it in the second SIM Slot in my FP3. And out of a sudden the Option WiFi Calling was there for both SIM Cards and I could activate it. Of course I tried to use WiFi Calling without the second SIM in the phone and to my supprice it worked. Even though the option was gone again as soon as I took out the second SIM out again, but it still worked. I just had to activate it once with another SIM in the second slot.

2 Likes