Lost internet yesterday even with 4G present - any ideas?


Yes. These services use a different type of cellular connection, not regular Internet as provided by Wi-Fi or mobile data.

Whatsapp does not use mobile data? Since when is this the case?

Does your provider also use EE network as Ecotalk? Have you tried the troubleshoots mentioned above? Like resetting APN to default?

1 Like

Oops, going too fast. Be interesting to see whether anything more than text can be sent (photo for e.g.)

Yes, EE. Have tried all of the above - thank you everyone! No solution yet.

We are also with Ecotalk. As you say, hope it’s not that combo that’s the issue, but I think it would be EE rather than ecotalk as they just buy into their network I think

1 Like

I have just spoken to ecotalk. They confirm it is a known issue and that it should be resolved for all users tomorrow. They could not state if it was Ecotalk or Fairphone issue but the combination of the 2 has caused the issue.


Yes, likely EE as it is their network.

Thanks for the update. I’m glad to hear its being resolved

Unlikely to be resolved to morrow if it was a Fairphone issue as it would require changes to the OS and a whole new update.

Issue resolved. restart and deselecting ‘automatically select network’ has fixed. Thank you everyone for your help! (still no reply from Fairphone support ticket).


I am having the same issue with my wife’s FP3+ on EE.

we tried resetting the network, installed a new simcard activated earlier today and new APN settings
It works for some time then it stops.
This started to happen after the last update I think.
It is a New phone , first time purchase, it is quite annoying as we travel a lot and the mobile data connection is vital.

Hi, same issue for me since a recent FP patch.

Network: EE

Model: fairphone 3

Attempts to fix:

  • network settings resets
  • SIM tried in both slots
  • EE tech support phone reset
  • different locations inside and outside
  • no reported outages in region
  • manual network override and reselection of EE/ automatic
  • factory reset of handset
  • APN reset to default

Any support to remedy would be welcome.

EE tech support sorted for me. Users online here were useful but EE said they were aware of the issue and fixed the day after. Unsure if you have the same issue. Fairphone support non existent. I think they checked in on me a month after I contacted them.

I spent all day on the phone to EE with no luck (led me through the troubleshooting above). Thoroughly demoralised.

Any chance to test a non EE Sim?

I feel for you, it’s a damn nuisance I know.

From what JJTreby told us, and your own report I suspect your problems are linked to the recent update in much the same way as for JJT before.

@JJTreby Just to be clear, while you said in an earlier post “restart and deselecting ‘automatically select network’ has fixed”, in fact it turned out there was a problem that EE were able to fix in their systems, is that correct?

Thanks for your help. There are unfortunately quite often problems with individual operators after OS updates. When Fairphone and / or the operator are aware of a potential problem they delay pushing out the update to that network until it’s fixed, but there are often cases like this.

It’s important to make sure that both FP and EE (in this instance) are aware of the problem.

Thank you for all your thoughts. I contacted both Fairphone and EE as soon as it happened. So far no response from Fairphone. My sim works fine in my 2017 Samsung A3 which I switched from last month.

Ok although it seems def related to the recent update, the fact that a SIM works in another phone does not indicate in general that it is not faulty

For those having issues after the recent update please follow-up here

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.