English

Loss of mobile network connection on FP2

Sure I have roaming enabled. I’d never have any connection without :wink:

So, here a brief update: I switched to “preferred network mode: 2G only” last Friday. Up to now, I didn’t have any missed calls or network disconnects – I didn’t use my phone a lot these days.

I’ll keep it in this mode for the rest of the week at least and then also allow 3G.

At least I seem to have a stable connection for now. 2G only is, as you can imagine, a pain. So this is hopefully only an intermediate state.

This is not gonna help to find the solution, but i have the same problem… randomly, it loss connections to network. I haven’t experienced lost of calls, but when using for exemple google maps ou waze app, it just get disconnected from the network.

It happens also when location is turned off.
This plus + restarting randomly + battery not lasting even a day… i just hope it will be a solution soon.

I agree, this is not going to find, let alone solve, the problem. Without any tool for debugging at hand, this is pretty hopeless. Having bought a phone for more than €500, I shouldn’t have to do any of this.

Since the service centre hasn’t answered my ticket in three (3) weeks, I obviously need to identify a workaround on my own.

(Sorry for the harsh words, but I’m pretty fed up with this situation)

Hi I am experiencing the same problem. Below the description of the problem:

My fairphone is only able to doing pone calls when it has 4G coverage, but not regular coverage. I tried with my former mobile phone (changing the sim card) and in the same places I could not do calls with fairphone I can with my former mobile phone, so it is not a problem of the telephone service provider. I have just updated to Fairphone 2 OS 1.7.0 and I still have the same problem.

Thanks for a quick response.

Hi

I have very similar problems. At a lot of places where my colleges with the same provider have good reception my phone has not network.

Fabian

Hi all

I’ve had this problem for a few weeks now. I lose connection all the time - I seem to be able to reproduce it in one specific situation, but it happens lots of other times too (when making calls, when checking facebook, etc).

Unfortunately I still have a very serious problem with random reboots (been going for 3 months+) so have requested a replacement.

I am running 1.7.0. I can reproduce the loss of network by opening the guardian app, then pulling down to refresh the information, at which point the network instantly disappears. It happened when I was using one sim. It still happens now when I use two sims - network on both sims disappears immediately that I try to refresh.

Not sure if this is helpful, but I guess it might be useful to know that others are experiencing similar issues.

Paul

This sounds like the problem I’ve been experiencing the last few weeks; when i am away from my wifi connection I don’t receive any app messages. When I come back to my home wifi, I suddenly get messages from the past hours all at once. What’s going on??

I got a new sim card and today also got it reset by my provider, but still didn’t get messages when I was just out.

Feeling frustrated!

Elise

Two quick things:

  • This is a community forum, so nearly all of the people here are fellow Fairphone owners. If you require customer support from Fairphone you’ll need to contact Fairphone customer support directly. See also the forum guide on Fairphone support. To avoid confusion: none of the community moderators are Fairphone staff.
  • Some, if not most of you, appear to have the same issues as described in the topic “FP2 dropping calls”. There is mention there that there can be problem with the connection of the antenna cable to the rest of the phone. One user reported that support is aware of this being the cause for at least some phones, and that if they establish that this is likely in a specific case they provide an option to replace the phone (or instructions on how to self-repair for those that dare to do that - check with support first before attempting, as this may affect your warranty).
3 Likes

This doesn’t necessarily mean that the phone is losing connection to the mobile network. If you see that the reception icon is empty, or has a cross in it, then it could be if that state persists for a long time.

I’m assuming you’re referring to WhatsApp/Signal messages, rather than MMS.
Have you tested whether cellular data works? (e.g. can you visit websites away from your wifi?)
If it does, have you tried opening the app when you’re away? If you do get the messages away from wifi when you open the app, then background data is probably restricted for that or all apps (see here).

2 Likes

Quite right Johannes, particularly about checking with support first.
Also, I’d like to add that it took me a while to ask but when I finally did, I had an answer within a few days.
Just make sure you follow the instructions properly to contact Fairphone support. I admit it is a bit of a complicated process but when done properly, it does work !

2 Likes

check this out FP2 dropping calls and make sure you have done everything right in the ticket opening process…

Hi

My FP2 worked perfectly the first three months. Suddenly, from one day to the other it couldn’t find the connection anymore. Since then the battery looses the power within 2-3 hours.

  • The sim-card was new
  • It happens with other sim-cards as well
  • It happens in both slots
  • Other phones have good connections at the same places
  • Phone is always updated

-> When I want to check my messages I have to turn off the simcard and turn it on again. Like that, sometimes my phone has enough time to download missed messages.

-> To make a phonecall, sometimes it helps when I put the connection on manually (on my own network), but usually the phone needs lots of tries and lots of time to find the own network.

-> Next step: I send my phone back and hope to get a new one within a few days (for 500 Euro I expect a serious support!!!)

I went through this thread. Up to now I haven’t experienced dropped calls. However, my impression is that the reception with my FP2 is a bit poorer than with other phones (I know, there a thousand other possible reasons for this).

Still, I bought a torx screwdriver (T5, if you want to know) to check the antenna connectors. The connector in the lower left corner of the phone was firmly attached to the circuit board (I could rotate it by some degrees without loosening it). The other one, just above the battery pins, was also connected, but I could easily remove it from the board with a tweezer. In turn, I could reconnect it as easily. As I don’t have any experience with such things, I cannot tell, if this connection is sufficient or if this may be the cause of my problems.

At least, after reassembling all the parts, my phone is up and running again :slight_smile:

1 Like

Hi all,

In my case with last OS update 1.7.1, I realised that after several minutes or hours with Wifi connected, when I switch off Wifi in order to get back to be 3G/4G connection, I get without internet until I make the flight mode trick(on/off) or I manually select the network of my internet provider.

I guess that this particular issue could be related to a SW issue.

I hope this could be usefull for developers.

Just to let you know, what happened to my problem:
I eventually filed a support case. After some e-mails going back and forth to track down the error, I was asked to send my phone back for further investigation and repair. In the end, I was provided with a new phone

The new phone is running flawlessly since the first day.

4 Likes

Finally! Something that worked for me!

(Operator: free mobile in France)

Hello,
On FP2 FPOS, I have the same problem with data 3G or 4G. The airplane doesn’t solve the problem for me, only a reboot
I have the latest version of th OS (16.12)
Any idea is welcome

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.