English

LineageOS fork including MicroG

https://forum.fairphone.com/search?q=lineageos%20root

There is a search function in this forum (click the magnifying glass left of your avatar in the top right corner), and sometimes it even helps :wink: .

6 Likes

Basically followed the same steps, but queued the latest modem.zip after LineageOS+MicroG. Works flawlessly :smiley: .

I haven’t used a modem.zip yet, what’s the advantage?

In other news, I have been running the every-other-nightly-ish builds, and I can report that for me at least 20171110 was a lot more stable than the latest one 20171113. I suffered quite a few random reboots when out and about today (caveat: my usage patterns have been different to normal, but nothing unusual for a phone at all) so I’ve rolled back to the previous update.

It would be good if we kept each other up to date on builds that are good or problematic, especially for newcomers. I plan on trying a build every week or so I think, I’ll update this thread with my thoughts or any isssues.

I “updated” to microG - and since then, WhatsApp is not really working anymore. Before it picked up the messages every 15 mins. What did I do wrong? Does it work for anyone else? How should I adjust the microG settings?

You should have an app called “microG settings” (it contains the Self-Check as well). Do you have Google Cloud Messaging enabled there?

See also here:

1 Like

I did the self check after installation (is mentioned on the micfoG - lineage homepage). first I activated google messaging, but then WhatsApp didn’t really work, so i turned it back off.

Try to backup your WhatsApp conversations from the app, clear WhatsApp’s data and re-register your account. Then WhatsApp should pick all fine.

It happens sometimes that some apps don’t reconnect with GMS through mG correctly —specially if you restore a backup coming from a ROM with GSF (GAPPS).

To which migration file are you referring here? is the migration of the official LOS? or another migration to the forked LOS+microg?

I guess this isn’t needed if you are moving from the official release, right?

A specific one for the LineagoOS+MicroG repos. So that when Lineage search for new available updates, it search in their repos…
The migration file can be found here : https://download.lineage.microg.org/extra/

Edit: I assume this migration zip is needed if you come from any LOS version (official, unofficial) and want to migrate towards LOS+MicroG

3 Likes

Thanks,

I just did it following those instructions and it worked perfectly and it’s so nice to dont need to patch it.

With this release there is no need to keep the microg repository in F-Droid, right?

Hey guys,

I came from stockROM went to FP Open and through TWRP I was wiping system, data and cache.
Then I tried to flash Lineage + MicroG from their hompage but always get an error. First: “Zip signature failed”. Then I turend off checking signature. Now I’m getting: “Upater process ended with ERROR: 7”.

What I’m doing wrong?

btw one more question: why there is no data manager in Open OS?

Hello
I’m using Lineage OS for microG for a little bit more than one week now and it works very well.
the one issue im struggliing with is the MS Outlook App…
The GMS is receiving the push notifications for this app, but that is all.
No notifications when I get a new email…

Does anyone else have this problem?
or even better…
Has a solution for this?

Cheers

According to the LineageOS for microG website (under F-droid):

You should add microG’s repository to F-Droid, so that you can easily update microG’s packages.

1 Like

There are several options that might influence your notifications; in the app itself (under settings -> notifications), in Android (settings -> notifications). You could try if changing these settings help, else try to reinstall the app.

Is anyone of you able to shutdown your phone? Mine always reboots when I try to switch it off.

1 Like

This is a known issue that’s already in the Lineage #bugtracker (Issue 24).

Though I have no idea how the MicroG fork relates to the official build and therefore the bugtracker.

1 Like

Thanks for the reply…
I checked the settings in the app and in android … all on go!
I reinstalled the app but again no notification
(reinstallation worked for all other apps)
The strange thing is, that the microG GMS recongises the notification coming in, but they won’t get through.
Its like outlook app has a different way of using the GMS…

Thanks for your answer. Indeed, it is exactly the same issue.
As far as I have understood, the MicroG “fork” takes the original LineageOS-sources as starting point.
Is the bug tracker still valid for official LineagoOS? I am a little bit cinfused, I have to admit.
Cheers!