English

LineageOS fork including MicroG

It is available now and works for me. Note to install it I had to do a factory reset/full banjax wipe or I would get Error 7s in TWRP. It works great! So lovely to be able to boot an android without being asked to sign in to google.

I have used Yalp Store to log in to my old google play account which has some paid for apps, and they work fine. WhatsApp is working. I have a caldav & carddav connections working for contacts & calendars.

Obviously haven’t tried an OTA update yet, or used it long enough to make an informed judgement on battery life (to be honest I have not used the phone long enough in any configuration to provide a comparative appraisal)

The only thing I can’t get to work is Signal Messenger, which gives a can’t connect to server error which I can’t work out if it is a related problem. I have tried with an apk from play store & off their website. Is this something people have run into before?

One note, whilst I only got my phone yesterday afternoon, I experienced 1 random reboot in the stock Fairphone OS, 1 in the 20171107 standard Lineage Nightly which I was running for a total of about 2 hours each. I’ve had the microg fork on my phone for about 12 hours and it hasn’t rebooted at all, so thats good.

I have some more questions about things I want to get sorted - disable the camera button, change the default camera app, is this the right thread for that or should I ask somehwere else?

I did the migration and everything is working. For memory this is what I did:

  • uninstall F-Droid (the microG apps were system apps already, so are wiped with /system)
  • reboot to TWRP and install migration zip.
  • wiped /system as advised by @roboe, and also wiped cache/dalvik just to be sure…
  • installed the build of LineageOS+MicroG for FP2 :slight_smile:
  • reboot
  • self-checked MicroG settings, but everything was already well configured !
  • no root access at the moment, I may reinstall the su addon later :wink:

Even Signal is working fine :slight_smile: @tomlong I’m using the “Danger zone” version of https://signal.org/android/apk/

@oli.sax That’s exactly what I installed! Good to know its not an issue with the apk/phone/OS, narrows down where to look for problems, thanks.

I installed the addsu-arm zip but after I had installed this fork, and I don’t seem to be root. Am I missing a step, or did I need to do it at the same time as the install? Is there a way to gain root now?

In the past I generally get Signal Error messages just after an LOS update and before repatching Tingle…
I wonder if this was a question of Safety Net failing?
Can you check if you have all options checked in MicroG settings?

For su, yes I would suggest to reflash it again :slight_smile:

@oli.sax The issue was the ‘Google Device Registration’ in microg settings, I was hoping not to enable it, but I have, and as if by magic Signal is working. I’ll read about it and get a better understanding of what is going on on the microg side.

Still no luck on the root front, but it’s not such a bugbear. I just want to get Yalp working more sympathetically, and allow KISS launcher some hibernation privs. No biggy.

1 Like

This is very cool! They used the same code to host the OTA updates as we were on the old buildserver.

@Roboe: Is this maybe a cool alternative to note in the Official Lineage thread?

2 Likes

Yup, I’d recommend it.

A few questions:

  • Is LOS also against adopting microG like CM was?
  • F-Secure blocks microG.org but I can’t see anything wrong with the SSL certificate.
  • What’s to prevent Google from removing the compatibility?

I don’t know about CM, but according to microG’s FAQ the LOS people have concerns regarding the singnature spoofing required to replace the original Google services by microG.
@Roboe doesn’t share these concerns (see his post above).

According to this F-Secure community forum thread it could be related to an update containing a “Family Rules” module.
Another thing I can imagine is that it is blocked intentionally because of the fact that migroG is “spoofing” Google’s software. So kind of the same reason why some virus engines give alarm when they detect some remote desktop access software (like VNC) running.

Probably nothing, except of their own and application developers’ effort for adjusting their APIs. So it’s kind of a tortoise and hare story.

I must say I’m very happy switching from FairphoneOS to Lineage OS with GApps to LineageOS without Gapps to this Lineage OS for MicroG fork.
The Battery Life improved significantly and I’m able to use all of my apps like under FairphoneOS without an Googl account
I don’t no if the spoofing security issues are justified, but it’s a very comfortable non googl solution.
So yay! Recommended

2 Likes

Can this ROM Lineage be rooted?

Can you root Fairphone Open OS?

For me it is essential the root.

https://forum.fairphone.com/search?q=fairphone%20open%20os%20root

There is a search function in this forum (click the magnifying glass left of your avatar in the top right corner), and sometimes it even helps :wink: .

3 Likes

Thanks, and Lineage OS (Android 7)?

https://forum.fairphone.com/search?q=lineageos%20root

There is a search function in this forum (click the magnifying glass left of your avatar in the top right corner), and sometimes it even helps :wink: .

6 Likes

Basically followed the same steps, but queued the latest modem.zip after LineageOS+MicroG. Works flawlessly :smiley: .

I haven’t used a modem.zip yet, what’s the advantage?

In other news, I have been running the every-other-nightly-ish builds, and I can report that for me at least 20171110 was a lot more stable than the latest one 20171113. I suffered quite a few random reboots when out and about today (caveat: my usage patterns have been different to normal, but nothing unusual for a phone at all) so I’ve rolled back to the previous update.

It would be good if we kept each other up to date on builds that are good or problematic, especially for newcomers. I plan on trying a build every week or so I think, I’ll update this thread with my thoughts or any isssues.

I “updated” to microG - and since then, WhatsApp is not really working anymore. Before it picked up the messages every 15 mins. What did I do wrong? Does it work for anyone else? How should I adjust the microG settings?

You should have an app called “microG settings” (it contains the Self-Check as well). Do you have Google Cloud Messaging enabled there?

See also here:

1 Like

I did the self check after installation (is mentioned on the micfoG - lineage homepage). first I activated google messaging, but then WhatsApp didn’t really work, so i turned it back off.