LineageOS 14.1 with OTA updates for FP2

It’s a wiki post, so you can edit it yourself. But try to keep the instructions as simple as possible :slight_smile:

1 Like

Thanks! But I am still trying…
I updated open OS to the very last one 17.07.
(actually I had a look at lineage because it was impossible to get the file from here 2 days ago, but it worked today… :slight_smile: )
Everything was still okay (apps, contacts, sms,… :slight_smile: )
I flashed modem-17.07.6 (myabe it was not useful now I had the latest open OS?)
Then lineage-migration-signed (the latest one 08-03)
What should I choose now in the team wine recovery project page?
reboot?

Edit : Actually, I finally manage to get Lineage OTA updates through the updater so I made a step (or at least I hope so…). But after the reboot, I have this same screen and I don’t kow what to do

If coming from open OS, follow this part from the 1st post (no migration zip needed):

Be aware that you’ll need to factory reset and you’ll lose all data that you don’t backup.

Ok, thanks, I will start from scratch :slight_smile:

Edit: sounds like it doesn’t work… I am “stuck” in open OS 17.07 whatever I try… :frowning:
Maybe is it because I get an “error 7” message (while flashing lineage-14.1-20170803…zip)?
I keep trying :slight_smile:

Edit2: I did exactly what is written here


And I still get this get this error7 message :-/

Edit3: No, it worked finally… in 2 steps

  1. factory reset
  2. flashing lineage 14.1-20170614-UNOFFICIAL-FP2.zip

@sky I just installed the testbuild.zip of 05/08/2017 and I also confirm that the SIM2 for SMS setup does’nt survive a reboot :frowning:

Pushed a update with the new security patches. Nothing else changed. Timestamp is 20170808.

Be aware of the following bugs:

3 Likes

As I still can’t OTA successfully (“Die Überprüfung ist fehlgeschlagen, beschädigter oder …”), I got me a logcat:

08-08 20:13:10.945 10081 18291 D DownloadManager: [269] Finished with status SUCCESS
08-08 20:13:14.691 7880 7890 I art : Background sticky concurrent mark sweep GC freed 139423(6MB) AllocSpace objects, 5(168KB) LOS objects, 28% free, 19MB/26MB, paused 1.564ms total 203.863ms
08-08 20:13:24.540 10081 10093 V DownloadManager: Deleting /data/data/com.android.providers.downloads/cache/lineage-14.1-20170808-UNOFFICIAL-FP2.zip via provider delete
08-08 20:13:30.775 18216 20682 E DownloadComplete: Verification failed
08-08 20:13:30.775 18216 20682 E DownloadComplete: java.security.SignatureException: signature digest verification failed
08-08 20:13:30.775 18216 20682 E DownloadComplete: at android.os.RecoverySystem.verifyPackage(RecoverySystem.java:315)
08-08 20:13:30.775 18216 20682 E DownloadComplete: at com.cyanogenmod.updater.service.DownloadCompleteIntentService.onHandleIntent(DownloadCompleteIntentService.java:99)
08-08 20:13:30.775 18216 20682 E DownloadComplete: at android.app.IntentService$ServiceHandler.handleMessage(IntentService.java:68)
08-08 20:13:30.775 18216 20682 E DownloadComplete: at android.os.Handler.dispatchMessage(Handler.java:102)
08-08 20:13:30.775 18216 20682 E DownloadComplete: at android.os.Looper.loop(Looper.java:154)
08-08 20:13:30.775 18216 20682 E DownloadComplete: at android.os.HandlerThread.run(HandlerThread.java:61)

(How do I format this best?)

Is it possible that the LineageOS/android_frameworks_opt_telephony tree isn’t used in our LAOS builds?

It’s included. If you search within the buildservers console log you’ll see:
00:01:19.506 Fetching project LineageOS/android_frameworks_opt_telephony

But I’ve heard there have been some other changes yesterday that could fix it. Could you test this one after is finishes?

I’ve seen that, but no more hints to the content of that tree and also no hints to SubscriptionController.java in my logcat after booting the phone.

I’ll try the new build as soon as possible.

No, the new testbuild didn’t fix it.

Is it possible that this one is not build? @snevas @z3ntu @chrmhoffmann

*/enable this build only when platform library is available
ifeq ($(TARGET_BUILD_JAVA_SUPPORT_LEVEL),platform)

Pushed a new release over OTA (20170815). Changes:

I’ve also put the new version of TWRP on the server with support for the new hardware (same filename as before).

7 Likes

Thanks for you great work. Have you thought about setting up a https://opencollective.com/ account/project?

I’ve been stuck on the 30 July release and it can’t seem to do the update check. Also it can delete the previous download. Should I manually install the latest release?

I’ve had some issues with LTE connectivity, restarting seems to be the only way to restore it. I used the migration file when doing the OTA fix but would installing the latest modem file help with this?

Yes manually do the lineage update and also update the modem files :slight_smile:

1 Like

How is battery life?
I can’t go for more than 12 to 14 at average use and greenify installed.

Where can I file in bugs?

Did you install the last version of the modem files (modem-17.07.6.zip)?

can tell what version I installed as I flashed LineageOS. Any change to figure out what version is installed? Can find anything in About phone.