English

Lineage-18.1: Unofficial test build

New test build can be found here: https://www.androidfilehost.com/?w=files&flid=325381

Nothing really new apart from security updates and a few kernel changes.

Note: I still can’t change the OP.
Kernel tip: https://review.lineageos.org/c/LineageOS/android_kernel_fairphone_msm8974/+/309949
Device tip:
https://review.lineageos.org/c/LineageOS/android_device_fairphone_FP2/+/303769/4

Chris

4 Likes

I’ve made the initial post into a wiki so you should be able to edit it now.

3 Likes

I just installed the lineage-18.1-20210514-UNOFFICIAL-FP2.zip in TWRP and rebooted, but I’m stuck at the loading screen… :frowning:

Then I flashed lineage-18.1-20210314-UNOFFICIAL-FP2.zip (the version that was installed before) but still infinite loading screen.

Now I flashed again 20210514 zip and wiped Cache/Dalvik/Data, and the phone is starting :smiley:

I didn’t have to wipe Data when upgrading from 17.1, perhaps some residuals of previous version blocked this specific update :wink:

That is kind a weird… Not aware of any breaking changes here.

Chris

I installed lineage-18.1-20210514-UNOFFICIAL-FP2.zip using TWRP 3.5.0 without issues.
Have been using it for two days and everything seems fine so far :+1:

1 Like

For me it’s always a mystery when a LineageOS update fails, however one thing is for sure: it’s always when you didn’t made any backup before :wink:

So, my first challenge was to recover my data !
My last TWRP backup was on February 2021 (actually just before switching from LOS17.1 stable to LOS18 unofficial), and I wanted to recover the app data that get populated in the meantime (e.g. Whatsapp conversation of the last 3 months).

  • Before wiping (factory reset) and fresh-installing lineage-18.1-20210514, I made a TWRP backup of the corrupted system.
  • So my data should be somewhere in the TWRP-image, in a file data.ext4.win000 data.ext4.win001 etc.
  • I checked before that it is possible to repopulate the Whatsapp conversations once the databases are extracted from data/data/ , and indeed it’s possible, see tutorial here.
  • The file data.ext4.win00* is a tar archive, so it should be as easy as 7zip > Extract here or tar -xf in terminal, no? Actually no! Even if I could see which files where inside the archive with 7zip, once extracting I got only error messages, like malformed extented header : missing equal sign :frowning:
  • So I searched for this error and I found two blog posts here and here, explaining basically that the file is not a standard tar archive as TWRP added some stuff to it:

It turns out, my backup files (made with TWRP 3.2.1) actual have two entries for every file in the tar archive. The first entry seems to only store selinux information, which TWRP probably uses during its full system restore process.

  • The tar header starts with the filename at line 00001200.
  • The header is 512 bytes long (200 in hex), and the “file contents” begin at line 00001400.
  • Tar archives support multiple entries for one filename as “links”. The link type is at byte offset 156 in the header. For this entry, that link type is x (last non-null byte on 00001290), which isn’t in the tar standard and is likely the problem for untarring programs.
  • In those blogs they mentioned some python script to clean the extra stuff, or some command line with dd , but honestly it started to be too long/complicated for me.
  • Then I found here a solution out-of-the-box :smiley: :

This isn’t exactly the answer your looking for, but if you want to restore the data on to a different phone, the easiest way is to just copy the with TWRP backups on to the new phone (same location too /sdcard/TWRP/BACKUPS), and then use Titanium Backup to restore from it. In Titanium, click on Menu - Extract from Nandroid backup.

  • Awesome! I’m using Titanium for more that I can remember (actually from the first time I got an Android phone) and I wasn’t aware of such a nice feature.
  • Actually this feature is only for the “donation” version of Titanium, but as I said I’m using it for so long that I don’t mind paying 5€ for unlocking the full version.
  • And it worked flawlessly! All app data were restored from the TWRP corrupted archive :smiley:

I’m happy. Having this kind of problems can be painful but at the end it’s a good opportunity to lean while solving it :wink:

5 Likes

I played a little with the new install and I noticed two issues:

  • My bank app is detecting root even if “Magisk hide” is enabled
  • Pokemon Go claims not finding the GPS even if OSMAnd or StatSat can (high precision, with wifi/bluetooth). OpenGapps was installed in a second step and I suspect that caused the issue…

So I erased everything again (I have up-to-date backup now, see previous post :wink: ) and did the following tests:

  • Fresh install of LOS17.1 and OpenGapps-pico at the same time, no Magisk
  • Fresh install of LOS18.1 and OpenGapps-pico at the same time, no Magisk

In both cases Pokemon Go get the GPS instantly so that confirms OpenGapps and LOS should be installed together :white_check_mark:
My banking app is working good on LOS17.1 :white_check_mark: but not on LOS18 :red_circle:, as no root was installed I suspect that’s because of the self-signed keys :frowning: . In my experience initializing it with LOS17.1 then upgrading to LOS18 could do the trick :wink:

2 Likes

I noticed that after the last update the notification LED still glows orange while charging but instead of turning green when fully charged, it turns off.

Can anybody else confirm this?

Hi @chrmhoffmann , do you think about bringing the new FP2 LOS 18.1 to official state?

I installed Lineage-18.1-20210514-UNOFFICIAL-FP2.zip yesterday and I am quite impressed - runs quite stable so far.

One problem I got two times: I can’t say in which situation or moment - but suddenly I see that memory is indicated a full (red 32 GB / 32 GB) - but it is not true, memory is about 25% full.

After a reboot everything is normal again…

Is it possible to do Split Screen in LOS 18.1 ?
When I long press the square button, nothing happens (that was the shortcut in LOS 17…)
Or is there a new combination?

It works fine for me using the described procedure (long press square button) :man_shrugging:

1 Like

Ok found it:

In Settings > Systems > Buttons you can define which action for each button.
For me nothing was set-up for long press on the square (recent applications), I just added that :slight_smile:

Thank you

2 Likes

I just tried upgrading from LOS 17.1 to LOS 18.1 using lineage-18.1-20210514-UNOFFICIAL-FP2.zip and OpenGApps 11.0.

I wiped System and Cache in TWRP and sideloaded the images. It rebooted fine and seems to be working, but now I can’t get past the unlock screen. It asks for my password (Password required after device restarts). I enter the password, the screen turns black and reloads the lock screen and asks for password etc. The first time I entered my password after a fresh reboot, I saw my regular home screen show for a split second and then asked for the password again.

So I guess it sort of worked, except that I can’t get to the home screen. Not sure what would have happened if I’d removed the password protection.

I’ve got an FP3 now, so this is on a spare FP2 and isn’t a high priority issue but just wanted to share this. Happy to try any fixes for the purposes of the LOS 18.1 project :slight_smile:.

1 Like

I remember having a similar issue repeatedly after a LOS upgrade without factory reset.
I assume the Launcher somehow crashed.

Maybe consider doing a factory reset and re-flash the new system image.

2 Likes

New builds are up…

Can someone test if this fixes the echo problem with stuff like signal as reported in other threads?

Chris

8 Likes

Can we please close this topic? 18.1 just became official - and lets open a new one.

Chris

8 Likes