Lineage 18.1 - finally official

Last built from 28th January:


Thanks for this topic reference, was of great help and describes exactly my current proplem. Now I changed in developer settings the “Animationsdauerfaktor” (animation duration factor?) from 1.0 → disabled - and until now all the apps with animations which triggered before a crash doing this not anymore. Instead of the animation just a arrow is displayd - looks ugly, but functionality is not limited in my view and it doesn’t crash.
So I will try to keeping FP2 alive with this a little bit longer … 6 years and counting …


Seeing the 3.6.0 TWRP update now supports Android 11, should I understand that if this version was ported to the FP2, TWRP would be compatible again with Lineage? @z3ntu, do you intend to port it?


There was a build failure but it’s available now: Download TWRP for FP2


Thanks! :slight_smile: We just have to know if it fixes the incompatibility now. @chrmhoffmann would you be able to tell?


I just struggled a bit getting Magisk installed after flashing LOS 18.1. Is there already a main wiki post / detailed guide about install Magisk on fairphones?

I basically followed the
Magisk install doc:

I tried both

  1. the “adb sideload a Magisk zip” - way (mentioned as depricated)
  2. the "patch boot.img and fastboot flash boot /path/to/magisk_patched.img " - way

but I always ended up, that the FP2 does not boot anymore (stays in the first “FAIRPHONE POWERED BY android” welcome screen).

Any idea/suggestion/idea what I’m doing wrong? Maybe is Magisk 24.2 not really working for the FP2 yet? (will give it another try with 24.1 now - not sure how I get to the point to already use 24.2 EDIT: was marked as suggested in Izzy-Droids Repo … - seems to be still a beta right now ‘2022-03-07T23:00:00Z’ → GitHub - topjohnwu/Magisk at v24.1
image )

EDIT: 24.1 works … :partying_face:

Regarding docs/wiki note:
I just found this for the FP2, but only with links and no real details. How to root my FP2 with LineageOS 17
A wiki note might also show the differences for the FP3 and FP4 (maybe the boot.img approach works or is needed there) or just link to existing other docs (maybe there are already dedicated threads or wiki entrys for the FP3 and FP4). For the second way (patching a boot.img) I think it might also worth to mention where to get the boot.img (Magisk install doc does not really say something about it)? I assume extracting it from your rom’s build zip which you plan to install, right?

Also a point which can be mentioned - a recommended moment when to setup Magisk? Directly after the LOS flash or boot the OS ones and e.g. set up encryption and then setup Magisk…

1 Like

maybe this recent discussion in german helps. 🇩🇪 Lineage 18.1 rooten

there was a how to that is obsolete in my eyes as Magisk recently changed “a lot”. For FP4 we have a good guide on how to root with Magisk, don’t know about FP3 havent searched for it.

Thanks. Also not that on point but hints like:

Übrigens ist die “alte” Methode (= via TWRP zu flashen) bei mir die, die am zuverlässigsten funktioniert hat.

Should be part of the wiki note and as explained maybe just link the other descriptions/guides for the other fairphones (and do not double the info). I think about some kind of “master-note”.

Maybe I will prepare something as soon I my phone is set up again :wink:

I updated my post above and the “sideload zip” way (nr. 1) worked fine with Magisk 24.1

1 Like

This here is the LOS thread, nothing Magisk specific and when you feel something is not up to date, then either rewrite thewiki, or if the topic is no wiki, then yes write a wiki or I can make the topic a wiki for you to update?

Edit:I see you should be able to open the old topic and make it a wiki on your own😉

1 Like

I confirm that this method always worked for me on FP2 :slight_smile:

1 Like

Should the TWRP method ever stop working as its no longer really maintained, this is a statement for FP4 but assume is true for FP2 and LOS as well

“The current stock boot images for FPOS can always be found on the kernel page, the /e/ ones can be taken from their released zips”

1 Like

Thanks for this little add. :+1: This was, what I wanted to know. For Magisk 24.2 I can tell it does not work with a patched Magisk boot.img. I took one from FP Open’s zip as wall as one in the latest LOS Zip → no success in both cases. As the old (sideload zip) way worked for Magisk 24.1, I did not try the patch boot image way again with this Magisk version.

Regarding TWRP:
I was always a TWRP user, but this time (as I read some difficulties - probably only regarding encryption) I used the LOS Recovery.
At the end I mostly used the wipe possibilities and adb sideload and this is possible with LOS Recovery as well.

TWRP always had difficulties with encryption on FP2, but for this release of LOS (18.1), TWRP has also difficulties with the LOS OTA updates: the two times I tried I got a not-booting device after performing a Lineage OTA update :frowning:

I assume there are good reasons for the initial statement about TWRP😉

And you did a quite dirty installation, not recommended

1 Like

I agree!
But I’m a researcher and I like to experiment by myself :angel:

BTW I noticed that dirty installation (migration LOS 17->18) is not a problem with TWRP.
The issue came only with OTA-updates, both on the dirty installation and on a fresh-installed LOS 18.1 :slight_smile:

1 Like

I usually only update my phone if the Android security string was bumped again, so I did that the day before yesterday. Today I wanted to use Osmand which usually has its maps installed on the SD card. Now it fails to do anything with the SD card. It cannot list the available space, it cannot find the maps, I even extracted the Osmand directory from Android/data/ and moved it to the root directory of the SD card to have it out of the sensitive area. If I tell Osmand to use this new directory it tells me that it cannot create maps in that directory.
I’ve looked through the changelog of LOS and found this one:
Could that be related to the issue I’m seeing? Does anyone know how I could fix this? For a quick workaround I could put the maps that I currently need into the internal storage, but usually I have more maps than what the internal memory permits…


I was brave and replaced LineageOS recovery with the latest TWRP and it was able to decrypt. Not sure about OTA-updates. Did anyone try that yet?

1 Like

Replying to myself: Is there really no one else using a FP2 with a current LOS 18.1 and Osmand with maps on the SD card? Can anyone confirm if the change that I found could be related to my issue. If it is related, what would be a good way forward to have my maps back in the SD card again?

Replying to myself again. Seems like not only the FP2 is affected and it seems like other people found where to post such things… :roll_eyes:

1 Like

Hey @Martin_Anderseck , sorry for the late reply. I had also some trouble when I moved from Lineage 17.1 to 18.1 with osmand~, as I wanted to prevent to download all the maps again. I set up my FP2 clean from scratch and as soon as 18.1 was running and the device was encrypted, I restored all my apps data with GitHub - NeoApplications/Neo-Backup: backup manager for android (v7.0.0 that time). All went well, but some errors were shown for Osmand~ after starting it for the maps. I tried to manually fix that by setting up a new folder on the SD card (backup up the initial one before manually → copy to PC) and overwrite the content of the new one after re-configure Osmand~ from scratch. But on that way, I somehow lost my favorites (marked places) etc… (maybe if I would have been more patient to 100% understand, where the Osmand~ favorites are save there might have been a solution - anyway)

If i remember correctly I finally restored the data as already explained and configured a new directory after the first start (I think it offers a migrate to new directory option). The maps were lost, but I now download them step by step when I need them.

No issue with using “External storage 2” which is my 128GB A2 SanDisk Extreme SD. :thinking:

PS.: For simple navigation I use this now:
Which I think finds a route quite quickly and is not that feature rich (people tend to say “overloaded”) like Osmand.