Lineage 17.1 for FP2 - Second preview version


Older stuff:


  • Official twrp should do

As usual: z3ntu (who did lot of the bring up work), m8 maintainers (bgcngm) - from which I kanged lots of stuff, all other lineage members who helped (mikeioannina, and lots of others).

Can now be downloaded from (ARM, 10, Pico).

What doesn’t work:

  • Encryption: Seems to hang on bootloader image after reboot. But it seems to work. Wait a few minutes and then restart with power button. Most likely Selinux issue. Will try to fix. UPDATE: Seems to work now (with 17.1 - beta1)
  • Apparently “Casting” does not work

What is not thoroughly tested:

What is not implemented yet (*) on lineage:

  • MultiSIM manual provisioning (means multi sim disable through settings - afaik)

What will most likely (*) not be implemented any more on Lineage:

  • PrivacyGuard

(*) This is afaik - please dont bug me with this or this thread. You can join #irc of lineage to request xyz feature


Oh cool! Might try it today :slight_smile:

Do I need a certain version of TWRP to install?

Official one should do.

1 Like

Even tho it’s kinda obvious that this is for FP2, could you add that to the subject (topic)?
(Saw you did that now, probably before I commented on it. :slight_smile: )


Installed smoothly (using the existing TWRP 3.3.1-0). :slight_smile:

First second impression: I’m suddenly getting to hear – certainly all normal – regular feedback sounds I didn’t use to hear under (my) LineageOS 16 installation.

Next observation: Display will go to sleep after one minute, but wakes up again after 7 seconds (happens both with cable connected and without only). Please note: I always had a similar issue before (under LineageOS 16) as well that no one else here seemed to have: Display would only dim, but never fully go off when cable connected (did not happen then with cable off). Manually switching (button) the display off works without re-awakening.


Installed using official TWRP 3.2.3

  • wipe: cache, system
  • format data
  • sideload Lineage + opengapps ZIP files
  • reboot to install

If you need more details how to do the install, head over to


  • follow the initial setup assistant
    • use PIN
  • log in to Play Store
    • disable backup in Google Drive
  • set SD card as external (mobile) storage
  • disable sounds and vibration for touch screen
  • disable vibration in keyboard settings
  • enable gestures (“new” navbar instead of back/home/applist buttons)
  • edit icons in quick settings menu to also show location + set location to battery saving
  • enable automatic brightness
  • disable “tap to sleep” and “wake on plug”
  • disable music visualizer on lock screen
  • show battery percentage in status bar
    • is not show in status bar, but only by pulling down once in the quick settings

Installed some apps

  • CardDav sync and CalDav sync
  • Moia
  • Spotify
  • Twitter
  • more to follow…

Things that work

  • bluetooth
    • audio speaker: MusicMan BT-X2

Things that don’t work

  • screen cast
    • in order to find my Samsung BD-J5500 Blu-Ray player that works well with Lineage 16.0, I first had to tap “settings” and then the three-vertical-dot menu to enable external display
    • but then, on connecting, the phone crashes after a few seconds (not asking for SIM PIN, so maybe some kind of warm reset?)
  • Notification LED
    • so far only tested with incoming SMS (text message)

Great news!
Will upgrade my partner’s and my daughter’s FP2, currently running 16.0, when it goes nightly.
And makes me dream of a 17.0 port for my FP3. Maybe in a few months…:wink:
Thanks again to @chrmhoffmann and @z3ntu for all that work on their spare time!


I notice there’s VLC among my apps under LineageOS 17. Now I wonder if this is because I myself installed it under LineageOS 16 and it has somehow been carried over when I installed LineageOS 17 – or is it pre-installed in LineageOS 17 by default? I did not install any apps today since installing LineageOS 17.
I notice self-installed apps seem to be taken over from whatever OS was installed right before. In my case, I found VLC under LineageOS 17 on my first install because I had VLC installed (myself) under the previously installed OS (Fairphone Open OS 19.08.1). In the meantime I returned once to a backed-up LineageOS 16, and having now installed LineageOS 17 over that, I now see apps that I installed myself under LineageOS 16 (e.g. Checkup, Firefox Klar/Focus, F-Droid …).

Has anyone been able to restore a TWRP backup of the new LineageOS 17.0 ? I have tried this twice now (i.e. creating seemingly a successful backup twice and afterwards trying to restore it) and after restoring, it keeps just reaching the Lineage animation and has the pulsating bubble moving repeatedly from right to left without end. Need to newly install LineageOS 17.0 instead.

1 Like

I successfully upgraded my LineageOS 16 to this BETA LineageOS 17.0 with TWRP 3.2.1-0, installing the ZIP without any wipe.
It works well, all my apps are still there and working, except:

  • My banking app that detects that the device is rooted and refuse to work. (Is it because it’s a custom ROM? I didn’t migrate the keys so I have a TRUST warning…)
  • I tried to install an update for my banking app, but Amaze is unable to install any APK file, it just gives “Error”. I checked settings and installation from Amaze is allowed. I’d like to investigate this later with adb logs once I’m connected with my computer… Installing a new app from F-Droid is working flawlessly.

Nice job, Chris and Z3ntu ! :smiley:


Here is the ‘adb logcat’ error message! (identical when trying to install different apk, only file path varies)

12-09 21:18:24.612   762  4708 I ActivityTaskManager: START u0 {act=android.intent.action.INSTALL_PACKAGE dat=file:///storage/emulated/0/Download/be.keytradebank.phone_2019-09-23.apk} from uid 10098
12-09 21:18:24.614 11900 11900 W System.err: android.content.ActivityNotFoundException: No Activity found to handle Intent { act=android.intent.action.INSTALL_PACKAGE dat=file:///storage/emulated/0/Download/be.keytradebank.phone_2019-09-23.apk }

By the way, root is not conserved doing the upgrade, and there is not yet any “addonsu-17-xxx” package on LOS website. Let’s wait to test root functionalities :wink:

This is absolutely amazing! Upgrades are coming faster every year! :clap: :smiley:

Just upgraded via TWRP 3.3.1 without any wiping (but switching keys using script and its working like a charm! All apps and settings are still there!

I had to repatch the boot image for Magisk for Root access (but still hiding it from my banking apps :shushing_face:) and it seems to work so far.

I also tried to reinstall UnifiedNlp from here but this seemed not to work. Will investigate further…

I cannot install Apps with Amaze either (Error) but it works fine with the Files-App. Could it be a bug in Amaze?

Thanks again for your amazing work on LineageOS!


Thanks @darioce for the pointer about Files instead of Amaze. Now I was able to install the downloaded F-Droid App :slight_smile:

1 Like

Could you please possibly explain the need of running that script (which exactly?) ?
What are these keys for?
And: Where are the paths described in that wiki?
Sorry for asking questions obviously well known for all :wink:

The scripts mentioned in the link can be found here:

I’ve not tried this yet, but I think the idea is that you need to tell your FP2 that you are using an unofficial version. So you need to replace official with unofficial. Not sure what happens when you don’t do this. I’m guessing it won’t install?


Right, so as far as I understand this will not be necessary with the official version in the future?

Sorry, I get the message that the file verification failed. I tried to install with the newest version of TWRP (3.3.1-0) and after that I tried an older one. Tried to install TWRP 3.2.1-0 but after doing that and started again I got the message Version Don’t know why.

I tried to install by sideload first, then I took out the SD-card and copied the files on it, booted into recovery and tried again. Both methods failed. TWRP does the file verification wether I disable the checkbox or not.

So what else can I do?

With the official LineageOS versions, I never had to do any manual tweaking or scripting. :slight_smile:

1 Like

Strange, notification LEDs work here (for example incoming SMS / text messages.

Have you checked the settings? Did you upgrade from 16.0?


Congratulation! Great work!

Question re

Does it seem to work with TWRP, i.e. can we expect that TWRP can decrypt or is it like LOS 16.1. where enc works but it is not possible to backup with TWRP?