English

Lineage 17.1 for FP2 - Second preview version

Tags: #<Tag:0x00007f05e1a96558>

This is not related to TWRP. TWRP will have same “issue” as under 16.
Chris

It will install (I tested it), just giving an annoying message from TRUST that the keys are wrong. But you can deactivate this verification in Trust settings :wink:

Maybe your file is corrupted… Did you checked the md5?

2 Likes

FYI … there will be no “addonsu-17-xxx” …

3 Likes

Hi Chris, I didn’t have time the past days to look into it.

It was a fresh install (coming from Ubuntu Touch).
Will check the settings at some point.

Thank You a lot. I now cleaned the phone by wiping everything except SD-Card. Now the installation with TWRP 3.3.1.0 worked without problems.

1 Like

Installed it and works like a charm. So far it was even way more stable than the Fairphone OS 19.08.1, which is a bit strange. Thanks a lot for the effort - this Beta Preview is way more stable than usual Betas of most apps.

Still trying to wrap my head around the signing procedure:

  1. Installed ADB
  2. Moved the lineage zip to the phone’s internal memory (root)
  3. Used the following migration script: https://github.com/LineageOS/scripts/tree/master/key-migration
  4. Made the following steps with adb:
adb root # This requires an userdebug/eng build and ADB root access to be enabled
adb shell stop
adb push ./lineage/scripts/key-migration/migration.sh /data/local/tmp/migration.sh
adb shell chmod +x /data/local/tmp/migration.sh
adb shell sh /data/local/tmp/migration.sh unofficial
adb reboot recovery
# Now install the official LineageOS install zip
  1. No errors displayed
    However: As far as I can see the install zip has not changed. After installing it again the same warning from Trust (signed with official keys) is displayed. As an absolute beginner I probably still don’t understand some parts of the signing process… :frowning:

Thanks for the hint.

After reading the article you posted, I installed https://github.com/topjohnwu/Magisk/releases/download/v20.1/Magisk-v20.1.zip via adb sideload and I now have root for CatLog and 3C System Tuner.
I also granted root to AdAway but that fails to update the hosts file. Logcat shows an error that mounting the filesystem RW failed (and then of course updating the hosts file is also not possible).

You could try:

  1. adb root
  2. adb remount <- this remounts system r/w
  3. try install adaway

Just guessing - have not tried myself.

Chris

Changing signing key does not change anything about the “Trust” warning. The unofficial Lineage ZIP here is signed with public keys. Only official Lineage releases are signed with “official” keys and “Trust” will not complain about those.

Switching from official to unofficial keys during upgrade has nothing to do with “Trust” warning.

I also do not exactly know why this is needed. I think it is needed to properly migrate data from 16 to 17 in case you switch from official to unofficial.

Chris

2 Likes

Thanks Chris for clarifying the issue! Data was perfectly migrated for me, so I had no issues with that. No crashes on the phone for 3 days of heavy use. I’m totally happy with that version after my very mixed experiences with official 19.08.1. (Don’t know why there is such a big difference but my fairphone was never that stable so far). Big thanks for all the work!

2 Likes

I found a github issue about this: https://github.com/AdAway/AdAway/issues/1477

So the solution is to

  • go to settings of Magisk Manager and enable systemless hosts file
  • reboot
  • enable filtering in AdAway
2 Likes

About the notifications I have some more observations.

Yesterday I got a couple of mentions in Tusky (Mastodon client).

The first time around this happend

  • sound was played
  • LED was blinking
    • stopped blinking after I read the corresponding post (as expected)

The next time only the sound was played and no LED light…

Will observe further.

1 Like

OK, I’m testing now and reporting my first Errors:

  1. When I make a call, in the moment I start the call, the display switches to dark. No possibility to end the call, If the call has ended, I can switch on my screen again.
  2. The same, when I want to play an audio in whatsapp. I have to wait until the audio ends and then I can switch on the screen again, not before.
    Playing videos in whatsapp works properly, also playing mp3s in my audioplayer software “Music speed changer”
  3. Incoming call: Screen switches to dark in the moment I accept the call by touching the green button. I can’t end the call.
2 Likes

First findings:

Coming from Lineage OS 16.0 official version, with Unified NLP Zip from @Roboe and Magisk:

  1. I can confirm Ingo’s notification issue. No notification whatsoever for incoming SMS. I tried it with Silence as the default SMS app and with Signal as the default SMS app.

  2. After a restart, the code to activate the screen works only the second time around. This does not happen when the phone goes into standby. Only after a restart. And not always. Happens randomly.

  3. Magisk works great.

  4. Location settings do not work with @Roboe 's Unifiednlp zip . This is however not related to Lineage OS and the issue is already mentioned here.

I have to go back to my TWRP backup of Lineage 16.0 for the next few days because of a busy schedule. Will test it the next weekend again.

Thanks @chrmhoffmann @z3ntu for the great work.

Cheers

3 Likes

What are the first observations for Wifi stability in comparison with other OSes for the FP2? @chrmhoffmann Did you also downgrade the WLAN driver like Fairphone did in their latest OS releases?

Not a solution but might be related to getting a black screen during calls.

I remember having a similar problem last year while I was still on official FPOS. It went away after I calibrated the proximity sensor using the built in tool. If that’s the issue, maybe there is a similar tool for Lineage?

LineageOS 17 includes “Calibration” (app) which is the Fairphone proximity sensor tool.

5 Likes

I had the same issue. Your approach worked for me. Thanks for sharing.

On similar lines:
I had the issue that I could not install any apps from Android via the priviledged extension when I flashed it via TWRP.
Using the MagiskModule worked for me.

1 Like

Have been going through the Settings recently and found a few minor things not working for me:

  • Live display settings cannot be changed, seem to be off by default
  • Status bar/Battery Symbol does not show Percentage, although selected in the settings

Is anybody else having these problems?

1 Like

I noticed the problem with the battery percentage as well.

Don’t know what live display is, so no idea :wink:

1 Like