English

Lineage 17.1 - FP2

Tags: #<Tag:0x00007f05daf7b110>

This is exactly the issue. Current image is read only. Do not install this image.

su package does not exist anymore. You have to use adb root or install magisks

Chris

Anyone has tested to hide Magisk root from banking app? That was the only thing blocking me from using the Beta LOS17 as a daily driver :wink:

1 Like

Exactly the same for me. In fact, when I switch off airplane mode, Wi-Fi is automatically reconnected which I didn’t get with LineageOS 16 (I would have to switch off Wi-Fi on the FP2 and switch it on again to reconnect) – so to me Wi-Fi works better with 17 than with 16.

Updater gives an error message so far, but I assume this might just suggest there simply is no new update yet. I believe this is unchanged from 16. Still the message remains confusing.

Click for screenshot.

Not using/installing OpenGApps, so cannot add to that.

It seems that after while of having data transfer via USB activated, this switches to USB tethering by itself. (Computer running MacOS 10.11.6)

P.S.: These observations referred to the 01042020 build.

2 Likes

And what are the differences feature-wise, is decryption working for any of the two yet?

I had the same questions in my mind, also a guide (link) how to root would be nice?

1 Like

Only a partial answer: taken from Lineage 17.1 for FP2 - Second preview version

I used TWRP 3.2.3

LiveDisplay doesn’t work for me, too. So I guess its back to Red Moon until there’s a fix for Live Display.

TIL: Signal can’t be restored from TitaniumBackup, as it uses Android KeyStore, which, by design, cannot be extracted/backed-up. Use Signal’s own back-up feature to save messages. Thought I’d share this.

Looking forward to test:

  • if Netguard works again
  • if wifi is still connected during sleep / auto-reconnects on wake-up
  • if the “Snap” camera app puts it’s photos again where they belong: my photo folder
  • if Tap’n’Turn works again
  • if the “Home” system profile auto-disables my lockscreen pattern while I’m on my home WiFi… (looking good)
  • if UnifiedNLP and GPS fix still works
  • if F-Droid priviledged extension (automatic updates) still works
  • … all the other little rough edges of LineageOS 16.1

@Singulus I managed to root my devices by sideloading Magisk-v20.4.zip from here in step 7 of Lineage Install guide and then later-on installing MagiskManager from the same site.

good luck!

2 Likes

Where can you get LOS 17? I can’t find it on the linked pages…

The first available builds had issues and got removed.

1 Like

its being built again…

3 Likes

All built again. Thanks @chrmhoffmann :slight_smile: . Are the lights green :traffic_light: ?

2 Likes

There seem to bee issues with the F-Droid Privileged Extension. However, there’s a Magisk Module available for those of you who rooted their FP2 LineageOS 17. 1 by flashing Magisk.
Just go to Magisk Manager > Downloads, search for “privileged”, install the F-Droid Privileged Module and reboot. Worked like a charm for me. :white_check_mark:

3 Likes

I actually was curious and tried today’s LOS build plus GAPPs. It worked, but only after formatting the data partition. Without format the GAPPs first install wizard never completed and crashed always before finishing.

6 Likes

thanks for taking the risk and sharing your experience!

1 Like

I’m actually not sure if a simple factory reset would have been sufficient. But as I only changed a couple of settings and installed like three apps from fdroid with yesterday’s broken build, not much damage was done by formatting.

I installed the April 2nd lineage build with the April 2nd OpenGAPPS directly over it and it worked.

I didn’t have to do a factory reset!

I didn’t lose any data from lineage 16.

6 Likes

I guess the difference could be that you never made it to a running system with yesterday’s build?

Yes! Green!!! It seems to work.
Please only use latest versions of
lineage + recovery + opengapps

15 Likes

so first install the lineage recovery, then todays lineage 17.1 build and then open gapps? is this the correct procedure?

1 Like

Please note that if you’re currently on an official build, you DO NOT need to wipe your device.

If you are installing from an unofficial build, you MUST wipe data from recovery before installing.

(from the LineagOS Blog )

1 Like