English

Lineage-16.0 (Android Pie) Nightly

Hi there,
there more a dozen users in this topic but
https://gitlab.com/LineageOS/issues/android/issues/937 1
has only two votes.
That affects anyone who uses LOS and Lock Screen, so please vote for it

1 Like

If I get this correctly: It only affects people who use LOS and a lock screen pattern (not PIN or password) and a certain grid size and GApps and Google cloud backup (ouch). That’s why it might get limited attention. Spamming this thread probably won’t change that.

3 Likes

PackElendFairphone Angel

1m

There a lot of and that true but to ensure a nice and easy user experience for standard user.
If I tell other users of my positive LOS experience and you still have the same feature as on stock ROM is required, such tripping hazard must not happen.
Such things are showstoppers, this rumors scars off any standard user.
A standard user may does not LOS flash so I was often contacted to do so for him or her as my function of Angel.

Finally got around to install LOS16. Thanks to everyone involved in this :slight_smile:

2 Likes

I tried as you described in your link. But it didn’t work, had many reboots since then.
Here is a link to some more: last_kmsg.zip
I used to have them quite often with Fairphone Open OS, very seldom with LOS 15, but now with LOS 16 my phone is rebooting at least 10x a day.
Any help would be awesome!

Since I installed LOS 16 yesterday, I had a few observations… not sure if they are going to repeat themselves:

  • Was connected to my WiFi (11.ac/n) but unable to connect to the internet. No other device had that problem at that time. I switched to my 2.4Ghz network and then it worked fine again. Weird.
  • Some stability issues with mobile internet when traveling in the bus - went from 4G full bars to nothing and back and forth again. Also weird.
  • The issue that I hoped to overcome by upgrading is that for a few days now my GPS has become very inaccurate and slow. Still the same. Maybe a hardware thing :frowning:
  • I can confirm that I also have problems with 5Ghz WiFi
  • No problems with 4G
  • I can confirm with the latest update problems with GPS, it takes forever for it has a fix.

I can not download the version 20190918 when checking is faulty and manual installation is the file is damaged

3 Likes

I can confirm this problem, it’s exactly the same (just tried through updater, I didn’t try manual installation though) on my FP2 with 20190918. Right after trying, the 20190917 update worked without any problems (I was on 20190916 before).

I can also confirm the GPS-issue, takes a very long time to get a fix.

Before the “boot-issue” I was on 20190818 and GPS worked perfectly. On 20190912 and on 20190916 it takes forever to get a fix if it even succeeds. (Gmaps usually succeeds in getting a rough position, ±2 km, but the excercise-apps usually fail as they need better accuracy)

Yeah, around that time I also started having huge problems - thing is, I was on LOS15.1 at the time. So I suppose it is a “google play services” problem or similar. This has happened before. I think it is not a problem with LOS - or at least, it was the same on LOS15.1 and 16, which is unlikely.

I was on version 20190912 have now on 20190918 update but only until the version 20190917.

Well maybe, but I didn’t update Gapps until 20190916, for 20190912 I had the same Gapps as i had in the august version. For the 16 version I also updated gapps to check if that was the cause, but no difference

The GPS Problem is the same on my SGS5. It takes up to ~2 minutes for getting the position. And somtimes position get lost on road. So it probably is not related to FP.

1 Like

LineageOS for microG 20190917 here, I don’t know which regular LineageOS build this is based on.
I took a closer look today after I initially just checked that GPS worked in general after updating.

It’s not entirely consistent, but the problem affects LineageOS for microG, too.

Sometimes I get my location instantly, but most of the time it takes much more time than before, and the detection of movement (location icon in OsmAnd changes from dot to pointer) seems to be affected, it constantly changes from fixed location to moving and back.

Satellites are found without a problem and the satellites in range count is constantly updated, though. Also confirmed with SatStat.

I tried to simply install the older build, but it doesn’t like my encrypted data partition. I would have to restore a full backup instead, which I don’t want to do just now.

P.S.: No trouble with 5 GHz WiFi and mobile internet connection.

1 Like

Update 20190919 successfully installed here. :slight_smile: Thank you, Chris!

1 Like

I have narrowed the WiFi issues down to the following:

  1. When there is only a 2.4 GHz network among the known networks in the range, the WiFi works just fine. :white_check_mark:
  2. When there is a network that provides 2.4 GHz and 5 GHz simultaneously, the WiFi is unstable. :x:
  3. When there is both a 2.4 GHz and a 5 GHz among the known networks in the range, WiFi is unstable: :x:

When I enable Ausführliche WLAN-Protokolle aktivieren (~ Enable detailed WiFi protocols) in the Android developer settings and observe the list of WiFi networks (which then shows the individual frequencies per network), I can see that the 5 GHz frequencies often keep appearing and disappearing.

PS: I was wondering whether updating the modem files could fix this. (I have read about it, but don’t recall actually having done this.)

4 Likes

I don‘t have wifi problems on myself but you could try the change in this post of a different device which leads to good outcome for a lot of people regarding 5ghz.

https://forum.xda-developers.com/showpost.php?s=0e63a9af9b9286fd66a17916f94a86db&p=80247634&postcount=1059

I cannot see any pattern in your kmsg files and so it is very difficult to analyze if we have not more information than: “My phone is rebooting at least 10x a day”.

  • First of all install a known functional nightly build of lineage 16.0: I think the last one reported in this thread was 20190919
  • What is your cpu temperature right before reboot?
  • At current level of knowledge my guess is still a hardware(driver) issue. You can try to disassemble your phone and clean all your metallic contactors with alcohol/electronic spray and then reassemble the phone.
  • If you are familiar backing up your partitions with TWRP you can do this and try a clean install of lineage (means to delete system and data partititon) to see if the problems continue to exist. Afterwards you can restore data/system partition from TWRP Backup.
  • Further I recommend to go through the list at: ✏ A little Guide to... Random Reboots
1 Like

If it can help, I found out the reason of my reboots was the “MPDecision” option enabled.
I’m no expert, but it has to do with the CPU and the on/off state of the 4 cores.
When this option is enabled, my phone is very unstable, borderline unusable.
It’s possible to disable the option in the L-Speed application and in the kernel adiutor application.
HTH

3 Likes