Keeps asking which launcher to use

That is the latest update, and sure some default settings may have changed, finding them ??

But note the posts you refer to via the link are two years old though they do refer to a number of phones.

You may try disabling all your custom apps, one at a time to see if there is any change or do a safe mode start which disables all of them and then enable them one by one.

It is notable that this is only reported on the FP3 A11 not the FP4 A11 so the issue does point to the an update somehow, though you may have had updates to the custom apps you are using to.

Had the same behaviour after updating the Android version. It wasn’t the first time though, and in an earlier version I had to set the standard-start-app first to Quickstep and then back to Lawnchair again. Important was to do it in the standard app settings, not by answering the choice of the standard-start-app. This time I had to repeat this procedure, switching back and forth between the launchers a few times and did some restarts between, now it seems to remember the launcher again.

Edit: Seems I celebrated too soon, every now and then the choice dialog still appears. Most of the time it is when closing an app (opening list of most recent apps).

4 Likes

For the record, the latest update was this, at the end of July: Software Update: 8901.4.A.0013.4

1 Like

Yes as mentioned that is the same one. Security updates do not necessarily coincide with OTA updates pushes

1 Like

I haven’t been able to find a series of steps to fix this, even after trying various things. It would be nice if someone discovers a definitive procedure to get the setting to stick.

1 Like

That may be a problem as it could be different for different people. Have you tried a safe mode start etc.

Also remove the launcher and let the phone settle down for a week maybe?

1 Like

I use Nova Launcher and I am usually happy with it. The phone now asks which launcher to use about 1-2 times a day. It seems like a bug in the default Quickstep launcher, which cannot be completely disabled as it seems. It did not happen right after the last system update.

Selecting “always” does not help.

5 Likes

If the hypothesis is a bug in the Android update or in Quickstep, I wonder where we should report this to Google (or Fairphone)?

To Fairphone in any case, you should #contactsupport. If ever it’s not their problem, they’ll tell you so or send that to the relevant service at Google.

This is not about the bug (since I use /e/) but did you try the KISS launcher?

If you only need one screen with widgets then this is the perfect launcher. The search is working really well, so besides a few main favourites I can open all other apps via checkin the whole list or open them via the search function, where I can find everything on my phone (apps, contacts, etc.) just by writing two or three letters in the search box.

You can download it with F-Droid.

I have the same issue since a week or ten days, with Nova Launcher (paid version).

The phone asks me what launcher to use about three times after I reboot it. I usually reboot my phone Evey morning.

It started some time after I updated to the June security update.
My guess is this may be related to some (Google?!) app or service updated in background lately.

2 Likes

Did any of you try clearing the cache (or even storage) or force stopping Quickstep?

Yup. All of those. All at once.

2 Likes

Hello

I have the same issue (the default launcher setting being asked every few hours) but with Lawnchair.

I wonder if it’s concerns only Nova and Lawnchair.

Nope
Exact same issue here with Kiss Launcher installed from FDroid

2 Likes

Same here. It started today (16.8.22). I have to choose launcher almost every time I press the home button. It is infuriating. None of the proposed solutions above worked.

3 Likes

Same issue with before launcher.

@rae, bringing your attention to this topic as it seems a widespread issue since last update.

6 Likes

Same issue here. It started out of the blue just yesterday (not immediately after the Android update in July).

Using Nova, full paid version. There was no update of Nova recently.

1 Like

As many people (except I) use Gesture navigation probably this helps (from a Samsung forum where the exact same issue is described about 2 years ago)

1. Cleared default launcher.
2. Switched back to navigation buttons.
3. Restarted phone.
4. Switched to navigations gestures.
5. Chose my default launcher.
6. Upon restart, launcher was still saved.

Maybe also vice versa helps in case you dont use gesture navigation…

1 Like