Keeps asking which launcher to use

Yup. All of those. All at once.

2 Likes

Hello

I have the same issue (the default launcher setting being asked every few hours) but with Lawnchair.

I wonder if it’s concerns only Nova and Lawnchair.

Nope
Exact same issue here with Kiss Launcher installed from FDroid

2 Likes

Same here. It started today (16.8.22). I have to choose launcher almost every time I press the home button. It is infuriating. None of the proposed solutions above worked.

3 Likes

Same issue with before launcher.

@rae, bringing your attention to this topic as it seems a widespread issue since last update.

6 Likes

Same issue here. It started out of the blue just yesterday (not immediately after the Android update in July).

Using Nova, full paid version. There was no update of Nova recently.

1 Like

As many people (except I) use Gesture navigation probably this helps (from a Samsung forum where the exact same issue is described about 2 years ago)

1. Cleared default launcher.
2. Switched back to navigation buttons.
3. Restarted phone.
4. Switched to navigations gestures.
5. Chose my default launcher.
6. Upon restart, launcher was still saved.

Maybe also vice versa helps in case you dont use gesture navigation…

1 Like

Same issue. Nova launcher. Tried clearing Quickstep (can’t be disabled), switching back and forth between default launchers, disabled battery optimization (to prevent nova from being killed by Android) and virtually all of the above. No working solution yet.

2 Likes

So can you confirm you also tried the gesture navigation thing I posted? As you dont mentioned it and it would be good to know.

Cleared the cache and it still asks, but it is very rare now so testing counter measures becomes quite difficult.

1 Like

As a sequence of steps I haven’t followed before, I had high hopes. Not being a gesture navigation user, I couldn’t follow it precisely. I did:

  1. Cleared default launcher. (in itself a step I’d never done before)
  2. Switched to navigation gestures.
  3. Restarted phone.
  4. Switched back to navigations buttons.
  5. Chose my default launcher. (in the settings, before ever hitting a navigation button)
  6. Restarted phone.

Didn’t work. And now it’s pestering me more frequently than before :joy:

3 Likes

Oh no, so sorry :see_no_evil: still thanks for testing and the feedback it might still help to troubleshoot.

1 Like

Same issue here. fwiw: I used Nova when this annoying behavior started; now regardless which launcher I’m using it remains. On the positive side: this motivated me to experiment with different launchers. :slight_smile:

One other issue that started about the same time is that MS swiftkey keyboard keeps telling me that the device language changed. Which of course it hasn’t. Has anyone else who is hit by the launcher bug observed this as well so there is hope that when one issue is resolved the other vanishes with it?

Hi just a couple of queries given I’ve use Nova since I got the phone nearly two years ago and do not have that problem.

  1. Do you have the ‘Home app’ set as yes under ‘Nova’ and no under Quickstep
  2. Can you change it to Quickstep > Yes and Nova > no and does that at least give a stable outcome
  3. Is it OK i.e. stable when there is no alternative launcher
  4. How did you install the launcher, let’s say Nova and what version is it.

For example I downloaded from apkpure.com and installed manually and some months ago updated to version 7.

Hey. No one has asked for permissions yet. have you given the launcher all the permissions it wants?
I use 1. Smart Launcher Pro (Beta Tester and Alpha), 2. Nova Launcher Pro 7 (Nova 8 with Branch: Kiss my A…), 3. Quichstep in case anything goes wrong. Quickstep has no permissions (it gets them if needed) Nova all, Smart L. all.
I don’t get the request for the default launcher.
My procedure to change a launcher is always via System Settings - Apps & … - Default Apps - Start App then the selection. Never via the app drawer.
I installed the launcher via the Play Store, no third-party providers.
No problems and with Netguard you then have control.

No, sorry, not that one. Didn’t think of that one because I honestly didn’t understand it. I don’t know what gesture navigation is… :thinking: I’ll have to look it up.

Dont worry I assume you dont use it, when you dont know what this is and we have a first feedback, that it did not help, and might even worsen it. Just FYI, you would find it under settings-system-gesture-system navigation

  1. Yup (using Niagara now, but it was the same with Nova)
  2. Yes I can change it, but no it asks again upon restart, though this time with Quickstep as the primary suggestion.
  3. I’m not prepared to test this. I’d have to set up Niagara again (unlike Nova it doesn’t have a way to export/import settings). It seems a good bet that it would be stable (why would it ask which launcher to use when there’s only 1?), but we can’t know for sure until someone (maybe someone using Nova) tests it.
  4. Play store. Nova 7. Not Pro. Niagara also via Play store.
2 Likes

I’m using Microsoft Launcher on my Fairphone 3 and got the same problem after the latest Faitphone update. I’ve tried to remove Microsoft Launcher and install it again but the problem is the same. On Fairphone 4 it’s no problem.

2 Likes