Issues rooting a FP3

Hello there,

I’m afraid that TWRP is only half the battle. As I have described here, there are also ways to root the FP3 that do not require TWRP.
Unfortunately, Magisk (v25.2) also seems to have a problem with the dynamic partitions, because the generated boot.img ends in a boot loop.

What about latest Magisk v26.1? Can anyone confirm that this release works again or not? :pray:

New Magic Mount Implementation

Magic Mount, the feature that make modules modify partitions, has gone through a major rewrite. The existing implementation doesn’t work well with OEMs injecting overlays into their system using overlayfs. The new implementation fundamentally changes how filesystem mirrors are created, giving us a more accurate clone of the unmodified filesystem.

Just generated the boot.img (from FP OS FP3-8901.4.A.0022.0) with v26.1 and tried to boot it via fastboot. Unfortunately still instant reboot :pensive:

1 Like

As you post about rooting in the TWRP topic I assume you try to use TWRP somehow?

This is there instruction for the FP4 and I would assume work the same for the FP3 and dont require TWRP

And without having ever tried one or the other it def sounds easier then the FP3-TWRP way

1 Like

Sorry for the confusion and posting in the “wrong” topic, but TWRP indeed was not involved.
I tried the way you mentioned but in step 3 the phone won’t start with the patched boot.img. Instead it instantly reboots and loads the unpatched stock boot.img from its internal storage.

I moved the discussion to a new topic.

Maybe you will find furher tipps also in the FP4 topic

That’s apparently a known issue on the FP3 :point_down:

Not sure what’s going on there :thinking:

Since it’s affecting several people it might be time to open an issue on the Magisk bugtracker again. Someone already did but it got closed because they failed to provide logs.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.