Issue with date time since Android 12 update

Did more people notice that (at least) the time does not update anymore when the phone is switched off? Now each morning my phone has the same time from when I switched it off the night before. This occurs since the update to Android 12.

1 Like

Welcome to the community :wave:

Is your issue similar to the ones described in

If that’s the case, it’s been there before A12 and there doesn’t seem to be a fix so far.
You can continue in that other topic, if you want.

Hello,

No the issue is not similar. I only experience the issue when I switch off the phone completely and switch it on again any period later.

Hi

Do you use Network provided time and when off are you still connected to the network?

No I don’t use the network provided time.

Aaah, you are switching the phone off completely, hadn’t considered that possibility.

Does the clock switch to the right time after a while or do you have to set it yourself every time? :thinking:

Yes I don’t use the network time either.

I only have to set the time on the occasions I remove the battery but not if I just power off, but then I have also have an FP3 with A11

Haven’t waited for more than 5 minutes yet. But on the other hand, that wasn’t necessary before the update.

Hello everyone :slight_smile: ,

I have exactly the same problem like Sander_Engelen. I opend up a ticket already to inform the fairphone-team about that issue.

Best regards

1 Like

I have this issue every morning when I switch the phone on it is the wrong time and hence the alarm (later) frails to wake me up!! What have they done with this update? It is crazy!

I had not observed this problem since my phone is set to network time and I rarely turn it off.

However I have just made the following experiment:

  • Activated Airplane mode (the phone has no external connection by whatever means)
  • Turned the phone off at 9.34 (T1)
  • Turned the phone on again at 11.39 (T2). After putting in the SIM code, the lock screen was showing a time of 09:34 (i.e. T1, the time at which I had turned it off) and the clock seems to be counting on from that.
  • A few minutes later at 11.50 (T3) I deactivated Airplane mode: network connections are re-established.
  • At 11.54 (T4) the clock has been automatically set to network time and is showing that time.

I can therefore confirm the problem as follows:
When the phone is turned off, the clock appears to be suspended, and when the phone is turned on again, the clock will resume at the time it was showing when the phone had been turned off.
If it is unable to re-set to network time, either because of a setting or because there is no network connection, it will continue to display a time which is behind the correct time, by a value corresponding to the duration of the period the phone had been turned off (T2 - T1).

I will file this “bug” with Fairphone support, though it’s possible I suppose that this is the designed behaviour, if we expect the phone to be completely inactive when it’s turned off.

3 Likes

I assume that you turn the phone off to avoid being disturbed and possibly to save battery. As a work-around, you might do the following, instead of turning the phone off:

  • Activate Airplane mode.
    This will prevent the phone from receiving signals from the various networks, so you’ll not be disturbed by calls, messages, e-mails etc.
    The phone will should use very little power.
    The phone will wake you up at the proper time you set for the alarm.

When you get up, deactivate Airplane mode.

2 Likes

OMG I hope this isn’t true. Even the oldest phones had battery-backed realtime clocks. This is usually a separate part that increments the clock when the main CPU is off. However, the OS is responsible for active reading of this value when it starts up and using it to update the system time. It seems to me most probably they either forgot to apply the value, or broke the RTC driver so that the OS cannot access the real-time clock.

3 Likes

Thanks, but this is not really satisfactory as already I sometimes have to re-charge the phone during the day to get through to the evening!

I look forward to a proper solution

David

I agree.
Note that I didn’t say “I suppose”, I said “it’s possible, I suppose …”
However I bear in mind that many phones don’t offer the luxury that we have, of easily removing the battery if we wish to completely deactivate the phone.
I’ve no idea what provisions are made in the FP4 regarding a dormant real-time clock, but in any case this is a software issue; we didn’t notice this behaviour before A12 and although my current habit is to leave the phone on, in the past I regularly turned it off at night without encountering this problem.

That shouldn’t be a problem.

  • The battery ‘shouldn’t’ be allowed to completely discharged. Charging it before it drops below 10% would be a sensible idea.

Well, while I was only suggesting a work-around, it seems strange to me if your phone is discharging more than two or three percent during the night in Airplane mode.
Given in addition, your frequent need to recharge during the day, you might want to check that you haven’t got some over-active app that’s running down your battery.

1 Like

Update from support came today:

Currently, the experts in our Software Team are investigating the issue and are liaising with the manufacturer to find the quickest possible solution.

2 Likes

Hello everyone,
Can someone tell me if there’s something I must do to solve this issue? I checked my time zone, checked the automatic setting of time. But when I turn off my cell for the night, in the morning, the clock is stuck
on the time when I turn off the cell!
I have an old HTC One, never once did this happened. Even if geolocalization is turned off.
Thanks for your replies.

This is a known bug brought with the Android 12 update. I’ve reported it to support and you should too.

As it worked with A11, it is apparent that hardware-wise, the phone is able to keep the clock counting even when the phone is off. They just broke the driver that should take time from the real-time clock and copy it to the system clock on boot.

3 Likes