English

Is it possible to upgrade a rooted FP2 without first unrooting it?

Thanks for your reply.
Well, I’ve tried to use again the original boot.img but the update failed anyway.

I do understand your reply, the thing is, at time being, I can not check if it’s applies to the Fairphone, since even on Android 5 the partial update did not work on the rooted system, we had to use to “full update file” to update the system.
With the last update from 17.04.3 to 17.04.8, this file is not available so I can not try the way I’ve done for months with FP 2 GMS verison 1.XX.YY.

I hope I’m clear… :blush:

Maybe a solution is to use TWRP to apply the minor update, maybe it will accept to update even on a rooted phone.

This might be exactly the reason why the full update file doesn’t exist. The problem with Android 6 and root is not just - as with Android 5 - that the incremental update doesn’t work, but that the app optimization process after the update will fail if the device is rooted/modified and therefore you’ll end up in a boot-loop.

I guess the only way it’s safe to release a full update file would be if that file automatically unmodifies the device first.

Well and sorry if the remark is silly, since I was able to to the update from Android 5 to Android 6 with a rooted phone without any problem whatsoever, the installation of android 6 does work from a rooted device as soon as the update is re-installing the full system (which was the case in the 17.04.3), I suppose I may do the same thing again from Android 6 to Android 6?

I know my case is quite specific but, I’ve done the update to 17.04.3 when it was public but no suppose to, otherwise I would have update from 1.13 to 17.04.8 and I guess, had no issue as I’ve had no issue from 1.13 (rooted and encrypted) to 17.04.3 (rooted and encrypted).
Thanks.

1 Like

Do you have any further information / sources about this? That does not seem plausible to me.

Fairphone will not release a full OTA for 17.04.8, but the binary images are available. Just flash them via fastboot. That’s what I did; worked like a charm. (No, you won’t loose any data.)

2 Likes

If I use the flash.bat, I will not lost my data?
Or/and which partitions do I need to flash with fastboot?

Correct. It won’t touch the data partition.

1 Like

My autobuild didn’t find anything, I hope FP devs won’t change their OTA-Server with every release in the future… :confused:

Anyway - available here.

I’m currently testing updating my phone with the img-files. Will report later if everything worked fine :wink:

Edit: Here is how I updated my rooted phone:

  • (Optional) Perform a backup with TWRP
  • Download “binary image” from here
  • Unpack it somewhere to your HDD.
  • For Linux: Edit flash.sh: Remove this:

sha256sum --status -c SHA256SUMS ||
{ echo “Checksums do not match. Not flashing.” ; exit 1 ; }

  • For Linux and Windows: Remove the last line (fastboot reboot)
  • Get fastboot running as described in Step 1 here
  • Go into bootloader (Press VOL- during start of your phone)
  • Run flash.sh/flash.bat
  • Do not reboot!
  • Flash rooted boot.img (get it e.g. from https://fp2.retsifp.de and use it only if it matches exactly the FPOS-Version you just installed!)
  • (Optional) Install XPosed Framework (Don’t forget that we have sdk23 now!)
  • Reboot
15 Likes

Thanks a lot.
It works perfectly!

One question: my encrypted phone does not ask anymore for my code before to start; it that normal?

Try setting a new screen lock password (you can use your existing one of course). If your phone is encrypted, you should be prompted whether to “Require password to start device”.

1 Like

Sorry for the question, im a beginner, but what does “Run flash.sh/flash.bat” mean? I stuck at that point. If I just doubleclick the flash.bat file it says that the fastboot command can’t be found.

Hi, you overlooked 2 lines above mentioned “Get fastboot running as described in Step 1 here”. It is a portion of Android developer tools.

With the mentioned activities you flash a new image which does not require the Google way which works only with regular, non-rooted devices and leaves you without root afterwards. If you have not missed being root before, you won’t need those extra steps.

2 Likes

hi amber, thank you for the answer! i didn’t skip the fastboot step. i really just dont know how to start the flashing process, i tried some different commands like “fastboot flashall c:\Users…\flash.bat” but nothing seemed to work. so i juat need help with getting the flash.bat running!
thank you in advance!

It’s because ADB is not fully installed/configured on your computer.
You have to look there for example: https://forum.xda-developers.com/showthread.php?t=1161776

thank you! ill try this later!

You are my hero! :slight_smile: Many THX!

2 Likes

Good to hear that it works with ADB and the binaries.

But how will it be possible to make the update process with TWRP only as we know it until now with <1.13.0?

Should we just wait, until the “autobuild” will find the correct file and then it is the same again?

The problem is, that the FP devs didn’t deliver a full OTA-Package yet (and I don’t think they will), only incremental images (which don’t work with rooted devices). I don’t know why.

I don’t think this will happen for 17.04.8, but maybe for the next version. Then yes, my autobuild-server only works with the full OTA packages.

I managed to install Android 6 and the rooted boot.img with fastboot now. I also have twrp recovery back, and now i wonde rif its possible to install gravitybox MM? Does someone have experiences?

Sure. Works fine. Don’t forget to use correct XPosed version (You’ll need sdk23 now). :wink:

Yeah, i noticed that :D, Thank you very much for your installation guide!

1 Like