English

Fairphone OS 17.05.2 (Android 6.0) is now available

I just upgraded to this new release and now I’m having wild ghost-touch issues. Not the slightly annoying kind, where it would jump all over the screen while touching/dragging something (I had those too, in the beginning). But the kind where it basically seems to trigger/react to random touch events, although I’m not even touching the screen. I think the FP1 used to have a similar problem? Unlocking my SIM was an adventure…
Any ideas as to why this might happen and how to fix it?

Oops, obviously I read your post too fast, sorry for that! :flushed:

There is no new information, although some of us would like to see Lineage OS officially supported by Fairphone…

Thanks for tyhe quick response,

There is no error message, the green robot just lays on his back and it
says error. I tried it yesterday twice and today, always the same response.

Regards,

Gerd

3 posts were split to a new topic: Why is FP Open OS behind FP OS?

Hi @Gerd
i have the same Problem with the Fairphone Update, ist completely impossible. Just dead Android after reboot (see my message above). No Error number, just “Error”.
Everything i Tried fails with Dead Android :frowning:
I tried several different installations nothing helps

  • Normal Install -> Dead Android
  • Advanced Mode -> Dead Andoid
  • Download full version (FP2-gms-17.05.2-ota-from-1.13.0.zip) -> Dead Android
  • Reinstall old Version (FP2-gms-17.04.8-ota-from-1.13.0.zip) -> Dead Andoid
    Clear Fairphone Updater Cache & Data -> Again Dead Andoid

As I am not willing to reset my phone to factory default (the Working setup with VPN and everything else took me more than one day)i will probably stick with my initial Marshmallow version. I used my old xperia mini pro 4 years without security updates so i can live with that but i am a bit disappointed. The update Problem starts with Android 6 (also had massive Problems there). I never had the Phone rooted and installed every Update since i got my Fairphone (one of the first 17418).
If Someone find a solution i will try again but i don’t have the time to spend so much hours to get my phone working. I just want to use it.
Greetings Heinz

There’s no need to do that.

Install it this way. You somehow modefied your /system or /boot, I don’t know how but it doesn’t care. :wink:

My lock screen message now displays correctly, thanks a lot :slight_smile:

2 Likes

Is there a reason why the update doesn’t include the latest Android Security Patch level? My phone says it is up to 1st May 2017 when the latest issue is 5th May 2017 which is what I have on another device.

From the respective Android Security Bulletin:

https://source.android.com/security/bulletin/2017-05-01

The announcements point out that “2017-05-01” is the string for the “Partial security patch level” while “2017-05-05” stands for the “Complete security patch level”. I do not know either why…

@Stefan mentioned here that security patches always come from Google in these two flavours.

Google explains this in the May 2017 Security Bulletin - Common Questions and Answers.

1 Like

But @Stefan also explains in his post that only the second patch level from Google contains all security patches. If Fairphone 2 is on “2017-05-01” and not “2017-05-05”, it would mean OS 17.05.2 does not contain the latest security patches.

@retsifp
Thanks a lot for your hint, the update worked like a charm (flashing the binary files). :smile:
No Data lost, everything like before :heart_eyes:
Flashed from manjaro linux

Greetings
Heinz

2 Likes

Is there a possibility to give my opinion about Fairphone OS 17.05.2, because I really liked the older version better… Or is there a way to go back?

What don’t you like about the update?

Mostly that the profiles for silence, vibration and sound have changed in what it is now… The rest is okay/good, but I really hate this feature, that I can’t have it on ‘vibration mode’ anymore…

There is a well written and informative article about that:

4 Likes

That is actually pretty helpful, thanks a bunch Gerry!

1 Like

Hello,

I can’t do the update. I just have a dead android with “error”. No number and I can’t do nothing. I have to unplug the battery to restar in the precedant version.
What does it mean? Why can’t I update?

Press Power and vol-up-button when you see robot to enter recovery menu and find more details about the error. (details regarding recovery mode you can find here: Dictionary Entry: Recovery Mode ).

To restart without unplugging battery: long press power (>12s).

1 Like

I followed instruction, and validate the update adb. It failed to.
E:Errorin/cache/fp_update_FP2-gms-17.17.05.7.zip (status 7)
Update aborded.

what am I supposed to do now?